Cannot boot from usb to install openSUSE Tumbleweed on T470s

Hi all,

I need your help to install openSUSE Tumbleweed on my just got T470s. It has Windows 10 preloaded with UEFI enabled. I want to use UEFI boot, with or without secure boot. The BIOS is updated to the latest 1.06 version.

I burned the ISO (snapshot 20170311) into a USB thumb drive, following 2 methods below with two different USB sticks. But none of them can make the laptop boot, with or without secure boot.

I have set in the BIOS to enable boot from USB. When I restart Windows 10, or press power button several seconds to complete poweroff the laptop then boot it, and then press F12 to choose a boot device, the USB device shows up. But when I select it and hit enter, the screen just splash back to the device list.

The burning methods I used,


umount /dev/sdb
dd if=ostw.iso of=/dev/sdb bs=4M status=progress;sync

Second, using SUSE Studio ImageWriter.

Any suggestion to install oSTW along with Win10 with UEFI enabled?

After hours of trying, I managed to use Rufus to create a bootable USB stick.

But some packages failed to install:


Rufus modifies the image be sure you use the dd option.

Either prior method should have worked. Personally I us cp /pathtoiso /dev/sdb. You want a binary copy of the iso to a device (not a partition on the device)

I’m not sure what went wrong there.

Make sure that you are using the 64-bit iso, not the 32-bit iso. While either should work, my understanding is that the 32-bit release is not as thoroughly tested as the 64-bit. Moreover, you have a UEFI system, and that needs 64-bit.

But when I select it and hit enter, the screen just splash back to the device list.

When I see that, it is typically because of a “secure-boot” issue. Try disabling secure-boot in your BIOS.

On my Lenovo Thinkserver, I don’t change the boot device in the BIOS. I just hit F12 during boot, and select the boot device there. When I first got that box, secure-boot did not work with opensuse install media. So I had to turn off secure-boot to install. After a BIOS update, that’s no longer an issue.

On 03/14/2017 09:06 AM, gogalthorp wrote:
> Rufus modifies the image be sure you use the dd option.
> Either prior method should have worked. Personally I us cp /pathtoiso
> /dev/sdb. You want a binary copy of the iso to a device (not a partition
> on the device)

Why not use SuSE Studio Writer? It works specifically with openSuSE ISO’s.

linux since 1994
S.u.S.E./openSUSE since 1996

That work ok too. as I said you need a unmodified binary copy of the iso to go to the device not a partition on a device how you accomplish this is up to you thee are lots of ways.

Sorry guys, I wish I could reply earlier but I seems not able to login to this forum today.

I thought the DD option was a sort of like the dd command and it failed me before, so I choose the first option (forgot the name). Maybe this is the reason that several packages failed to install. But the system booted successfully and I installed them later.

Yes, it’s weird. Like I stated in the first post, I tried both with and without “secure boot”. And I was definitely using 64-bit version.
In case anyone interests on this, “secure boot” works as I successfully installed oSTW later with it enabled.

Yes, I tried ImageWriter but failed.

I will try the cp method later so that if it works for me then I do not need a Windows in future :slight_smile:
And I’ll try to find out why the first two methods failed in my case.

Again, thank you all for your concern. I am writing on the new laptop with openSUSE Tumbleweed now but there are still several problems I could not solve. Hopefully someone could help me out. I’ll open several posts later.

Make sure that you disable the fast boot during the install and reboot processes.
I’ve been using ImageWriter for a long time.

What error messages did you get with it?

Thanks. I’ve tried with and without “fast boot” enabled. It seems have no influence on this. And during the last installation, which is successful, the boot is set to “fast boot”.

There is no error when using imagewriter, and during boot with the USB stick. The only symptom is that screen black for 1 second then returning back to boot device selection. I guess my problem is not with the methods, but something else. I’ll try to find out when I have time to test.

There can be two “fast boots” on some systems, one in the BIOS, the other in Windows. The one in Windows is usually the main headache, but should be turning both the BIOS & Windows fast boots off to be sure.

Yes, I have disabled fast boot in Windows 10. I forgot to mention this.

not sure from thread if you actually managed to ever boot from this usb stick - i have maybe 10 usb sticks, i have noted that 2 will never boot (bios wont recognise), so maybe try a different usb stick.

Thanks. I’ve managed to make one of the USB booted by using Rufus to burn the ISO into it. Havn’t try that on the other one, so I’m not sure. I am too busy this week to perform further tests to find out the reason. But yes, I have installed the OS already.

After some digging, I found the problem with my previous made USB sticks might be this:

  • There are two partitions.
  • The first one is about 4MB in size with a folder named EFI .
  • The 2nd one is in the size of the ISO.
  • The 2nd partition is not visible in Linux or Windows. (Maybe this is the reason the computer cannot boot from it.)
  • Both dd and imagewriter give me the same results.

But Rufus gives me only one partition. And the USB stick can boot the laptop for installation.

Anyone knows what is the problem?

As a reference, the command I used for dd is this (as root or console will remind me I have no permission to do this),

# cd /path/to/the/iso/
# umount /dev/sdb
# dd if=ostw.iso of=/dev/sdb bs=4M status=progress;sync

The USB stick is formatted previously in NTFS or FAT32 and has only ONE partition.

Are you booting the USB in EFI or legacy mode??

It is normal to have 2 partitions the EFI one is the EFI boot partition.

Note it should boot in either mode there also should be a MBR available for legacy boot. Also the device should use GPT partitioning after the copy.

I have only tried to boot the USB in EFI mode. When I used Rufus, it does provide an option to select support for both MBR and EFI. And I found only 1 partition in the USB after burning with Rufus.

But for dd and ImageWriter, I always get two partitions and cannot boot from the USB. Then, if it’s normal to have 2 partitions, what have I done incorrectly? I really want to know why my dd operation does not work and how to make it work.

Refus modifies the iso it is not to be trusted for most it simply does not work.

I use cp (or some use dd) and that has worked for many versions. When you do it makes a clean unmodified binary copy of the iso to the device.

In general if multi-booting then always use the same boot method for all OS installed. If you don’t you will have problems. I suspect that Rufus sets up a MBR boot since you must have a EFI boot partition to boot in EFI mode. If the installer is started in legacy mode the defaults will be set for MBR/legacy boot. You know you are in legacy if you see options along the bottom of the boot screen they are not there in EFI mode

Does that imply my system might have been compromised through the installation? Should I reinstall the system just in case?

I will definitely try this method later. I have forgotten about this when I did the test.

I think I am using EFI mode on this dual-boot system. And I was intend to install an EFI booted openSUSE Tumbleweed at the very beginning.

I am not sure whether the installation could be started in Legacy mode if the settings in BIOS say that it’s an EFI boot only system. What do you mean by “options along the bottom of the boot screen”. I do not know about this although I was always booting the system in Legacy mode before this one. Could you please describe it more specific?

If you don’t see any options along bottom of the install menu then you are in EFI mode. The installer should default to mounting the EFI boot partition as /boot/efi and not formatting it if it exists or formatting as FAT if it does not. And it should use grub2-efi not grub2 as boot program.

Not sure how Rufus works nobody around here uses it. But we have seen many fail to install when they do. But NO Linux install helpers are needed. Just be sure to copy to the device and not a partition on the device.

Did not mean to imply that Rufus is a bad program just that in the past it simply does not work with openSUSE. openSUSE ISO is a ready to boot image and needs no modification if copied to the device.

Your comment on Rufus is a relief to me. I just thought about reinstall my system :slight_smile:

Although Rufus might have a not-so-good history with openSUSE ISO, it saved me from failing of boot the USB to install openSUSE TW several days ago. But I do not want to use it in the future. If possible, I want to use dd, or cp as you suggested.

I am just curious of that why dd doesn’t work for me. It seems that dd should work in all case of burning an ISO into USB. I hope someone could help me finding out the reason and a proper way to use dd.

But I’ll try cp tomorrow when I have access to a high speed network to download the ISO.