Broken breeze dark icons in gtk applications on tumbleweed

Hello, gtk applications installed from opensuse repos seem to have broken breeze dark icons. Take a look at the provided screenshot please.

There is no difference between breeze-dark and breeze icon themes for the play, pause suspend symbols in virtual machine manager, but the tick mark next to accept is applying properly. Other icon themes seem to be applying fine as well like oxygen, just that some breeze-dark icons dont seem to be colored white.

I have had this install of tumbleweed from before kde 6, this issue popped up after the update from kde 5 and I hoped that it would be fixed in upcoming updates.

I just want to know if this is user error or a bug and any assistance is appreciated :slight_smile:

I’ve had this same issue like the one you having before, I had to change icons and/or themes, that fixed the problem, maybe you should try that, make sure you do a timeshift snapshot before starting tweaking your system just in case, good luck, cheers!

I havent really messed around with community themes. I have just applied the default dark theme. It looks like its just the breeze dark icons that are broken and that too only for gtk applications, as VLC uses the same icons and are applied properly.

I would appreciate it if you go into more details on how you managed to fix it, thanks!

This is a bug that isn’t going to be fixed, basically.

It’s GNOME/libadwaita’s fault.

Pretty much stuck, until either app developers ship their own internal icons, or the desktops other than GNOME develop a fallback when libadwaita doesn’t follow the FDO spec.

1 Like

I was afraid this was the case, thank you for letting me know. Cheers.

can you tell me what DE are you using? in my case I’m using tumbleweed plasma 5 and like I said by changing themes and some icons I was able to fix this issues, I can tell you want themes I had installed later when I get home, cheers!

1 Like

Yep im using plasma 6, thanks for going out of your way to help me!

1 Like

Ok, go to system settings/colors & themes/global themes and click on the “get new” icon on the upper right side of the menu and download the “Colorful-Dark-Global-6” theme, then when it is downloaded just apply that theme, make sure the “Appereance settings” and the “Desktop and windows layout” boxes are check marked both of them and hit the apply button, that should work with the icons issue on gtk applications like Gparted for example, it worked for me, I wish I can post pictures here to show you but I don’t think I can, I’ll try to upload a picture but I cannot promise anything, anyways I wish you good luck!



As you can see in the pictures, it works, before applying this theme, Gparted icons were almost invisible, now with this theme I have visible icons again, but keep in mind that not only this theme but other themes might work for you also!

Thanks a lot it seems to have fixed the issue. :smiley:

1 Like

You’re welcome, I’m glad I was able to help fix your issue, cheers!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.