Booting into Plasma w/Wayland default fails/drops to TTY

On two separate systems, setting Wayland as the default (when logging into Plasma) fails, instead landing me at TTY 6 (or 7, I can’t remember). At any rate, I have to login as root, issue the [startx] command, reset SSDM to default to X11, and then everything works. So, at least with two of my systems, Wayland and Plasma are dead on arrival. This has been going on for several months now. Anyone know why and has anyone else dealt with this? EDIT: If I login under X11, then logout, switch to Wayland, and log back in, then everything works. This is true on both my systems.

Host: Open Kernel: 6.1.10-1-default arch: x86_64 bits: 64
Desktop: KDE Plasma v: 5.26.5 Distro: openSUSE Tumbleweed 20230209

1 Like

No, we do not. You could a) describe step by step how you “set Wayland as the default” so someone could try to reproduce it and b) provide output of “journalctl -b” as root and “journalctl --user -b” as your user after this happens (log in as user on terminal). Upload logs to

//how you “set Wayland as the default”//

The usual way. This is set through the SDDM login manager. Settings—> Login and Shutdown—>Login Screen (SDDM)—> Behavior—>Automatically login with session: [Default, X11, Wayland, etc…]

//No, we do not.//

I’m sure others can speak for themselves. In the meantime, I’ll get a journal to you later today. Thanks.

The usual way on openSUSE is to use YaST (“usually” during installation).

Anyway - I configured auto-login via KDE. I cannot be sure I did the same as you because there is no Settings (it is “System Settings” here) nor “Login and Shutdown” (“Startup and Shutdown”) and you did not say which session you selected but using “Plasma (Wayland)” and rebooting worked and I verified that it actually started Wayland session. Which also reminded me why I disabled Wayland - because copy-paste does not work in KDE with Spice vdagent (it has explicit support for GNOME, but not for KDE).

This is in QEMU with spice/virgl. So it seems to work in general.

Yeah, not in my installation of Opensuse or YAST. There’s no option to switch from to Wayland in YAST—unless there’s some component I need to install.

Good to know that it works for you. That tells me there isn’t something intrinsically wrong with Wayland/Plasma. But it’s odd that both my systems would be afflicted by the same bug (which is what I think it is). I’m not sure how important it is, to me, to solve the problem at this time. There’s a slight convenience to using Plasma/Wayland (touchpad gestures) but not enough of a convenience to spend alot of time on it. But out of curiosity I googled “plasma wayland autologin fails” and it seems I’m not alone. Here for example (exactly the symptoms on both my systems):

Feh. I don’t know how much time I want to spend on this… I should probably at least post a journal… But maybe it would be quicker to just replace SDDM with LightDM and move on…

Oh, and now after more searching, this:

And this:

And a solution was offered by you, by the way…

Not needed. Just logout from your session, and then login to the session that you want. That should be remembered next time.

1 Like

This is broken on openSUSE if you are using YaST (or /etc/sysconfig/displaymanager) to configure auto-logon - SDDM will force X11 session. When going via System Settings it will add explicit Wayland session to /etc/sddm.conf.d, thus overriding openSUSE default.

Which solution? I just tried to clarify what was running - was it really Wayland or X11 session. The only “solution” mentioned in this topic by OP was to not use auto-login.

Nobody doubts that there is a problem. It is just that the root cause is unclear and so far no real troubleshooting was done. It sounds more like some race condition on startup which makes it even more difficult to debug.

Yeah, sorry. I thought it was you.

The bug seems to be unique to Opensuse, according to the other posts. I messaged the OP to better understand his solution. If you’re right that he only opted not to use auto-login, then it seems that the simplest solution is to use Lightdm.

I would be tempted to file a bug report but these can be time sinks and I’ve spent way too much time this past week on computer related issues (some self-inflicted). (Not including another bug report I filed related for a Kernel regression.) I’m trying to finish a novel. :slight_smile:

1 Like

I have the same bug and I am looking for a solution. Switching into Wayland works but neither restarting from Plasma Wayland nor booting into Wayland works.

1 Like

Hi Meisterolsen, this topic was carried on here:

The simplest workaround appears to be the installation of LightDM. The *.conf for LightDM is either not used in openSUSE or no longer a thing in general, so your options for configuring LightDM through configuration files is limited. Also, I wasn’t successful using YaST to configure LightDM. The simplest workaround to that is to 1.) install LightDM, 2.) choose LightDM as your default display manager 3.) Reboot 4.) Log out 5.) Set your preferred Display Server to Wayland, then log back in. This worked on my own system with autologin. :slight_smile: