Autologin with plasmawayland.desktop leads to black screen with cursor.

Hello! :slight_smile:

Since I had issues with screen tearing on X (had to do full window re-paints to get the tearing to stop - this only started recently…), I am trying out wayland, which appears to be production-ready.

I am running Tumbleweed, fully zypper duped.

At first, I tried the wayland session by logging out of the X plasma session (system default), then choosing “Plasma (Wayland)” in the sddm session selector, typing my password and thus starting plasma in wayland. This worked perfectly fine, so I thought I could set it as my standard-session for autologin.

In the System Settings, I had changed the Startup and Shutdown -> Login Screen (SDDM) -> Advanced -> Auto Login -> Session value from “(System Default)” to “Plasma (Wayland)”.
As I later had issues, I force-reinstalled sddm, blanked the /etc/sddm.conf and added for testing:


Before reinstalling sddm, I had additional sections which did not seem to matter - so here for completeness:




journalctl -b shows that sddm reads the .desktop file properly:

Dec 26 22:31:30 felinity sddm[1985]: Reading from "/usr/share/wayland-sessions/plasmawayland.desktop"
Dec 26 22:31:30 felinity sddm[1985]: Session "/usr/share/wayland-sessions/plasmawayland.desktop" selected, command: "dbus-run-session /usr/bin/startplasmacompositor"

The compositor is started:

Dec 26 22:31:30 felinity sddm-helper[3949]: Starting: "/usr/share/sddm/scripts/wayland-session dbus-run-session /usr/bin/startplasmacompositor"
Dec 26 22:31:30 felinity sddm[1985]: Session started

At this point, iirc I have X running (for sddm afaik) and I have wayland running, which should show my plasma session.
Instead, however, wayland displays a black screen.
If once I hit Ctrl+Alt+F1(or F2-F6) and back to Ctrl+Alt+F7, then a default cursor is added to the previously visible black screen, but nothing more happens. There is no plasma shell, no windows, no background, and no reaction to clicks.

However, I can log into etc tty2 with my username and manually run dbus-run-session /usr/bin/startplasmacompositor.
This causes a perfect and fully-functional plasma desktop to start up within wayland.

So why can I start a plasma wayland session from sddm (via logout from X → change session in sddm → login again), and also from the terminal (startplasmacompositor) – but only for autologin it does not work? Is there any race condition? What is happening / what is missing? It looks like the compositor is starting just fine, but kwin & plasma are missing.

Side Note: when /etc/sddm.conf is entirely blank, then an autologin is done into an X session just fine. Only for wayland I could not find any way to make it work.

Thank you so much for your help!

– Labyrinth

1 Like

I’m not sure how you set that up. It’s a mistake to use “sddm.conf” for autologin.

I don’t normally use autologin. But I just tested. So I set to use “autologin” using “/etc/sysconfig/displaymanager” – you can set that with Yast (the “/etc/sysconfig” editor).

I tested, and logged into Plasma.

Then I logged out, and logged into Plasma/Wayland.

I rebooted. And it remembered that my last login was for Plasma/Wayland, so I was auto-logged into that.

It seems to work just fine. And “/etc/sddm.conf” is empty.

Now I’ll go turn off autologin.

I take that back. My tests were wrong.

I had been using GDM as displaymanager, and it worked as I described it.

So, for a better test, I switched to SDDM. And autologin took me to an X session. It did not login to Plasma/Wayland.

I then tested with “lightdm”. And it does work there.

My suggestion: Switch to “lightdm”. First make sure that “lightdm” is installed. Then, to switch:

update-alternatives --config default-displaymanager

and select “lightdm”. You have to be root for that command.

Then, on reboot, logout if needed and login again with Plasma-wayland. And it should remember that.

1 Like

Danke nrickert!

Ich suche noch nach einem Weg, weiter sddm zu benutzen.

Bin aber auf einiges gestoßen, wo ich mal Frühjahrsputz machen müsste: Viel zu viele *.rpmnew in meinem /etc…
Vielleicht löst sich das Problem im Verlaufe der Säuberungsarbeiten noch selbst. Ich melde mich notfalls wieder.

Bis dahin herzlichen Dank! <3

On your behalf:

Thank you!

I’m still looking for a way to continue to use sddm.

But I came across some, where I would have to do some spring cleaning: way too many * .rpmnew in my / etc …
Maybe the problem will be solved in the course of the cleaning work itself. If necessary I will contact you again.

Thank you so much! <3

1 Like

Thanks for the translation, though I got the gist anyway.

Oh my! I must have very much mentally absent! mD

Thank you @kerijan2003! Very kind and woke of you :slight_smile:

And sorry @nrickert! :smiley: Don’t know how that happened…