Bold within PRE not happening

What’s the secret to bolding text contained within PRE tags? It was no big deal before the migration. Asterisks, [b] & <b> and selecting text then clicking B all result in literals.

Don’t click B: Discourse BBCode - plugin - Discourse Meta

1 Like

Where is this place I’m supposed to not click?

The place is in the linked page, presumably button “Feature”,

Yes. And I already have seen users trying to execute command ip **eth0** after copying bold text.

Anyway - here is bold preformatted text.

Clear as mud. How is that supposed to work when I want to bold several places in a dozen or more lines of command output pasted? Before I could swipe the applicable text and click the bolding icon. All that does now is insert asterisk pairs in the pasted output that show up as asterisks in the submission. Why can’t b or i or code and appropriate /s between <> or [] just mean bold like they used to?

The fact you provided a link was hidden here until after your response and I thought to hover your text.

I’m still lost. All I see there suggests [b] and [code] without any “plugins” should work just like they used to. It looks like the plugin is something the admins either enable or not, and they enabled it, and it makes complicated understanding how to input what used to be simple to understand. I don’t see anything in my own preferences about enabling any kind of “plugins” or not.

The Reload Button of the browser helps.

As I understand they will improve the very basic implementation of BBC upon user request.

Because preformatted text means exactly that - preformatted. It does not mean “take some arbitrary parts of text and format them once more”. In any case, you are barking up the wrong tree. Complain to developers of markdown or - if you have reasons to think that discourse implementation is wrong - to developers of discourse.

You have enough ways to format text including HTML tags.


Brain fart. I wrote PRE when I meant CODE, and there’s no icon for CODE above the input window to remind, unlike for Blockquote or PRE or Bold or Italic.

So, the thread topic should have indicated the problem is ultimately that there is no icon for CODE!

So, I tried some experimenting here but it looks like a number of formatting tags simply aren’t supported.

For example:

[size=10]The Size Tag is not supported.[/size]
[color=green]Color Tags[/color]
[color=00ff00]are also[/color]
[color=#00ff00]not supported.[/color]

Hello. Guess what else isn’t supported. :wink:

What a weird way to spec "Code" formatted text. Oh well...

Markdown doesn’t support color…

But is should support for example bash;

echo "add ```bash"

Or yaml…

variant: fcos
version: 1.0.0
1 Like

Well, I guess the point I’m getting at is I literally tried out the things the Discourse support page linked to above demonstrated and said were a part of the Discourse plugin or code or whatever, yet those basic things don’t actually work here on this Discourse-based message board. So I’m really left scratching my head. Does that mean this message board’s maintainers have somehow deliberately nerfed Discourse’s feature set? That really doesn’t make any sense to me.

No, the BBCODE plugin is not installed… give it a few more weeks, then can start looking at these features.


Are you sure? Installing plugins is straight forward: Install Plugins in Discourse - sysadmin - Discourse Meta