Atleast 20 vlc conflicts in latest dup

this seems ti have been a problem before but after resolving to install the versions from opensuse it is asking to uninstall VLC, could I please have some guidance?

*******@localhost:~> sudo zypper dup
Loading repository data...
Reading installed packages...
Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
Computing distribution upgrade...
4 Problems:
Problem: 1: the to be installed phonon-vlc-qt6-0.12.0-2.3.x86_64 requires 'vlc = 3.0.21', but this requirement cannot be provided
not installable providers: vlc-3.0.21-1.1.x86_64[https-download.opensuse.org-b44f06ae]
                   vlc-3.0.21-1.1.x86_64[repo-oss]

Problem: 2: the to be installed vlc-codec-fluidsynth-3.0.21-1.1.x86_64 requires 'vlc-noX = 3.0.21', but this requirement cannot be provided
not installable providers: vlc-noX-3.0.21-1.1.x86_64[https-download.opensuse.org-b44f06ae]
                   vlc-noX-3.0.21-1.1.x86_64[repo-oss]

Problem: 3: the to be installed phonon-vlc-qt5-0.12.0-2.3.x86_64 requires 'vlc-noX = 3.0.21', but this requirement cannot be provided
not installable providers: vlc-noX-3.0.21-1.1.x86_64[https-download.opensuse.org-b44f06ae]
                   vlc-noX-3.0.21-1.1.x86_64[repo-oss]

Problem: 4: the to be installed tlp-1.6.1-2.1.noarch conflicts with 'tuned' provided by the installed tuned-2.22.1.2+git.86ac977-3.1.noarch

Problem: 1: the to be installed phonon-vlc-qt6-0.12.0-2.3.x86_64 requires 'vlc = 3.0.21', but this requirement cannot be provided
not installable providers: vlc-3.0.21-1.1.x86_64[https-download.opensuse.org-b44f06ae]
                   vlc-3.0.21-1.1.x86_64[repo-oss]

 Solution 1: deinstallation of phonon-vlc-qt6-0.12.0-2.2.x86_64
 Solution 2: install vlc-3.0.21-1.1.x86_64 from vendor openSUSE
  replacing vlc-3.0.20-1699.10.pm.2.x86_64 from vendor http://packman.links2linux.de
 Solution 3: keep obsolete phonon-vlc-qt6-0.12.0-2.2.x86_64
 Solution 4: break phonon-vlc-qt6-0.12.0-2.3.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/3/4/s/r/c/d/?] (c): 
2 Likes

…

Regarding tlp/tuned you can do the forum search yourself. Uninstall one of the packages…

You have to select the option which installs from openSUSE instead of packman for each error. Packman has not yet caught up with the latest in this area.

Stuart

what about this one?

Problem: 4: the installed vlc-noX-3.0.20-1699.10.pm.2.x86_64 requires 'libvlccore9 = 3.0.20-1699.10.pm.2', but this requirement cannot be provided
deleted providers: libvlccore9-3.0.20-1699.10.pm.2.x86_64

 Solution 1: Following actions will be done:
  do not install vlc-3.0.21-1.1.x86_64
  do not install libvlccore9-3.0.21-1.1.x86_64
 Solution 2: deinstallation of vlc-codecs-3.0.20-1699.10.pm.2.x86_64
 Solution 3: do not install libvlccore9-3.0.21-1.1.x86_64
 Solution 4: break vlc-noX-3.0.20-1699.10.pm.2.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/3/4/s/r/c/d/?] (c): 

full text:

localhost:~> sudo zypper dup
[sudo] password for root: 
Loading repository data...
Reading installed packages...
Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
Computing distribution upgrade...
4 Problems:
Problem: 1: the to be installed phonon-vlc-qt6-0.12.0-2.3.x86_64 requires 'vlc = 3.0.21', but this requirement cannot be provided
not installable providers: vlc-3.0.21-1.1.x86_64[https-download.opensuse.org-b44f06ae]
                   vlc-3.0.21-1.1.x86_64[repo-oss]

Problem: 2: the to be installed vlc-codec-fluidsynth-3.0.21-1.1.x86_64 requires 'vlc-noX = 3.0.21', but this requirement cannot be provided
not installable providers: vlc-noX-3.0.21-1.1.x86_64[https-download.opensuse.org-b44f06ae]
                   vlc-noX-3.0.21-1.1.x86_64[repo-oss]

Problem: 3: the to be installed phonon-vlc-qt5-0.12.0-2.3.x86_64 requires 'vlc-noX = 3.0.21', but this requirement cannot be provided
not installable providers: vlc-noX-3.0.21-1.1.x86_64[https-download.opensuse.org-b44f06ae]
                   vlc-noX-3.0.21-1.1.x86_64[repo-oss]

Problem: 4: the to be installed tlp-1.6.1-2.1.noarch conflicts with 'tuned' provided by the installed tuned-2.22.1.2+git.86ac977-3.1.noarch

Problem: 1: the to be installed phonon-vlc-qt6-0.12.0-2.3.x86_64 requires 'vlc = 3.0.21', but this requirement cannot be provided
not installable providers: vlc-3.0.21-1.1.x86_64[https-download.opensuse.org-b44f06ae]
                   vlc-3.0.21-1.1.x86_64[repo-oss]

 Solution 1: deinstallation of phonon-vlc-qt6-0.12.0-2.2.x86_64
 Solution 2: install vlc-3.0.21-1.1.x86_64 from vendor openSUSE
  replacing vlc-3.0.20-1699.10.pm.2.x86_64 from vendor http://packman.links2linux.de
 Solution 3: keep obsolete phonon-vlc-qt6-0.12.0-2.2.x86_64
 Solution 4: break phonon-vlc-qt6-0.12.0-2.3.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/3/4/s/r/c/d/?] (c): 1 

Problem: 2: the to be installed vlc-codec-fluidsynth-3.0.21-1.1.x86_64 requires 'vlc-noX = 3.0.21', but this requirement cannot be provided
not installable providers: vlc-noX-3.0.21-1.1.x86_64[https-download.opensuse.org-b44f06ae]
                   vlc-noX-3.0.21-1.1.x86_64[repo-oss]

 Solution 1: install vlc-codec-fluidsynth-3.0.20-1699.11.pm.19.x86_64 from vendor http://packman.links2linux.de
  replacing vlc-codec-fluidsynth-3.0.20-7.1.x86_64 from vendor openSUSE
 Solution 2: install vlc-noX-3.0.21-1.1.x86_64 from vendor openSUSE
  replacing vlc-noX-3.0.20-1699.10.pm.2.x86_64 from vendor http://packman.links2linux.de
 Solution 3: keep obsolete vlc-codec-fluidsynth-3.0.20-7.1.x86_64
 Solution 4: break vlc-codec-fluidsynth-3.0.21-1.1.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/3/4/s/r/c/d/?] (c): 2

Problem: 3: the to be installed phonon-vlc-qt5-0.12.0-2.3.x86_64 requires 'vlc-noX = 3.0.21', but this requirement cannot be provided
not installable providers: vlc-noX-3.0.21-1.1.x86_64[https-download.opensuse.org-b44f06ae]
                   vlc-noX-3.0.21-1.1.x86_64[repo-oss]

 Solution 1: install libvlc5-3.0.21-1.1.x86_64 from vendor openSUSE
  replacing libvlc5-3.0.20-1699.10.pm.2.x86_64 from vendor http://packman.links2linux.de
 Solution 2: deinstallation of phonon-vlc-qt5-0.12.0-2.2.x86_64
 Solution 3: keep obsolete phonon-vlc-qt5-0.12.0-2.2.x86_64
 Solution 4: break phonon-vlc-qt5-0.12.0-2.3.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/3/4/s/r/c/d/?] (c): 1

Problem: 4: the to be installed tlp-1.6.1-2.1.noarch conflicts with 'tuned' provided by the installed tuned-2.22.1.2+git.86ac977-3.1.noarch
 Solution 1: deinstallation of tlp-1.6.1-1.3.noarch
 Solution 2: deinstallation of tuned-2.22.1.2+git.86ac977-3.1.noarch
 Solution 3: keep obsolete tlp-1.6.1-1.3.noarch

Choose from above solutions by number or skip, retry or cancel [1/2/3/s/r/c/d/?] (c): 2

Resolving dependencies...
Computing distribution upgrade...
4 Problems:
Problem: 1: the to be installed vlc-qt-3.0.20-1699.11.pm.19.x86_64 requires 'vlc-noX = 3.0.20-1699.11.pm.19', but this requirement cannot be provided
not installable providers: vlc-noX-3.0.20-1699.11.pm.19.i586[packman]
                   vlc-noX-3.0.20-1699.11.pm.19.x86_64[packman]

Problem: 2: the to be installed vlc-3.0.20-1699.11.pm.19.x86_64 requires 'vlc-noX = 3.0.20-1699.11.pm.19', but this requirement cannot be provided
not installable providers: vlc-noX-3.0.20-1699.11.pm.19.i586[packman]
                   vlc-noX-3.0.20-1699.11.pm.19.x86_64[packman]

Problem: 3: the to be installed vlc-codec-fluidsynth-3.0.21-1.1.x86_64 requires 'vlc-noX = 3.0.21', but this requirement cannot be provided
not installable providers: vlc-noX-3.0.21-1.1.x86_64[https-download.opensuse.org-b44f06ae]
                   vlc-noX-3.0.21-1.1.x86_64[repo-oss]

Problem: 4: the installed vlc-noX-3.0.20-1699.10.pm.2.x86_64 requires 'libvlc5 = 3.0.20-1699.10.pm.2', but this requirement cannot be provided
deleted providers: libvlc5-3.0.20-1699.10.pm.2.x86_64


Problem: 1: the to be installed vlc-qt-3.0.20-1699.11.pm.19.x86_64 requires 'vlc-noX = 3.0.20-1699.11.pm.19', but this requirement cannot be provided
not installable providers: vlc-noX-3.0.20-1699.11.pm.19.i586[packman]
                   vlc-noX-3.0.20-1699.11.pm.19.x86_64[packman]

 Solution 1: install vlc-qt-3.0.21-1.1.x86_64 from vendor openSUSE
  replacing vlc-qt-3.0.20-1699.10.pm.2.x86_64 from vendor http://packman.links2linux.de
 Solution 2: do not install vlc-noX-3.0.21-1.1.x86_64
 Solution 3: break vlc-qt-3.0.20-1699.11.pm.19.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/3/s/r/c/d/?] (c): 1

Problem: 2: the to be installed vlc-3.0.20-1699.11.pm.19.x86_64 requires 'vlc-noX = 3.0.20-1699.11.pm.19', but this requirement cannot be provided
not installable providers: vlc-noX-3.0.20-1699.11.pm.19.i586[packman]
                   vlc-noX-3.0.20-1699.11.pm.19.x86_64[packman]

 Solution 1: install vlc-3.0.21-1.1.x86_64 from vendor openSUSE
  replacing vlc-3.0.20-1699.10.pm.2.x86_64 from vendor http://packman.links2linux.de
 Solution 2: do not install libvlc5-3.0.21-1.1.x86_64
 Solution 3: break vlc-3.0.20-1699.11.pm.19.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/3/s/r/c/d/?] (c): 1

Problem: 3: the to be installed vlc-codec-fluidsynth-3.0.21-1.1.x86_64 requires 'vlc-noX = 3.0.21', but this requirement cannot be provided
not installable providers: vlc-noX-3.0.21-1.1.x86_64[https-download.opensuse.org-b44f06ae]
                   vlc-noX-3.0.21-1.1.x86_64[repo-oss]

 Solution 1: install libvlccore9-3.0.21-1.1.x86_64 from vendor openSUSE
  replacing libvlccore9-3.0.20-1699.10.pm.2.x86_64 from vendor http://packman.links2linux.de
 Solution 2: install vlc-codec-fluidsynth-3.0.20-1699.11.pm.19.x86_64 from vendor http://packman.links2linux.de
  replacing vlc-codec-fluidsynth-3.0.20-7.1.x86_64 from vendor openSUSE
 Solution 3: keep obsolete vlc-codec-fluidsynth-3.0.20-7.1.x86_64
 Solution 4: break vlc-codec-fluidsynth-3.0.21-1.1.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/3/4/s/r/c/d/?] (c): 1

Problem: 4: the installed vlc-noX-3.0.20-1699.10.pm.2.x86_64 requires 'libvlc5 = 3.0.20-1699.10.pm.2', but this requirement cannot be provided
deleted providers: libvlc5-3.0.20-1699.10.pm.2.x86_64

 Solution 1: deinstallation of phonon-vlc-qt5-0.12.0-2.2.x86_64
 Solution 2: deinstallation of vlc-codecs-3.0.20-1699.10.pm.2.x86_64
 Solution 3: keep obsolete phonon-vlc-qt5-0.12.0-2.2.x86_64
 Solution 4: break vlc-noX-3.0.20-1699.10.pm.2.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/3/4/s/r/c/d/?] (c): 1

Resolving dependencies...
Computing distribution upgrade...
5 Problems:
Problem: 1: the to be installed phonon-vlc-lang-0.12.0-2.3.noarch requires '(phonon-vlc-qt5 or phonon-vlc-qt6)', but this requirement cannot be provided
deleted providers: phonon-vlc-qt5-0.12.0-2.2.x86_64
                   phonon-vlc-qt6-0.12.0-2.2.x86_64
not installable providers: phonon-vlc-qt5-0.12.0-2.3.x86_64[https-download.opensuse.org-b44f06ae]
                   phonon-vlc-qt6-0.12.0-2.3.x86_64[https-download.opensuse.org-b44f06ae]
                   phonon-vlc-qt5-0.12.0-2.3.x86_64[repo-oss]
                   phonon-vlc-qt6-0.12.0-2.3.x86_64[repo-oss]

Problem: 2: the to be installed vlc-vdpau-3.0.20-1699.11.pm.19.x86_64 requires 'vlc-noX = 3.0.20', but this requirement cannot be provided
deleted providers: vlc-noX-3.0.20-1699.10.pm.2.x86_64
not installable providers: vlc-noX-3.0.20-1699.11.pm.19.i586[packman]
                   vlc-noX-3.0.20-1699.11.pm.19.x86_64[packman]

Problem: 3: the installed vlc-noX-3.0.20-1699.10.pm.2.x86_64 requires 'libvlc5 = 3.0.20-1699.10.pm.2', but this requirement cannot be provided
deleted providers: libvlc5-3.0.20-1699.10.pm.2.x86_64

Problem: 4: the installed vlc-noX-3.0.20-1699.10.pm.2.x86_64 requires 'libvlccore9 = 3.0.20-1699.10.pm.2', but this requirement cannot be provided
deleted providers: libvlccore9-3.0.20-1699.10.pm.2.x86_64

Problem: 5: the to be installed vlc-qt-3.0.21-1.1.x86_64 requires 'vlc-noX = 3.0.21-1.1', but this requirement cannot be provided
not installable providers: vlc-noX-3.0.21-1.1.x86_64[https-download.opensuse.org-b44f06ae]
                   vlc-noX-3.0.21-1.1.x86_64[repo-oss]


Problem: 1: the to be installed phonon-vlc-lang-0.12.0-2.3.noarch requires '(phonon-vlc-qt5 or phonon-vlc-qt6)', but this requirement cannot be provided
deleted providers: phonon-vlc-qt5-0.12.0-2.2.x86_64
                   phonon-vlc-qt6-0.12.0-2.2.x86_64
not installable providers: phonon-vlc-qt5-0.12.0-2.3.x86_64[https-download.opensuse.org-b44f06ae]
                   phonon-vlc-qt6-0.12.0-2.3.x86_64[https-download.opensuse.org-b44f06ae]
                   phonon-vlc-qt5-0.12.0-2.3.x86_64[repo-oss]
                   phonon-vlc-qt6-0.12.0-2.3.x86_64[repo-oss]

 Solution 1: deinstallation of phonon-vlc-lang-0.12.0-2.2.noarch
 Solution 2: keep phonon-vlc-qt6-0.12.0-2.2.x86_64
 Solution 3: keep phonon-vlc-qt5-0.12.0-2.2.x86_64
 Solution 4: break phonon-vlc-lang-0.12.0-2.3.noarch by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/3/4/s/r/c/d/?] (c): 1

Problem: 2: the to be installed vlc-vdpau-3.0.20-1699.11.pm.19.x86_64 requires 'vlc-noX = 3.0.20', but this requirement cannot be provided
deleted providers: vlc-noX-3.0.20-1699.10.pm.2.x86_64
not installable providers: vlc-noX-3.0.20-1699.11.pm.19.i586[packman]
                   vlc-noX-3.0.20-1699.11.pm.19.x86_64[packman]

 Solution 1: Following actions will be done:
  do not install vlc-3.0.21-1.1.x86_64
  do not install vlc-noX-3.0.21-1.1.x86_64
 Solution 2: install vlc-vdpau-3.0.21-1.1.x86_64 from vendor openSUSE
  replacing vlc-vdpau-3.0.20-1699.10.pm.2.x86_64 from vendor http://packman.links2linux.de
 Solution 3: do not install vlc-noX-3.0.21-1.1.x86_64
 Solution 4: break vlc-vdpau-3.0.20-1699.11.pm.19.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/3/4/s/r/c/d/?] (c): 2

Problem: 3: the installed vlc-noX-3.0.20-1699.10.pm.2.x86_64 requires 'libvlc5 = 3.0.20-1699.10.pm.2', but this requirement cannot be provided
deleted providers: libvlc5-3.0.20-1699.10.pm.2.x86_64

 Solution 1: Following actions will be done:
  do not install vlc-3.0.21-1.1.x86_64
  do not install libvlc5-3.0.21-1.1.x86_64
 Solution 2: install vlc-codec-gstreamer-3.0.21-1.1.x86_64 from vendor openSUSE
  replacing vlc-codec-gstreamer-3.0.20-1699.10.pm.2.x86_64 from vendor http://packman.links2linux.de
 Solution 3: do not install libvlc5-3.0.21-1.1.x86_64
 Solution 4: break vlc-noX-3.0.20-1699.10.pm.2.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/3/4/s/r/c/d/?] (c): 2

Problem: 4: the installed vlc-noX-3.0.20-1699.10.pm.2.x86_64 requires 'libvlccore9 = 3.0.20-1699.10.pm.2', but this requirement cannot be provided
deleted providers: libvlccore9-3.0.20-1699.10.pm.2.x86_64

 Solution 1: Following actions will be done:
  do not install vlc-3.0.21-1.1.x86_64
  do not install libvlccore9-3.0.21-1.1.x86_64
 Solution 2: deinstallation of vlc-codecs-3.0.20-1699.10.pm.2.x86_64
 Solution 3: do not install libvlccore9-3.0.21-1.1.x86_64
 Solution 4: break vlc-noX-3.0.20-1699.10.pm.2.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/3/4/s/r/c/d/?] (c): 
1 Like

Until packman gets an actual package…

1 Like

Et al. It’s a packman Project Config issue, until that’s resolved it won’t build…

I dont want to break VLC on this system, would it be best to just wait?

You either wait and have a vulnerable system (security issues in VLC 3.0.20) or you switch back to the actual openSUSE package 3.0.21 (fixed security issue) by uninstalling vlc-codecs…your decission.
Packman users needs to make decissions.

1 Like

@40476 probably, but when the fix will happen, no ETA…

1 Like

Similar issue over here on my end. For each conflict I selected to swap the Packman packages for OpenSuse ones. Unfortunately, I found that when swapped the Mesa-Gallium ones, they broke my Nvidia drivers.

So, it looks like it’s time for another episode of sit back and wait until a future update to resolve things.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.