Conflicts of python-lsp-server with pycodestyle and missing python-lsp-server >= 1.4

I get the following conflict when I run zypper dup:

$ sudo zypper dup
Loading repository data...
Reading installed packages...
Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
Computing distribution upgrade...
4 Problems:
Problem: 1: the installed python311-python-lsp-server-1.11.0-1.1.noarch conflicts with 'python3-pycodestyle >= 2.12.0' provided by the to be installed python311-pycodestyle-2.12.0-1.1.noarch
Problem: 2: the to be installed phonon-vlc-qt5-0.12.0-2.3.x86_64 requires 'vlc = 3.0.21', but this requirement cannot be provided
not installable providers: vlc-3.0.21-2.1.x86_64[download.opensuse.org-oss]

Problem: 3: the to be installed phonon-vlc-qt6-0.12.0-2.3.x86_64 requires 'vlc-noX = 3.0.21', but this requirement cannot be provided
not installable providers: vlc-noX-3.0.21-2.1.x86_64[download.opensuse.org-oss]

Problem: 4: the installed python311-python-lsp-black-2.0.0-3.2.noarch requires 'python311-python-lsp-server >= 1.4', but this requirement cannot be provided

Problem: 1: the installed python311-python-lsp-server-1.11.0-1.1.noarch conflicts with 'python3-pycodestyle >= 2.12.0' provided by the to be installed python311-pycodestyle-2.12.0-1.1.noarch
 Solution 1: Following actions will be done:
  deinstallation of python311-pycodestyle-2.11.1-1.5.noarch
  deinstallation of python311-autopep8-2.0.4-3.3.noarch
 Solution 2: deinstallation of python311-python-lsp-server-1.11.0-1.1.noarch
 Solution 3: keep obsolete python311-pycodestyle-2.11.1-1.5.noarch

Choose from above solutions by number or skip, retry or cancel [1/2/3/s/r/c/d/?] (c):

I’ve read the posts regarding the phonon-vlc conflict (Atleast 20 vlc conflicts in latest dup - #2 by hui), but I’m unsure what option I should pick for the pycodestyle conflict and the missing python-lsp-server >= 1.4.

Thank you for your help! :slight_smile:

@LLiebermann Hi, select Solution 1…python311-pycodestyle-2.11 is now 2.12. Perhaps 2.12 takes care of autopep8-2.0.4

You can always use the dry run option (-D), it will go through the motions, but nothing will be done… zypper -vvv dup -D

@malcolmlewis Thank you for you for your answer and the advice about the dry run option. Can you also give me advice on what to do about the missing 'python311-python-lsp-server >= 1.4'?

Here is the output of my zypper dup:

$ su - -c 'zypper dup -dD'
Password: 
Loading repository data...
Reading installed packages...
Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
Computing distribution upgrade...
4 Problems:
Problem: 1: the installed python311-python-lsp-server-1.11.0-1.1.noarch conflicts with 'python3-pycodestyle >= 2.12.0' provided by the to be installed python311-pycodestyle-2.12.0-1.1.noarch
Problem: 2: the to be installed phonon-vlc-qt5-0.12.0-2.3.x86_64 requires 'vlc = 3.0.21', but this requirement cannot be provided
not installable providers: vlc-3.0.21-2.1.x86_64[download.opensuse.org-oss]

Problem: 3: the to be installed phonon-vlc-qt6-0.12.0-2.3.x86_64 requires 'vlc-noX = 3.0.21', but this requirement cannot be provided
not installable providers: vlc-noX-3.0.21-2.1.x86_64[download.opensuse.org-oss]

Problem: 4: the installed python311-python-lsp-black-2.0.0-3.2.noarch requires 'python311-python-lsp-server >= 1.4', but this requirement cannot be provided

Problem: 1: the installed python311-python-lsp-server-1.11.0-1.1.noarch conflicts with 'python3-pycodestyle >= 2.12.0' provided by the to be installed python311-pycodestyle-2.12.0-1.1.noarch
 Solution 1: Following actions will be done:
  deinstallation of python311-pycodestyle-2.11.1-1.5.noarch
  deinstallation of python311-autopep8-2.0.4-3.3.noarch
 Solution 2: deinstallation of python311-python-lsp-server-1.11.0-1.1.noarch
 Solution 3: keep obsolete python311-pycodestyle-2.11.1-1.5.noarch

Choose from above solutions by number or skip, retry or cancel [1/2/3/s/r/c/d/?] (c): 1

Problem: 2: the to be installed phonon-vlc-qt5-0.12.0-2.3.x86_64 requires 'vlc = 3.0.21', but this requirement cannot be provided
not installable providers: vlc-3.0.21-2.1.x86_64[download.opensuse.org-oss]

 Solution 1: Following actions will be done:
  install vlc-3.0.21-2.1.x86_64 from vendor openSUSE
    replacing vlc-3.0.20-1699.11.pm.19.x86_64 from vendor http://packman.links2linux.de
  install vlc-qt-3.0.21-2.1.x86_64 from vendor openSUSE
    replacing vlc-qt-3.0.20-1699.11.pm.19.x86_64 from vendor http://packman.links2linux.de
  install vlc-vdpau-3.0.21-2.1.x86_64 from vendor openSUSE
    replacing vlc-vdpau-3.0.20-1699.11.pm.19.x86_64 from vendor http://packman.links2linux.de
  install vlc-codec-gstreamer-3.0.21-2.1.x86_64 from vendor openSUSE
    replacing vlc-codec-gstreamer-3.0.20-1699.11.pm.19.x86_64 from vendor http://packman.links2linux.de
  install vlc-lang-3.0.21-2.1.noarch from vendor openSUSE
    replacing vlc-lang-3.0.20-1699.11.pm.19.noarch from vendor http://packman.links2linux.de
  install libvlc5-3.0.21-2.1.x86_64 from vendor openSUSE
    replacing libvlc5-3.0.20-1699.11.pm.19.x86_64 from vendor http://packman.links2linux.de
  install libvlccore9-3.0.21-2.1.x86_64 from vendor openSUSE
    replacing libvlccore9-3.0.20-1699.11.pm.19.x86_64 from vendor http://packman.links2linux.de
 Solution 2: deinstallation of phonon-vlc-qt5-0.12.0-2.2.x86_64
 Solution 3: keep obsolete phonon-vlc-qt5-0.12.0-2.2.x86_64
 Solution 4: break phonon-vlc-qt5-0.12.0-2.3.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/3/4/s/r/c/d/?] (c): 1

Problem: 3: the to be installed phonon-vlc-qt6-0.12.0-2.3.x86_64 requires 'vlc-noX = 3.0.21', but this requirement cannot be provided
not installable providers: vlc-noX-3.0.21-2.1.x86_64[download.opensuse.org-oss]

 Solution 1: Following actions will be done:
  install vlc-noX-3.0.21-2.1.x86_64 from vendor openSUSE
    replacing vlc-noX-3.0.20-1699.11.pm.19.x86_64 from vendor http://packman.links2linux.de
  install vlc-qt-3.0.21-2.1.x86_64 from vendor openSUSE
    replacing vlc-qt-3.0.20-1699.11.pm.19.x86_64 from vendor http://packman.links2linux.de
  install vlc-vdpau-3.0.21-2.1.x86_64 from vendor openSUSE
    replacing vlc-vdpau-3.0.20-1699.11.pm.19.x86_64 from vendor http://packman.links2linux.de
  install vlc-codec-gstreamer-3.0.21-2.1.x86_64 from vendor openSUSE
    replacing vlc-codec-gstreamer-3.0.20-1699.11.pm.19.x86_64 from vendor http://packman.links2linux.de
  install vlc-lang-3.0.21-2.1.noarch from vendor openSUSE
    replacing vlc-lang-3.0.20-1699.11.pm.19.noarch from vendor http://packman.links2linux.de
  install libvlc5-3.0.21-2.1.x86_64 from vendor openSUSE
    replacing libvlc5-3.0.20-1699.11.pm.19.x86_64 from vendor http://packman.links2linux.de
  install libvlccore9-3.0.21-2.1.x86_64 from vendor openSUSE
    replacing libvlccore9-3.0.20-1699.11.pm.19.x86_64 from vendor http://packman.links2linux.de
 Solution 2: deinstallation of phonon-vlc-qt6-0.12.0-2.2.x86_64
 Solution 3: keep obsolete phonon-vlc-qt6-0.12.0-2.2.x86_64
 Solution 4: break phonon-vlc-qt6-0.12.0-2.3.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/3/4/s/r/c/d/?] (c): 1

Problem: 4: the installed python311-python-lsp-black-2.0.0-3.2.noarch requires 'python311-python-lsp-server >= 1.4', but this requirement cannot be provided
 Solution 1: deinstallation of python311-flake8-7.0.0-1.3.noarch
 Solution 2: deinstallation of python311-python-lsp-black-2.0.0-3.2.noarch
 Solution 3: keep obsolete python311-flake8-7.0.0-1.3.noarch
 Solution 4: break python311-python-lsp-black-2.0.0-3.2.noarch by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/3/4/s/r/c/d/?] (c): 

@LLiebermann you have to delete the old to get the new… You didn’t continue to the end?

You have an old package “conflicts with 'python3-pycodestyle”, I suspect it’s @System not a repository… It should be “python311-pycodestyle”

Sorry for the incomplete output. If I select solution 1 for the last choice (Problem 4), three python packages will be removed, but I don’t see a “new” package that replaces them.

su - -c 'zypper dup -dD'
Password: 
Loading repository data...
Reading installed packages...
Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
Computing distribution upgrade...
4 Problems:
Problem: 1: the installed python311-python-lsp-server-1.11.0-1.1.noarch conflicts with 'python3-pycodestyle >= 2.12.0' provided by the to be installed python311-pycodestyle-2.12.0-1.1.noarch
Problem: 2: the to be installed phonon-vlc-qt5-0.12.0-2.3.x86_64 requires 'vlc = 3.0.21', but this requirement cannot be provided
not installable providers: vlc-3.0.21-2.1.x86_64[download.opensuse.org-oss]

Problem: 3: the to be installed phonon-vlc-qt6-0.12.0-2.3.x86_64 requires 'vlc-noX = 3.0.21', but this requirement cannot be provided
not installable providers: vlc-noX-3.0.21-2.1.x86_64[download.opensuse.org-oss]

Problem: 4: the installed python311-python-lsp-black-2.0.0-3.2.noarch requires 'python311-python-lsp-server >= 1.4', but this requirement cannot be provided

Problem: 1: the installed python311-python-lsp-server-1.11.0-1.1.noarch conflicts with 'python3-pycodestyle >= 2.12.0' provided by the to be installed python311-pycodestyle-2.12.0-1.1.noarch
 Solution 1: Following actions will be done:
  deinstallation of python311-pycodestyle-2.11.1-1.5.noarch
  deinstallation of python311-autopep8-2.0.4-3.3.noarch
 Solution 2: deinstallation of python311-python-lsp-server-1.11.0-1.1.noarch
 Solution 3: keep obsolete python311-pycodestyle-2.11.1-1.5.noarch

Choose from above solutions by number or skip, retry or cancel [1/2/3/s/r/c/d/?] (c): 1

Problem: 2: the to be installed phonon-vlc-qt5-0.12.0-2.3.x86_64 requires 'vlc = 3.0.21', but this requirement cannot be provided
not installable providers: vlc-3.0.21-2.1.x86_64[download.opensuse.org-oss]

 Solution 1: Following actions will be done:
  install vlc-3.0.21-2.1.x86_64 from vendor openSUSE
    replacing vlc-3.0.20-1699.11.pm.19.x86_64 from vendor http://packman.links2linux.de
  install vlc-qt-3.0.21-2.1.x86_64 from vendor openSUSE
    replacing vlc-qt-3.0.20-1699.11.pm.19.x86_64 from vendor http://packman.links2linux.de
  install vlc-vdpau-3.0.21-2.1.x86_64 from vendor openSUSE
    replacing vlc-vdpau-3.0.20-1699.11.pm.19.x86_64 from vendor http://packman.links2linux.de
  install vlc-codec-gstreamer-3.0.21-2.1.x86_64 from vendor openSUSE
    replacing vlc-codec-gstreamer-3.0.20-1699.11.pm.19.x86_64 from vendor http://packman.links2linux.de
  install vlc-lang-3.0.21-2.1.noarch from vendor openSUSE
    replacing vlc-lang-3.0.20-1699.11.pm.19.noarch from vendor http://packman.links2linux.de
  install libvlc5-3.0.21-2.1.x86_64 from vendor openSUSE
    replacing libvlc5-3.0.20-1699.11.pm.19.x86_64 from vendor http://packman.links2linux.de
  install libvlccore9-3.0.21-2.1.x86_64 from vendor openSUSE
    replacing libvlccore9-3.0.20-1699.11.pm.19.x86_64 from vendor http://packman.links2linux.de
 Solution 2: deinstallation of phonon-vlc-qt5-0.12.0-2.2.x86_64
 Solution 3: keep obsolete phonon-vlc-qt5-0.12.0-2.2.x86_64
 Solution 4: break phonon-vlc-qt5-0.12.0-2.3.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/3/4/s/r/c/d/?] (c): 1

Problem: 3: the to be installed phonon-vlc-qt6-0.12.0-2.3.x86_64 requires 'vlc-noX = 3.0.21', but this requirement cannot be provided
not installable providers: vlc-noX-3.0.21-2.1.x86_64[download.opensuse.org-oss]

 Solution 1: Following actions will be done:
  install vlc-noX-3.0.21-2.1.x86_64 from vendor openSUSE
    replacing vlc-noX-3.0.20-1699.11.pm.19.x86_64 from vendor http://packman.links2linux.de
  install vlc-qt-3.0.21-2.1.x86_64 from vendor openSUSE
    replacing vlc-qt-3.0.20-1699.11.pm.19.x86_64 from vendor http://packman.links2linux.de
  install vlc-vdpau-3.0.21-2.1.x86_64 from vendor openSUSE
    replacing vlc-vdpau-3.0.20-1699.11.pm.19.x86_64 from vendor http://packman.links2linux.de
  install vlc-codec-gstreamer-3.0.21-2.1.x86_64 from vendor openSUSE
    replacing vlc-codec-gstreamer-3.0.20-1699.11.pm.19.x86_64 from vendor http://packman.links2linux.de
  install vlc-lang-3.0.21-2.1.noarch from vendor openSUSE
    replacing vlc-lang-3.0.20-1699.11.pm.19.noarch from vendor http://packman.links2linux.de
  install libvlc5-3.0.21-2.1.x86_64 from vendor openSUSE
    replacing libvlc5-3.0.20-1699.11.pm.19.x86_64 from vendor http://packman.links2linux.de
  install libvlccore9-3.0.21-2.1.x86_64 from vendor openSUSE
    replacing libvlccore9-3.0.20-1699.11.pm.19.x86_64 from vendor http://packman.links2linux.de
 Solution 2: deinstallation of phonon-vlc-qt6-0.12.0-2.2.x86_64
 Solution 3: keep obsolete phonon-vlc-qt6-0.12.0-2.2.x86_64
 Solution 4: break phonon-vlc-qt6-0.12.0-2.3.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/3/4/s/r/c/d/?] (c): 1

Problem: 4: the installed python311-python-lsp-black-2.0.0-3.2.noarch requires 'python311-python-lsp-server >= 1.4', but this requirement cannot be provided
 Solution 1: deinstallation of python311-flake8-7.0.0-1.3.noarch
 Solution 2: deinstallation of python311-python-lsp-black-2.0.0-3.2.noarch
 Solution 3: keep obsolete python311-flake8-7.0.0-1.3.noarch
 Solution 4: break python311-python-lsp-black-2.0.0-3.2.noarch by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/3/4/s/r/c/d/?] (c): 1

Resolving dependencies...
Computing distribution upgrade...

The following 592 packages are going to be upgraded:

  [I REMOVED SOME LINES HERE TO JUST SHOW THE PYTHON LIBRARIES]
  pimcommon python311-PyICU
  python311-lxml python311-ujson python311-urllib3 python311-watchdog qpdf qt6-network-tls
  [I REMOVED SOME LINES HERE TO JUST SHOW THE PYTHON LIBRARIES]

The following product is going to be upgraded:
  openSUSE Tumbleweed  20240612-0 -> 20240618-0

The following 8 packages are going to change vendor:
  libvlc5              http://packman.links2linux.de -> openSUSE
  libvlccore9          http://packman.links2linux.de -> openSUSE
  vlc                  http://packman.links2linux.de -> openSUSE
  vlc-codec-gstreamer  http://packman.links2linux.de -> openSUSE
  vlc-lang             http://packman.links2linux.de -> openSUSE
  vlc-noX              http://packman.links2linux.de -> openSUSE
  vlc-qt               http://packman.links2linux.de -> openSUSE
  vlc-vdpau            http://packman.links2linux.de -> openSUSE

The following 2 NEW packages are going to be installed:
  envsubst kernel-default-6.9.5-1.1

The following 3 packages are going to be REMOVED:
  python311-autopep8 python311-flake8 python311-pycodestyle

The following package requires a system reboot:
  kernel-default-6.9.5-1.1

592 packages to upgrade, 2 new, 3 to remove, 8  to change vendor.

@LLiebermann I think you will have to cross that bridge after the dup and manually re-install to see what is happening, or use the keep (Solution 4)…

Thanks! I went with solution 1 and since I’m not missing any functionality so far, I haven’t reinstalled anything yet. :+1:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.