ATI FirePro M7740 went unstable - any ideas?

Hi again!

Have an old Dell Precision M6400 with an ATI FirePro M7740 graphics, doing fine with TW 64bit KDE for months, but since about ernel 13.10 the machine crashes, the display turns background colour, icons dissapear and never turn up again. Hard crash, no console on e.g. CTRL+ALT F2 functionally (tried it even blind to login and reboot), only with power button can return to normal.

In the beginning, it was once a week, now we are at several times a day. It has nothing to do with the actuall install of TW, tried a rather fresh install on an USB-stick, same crashes.

With Win7 (dual boot) graphics is stable with the latest Dell/AMD driver. Unfortunately there is apparently no Linux driver for this graphics card:

Any ideas how to get this nice old system healthy again?:frowning:

If you check the output from /sbin/modinfo radeon and look at the parm options, you may have to do some tweaking… there are lots…

You can see what the current settings are via systool (as root user)

systool -vm radeon

Hi and thanks! That sounds REALLY funnnn… :smiley:

ANY suggestion where to start looking? :expressionless:

systool -vm radeon
Module = "radeon"

    coresize            = "1642496"
    initsize            = "0"
    initstate           = "live"
    refcnt              = "17"
    srcversion          = "47BE0D670BED63D6F5BAFD8"
    taint               = ""
    uevent              = <store method only>

    agpmode             = "0"
    aspm                = "-1"
    audio               = "-1"
    auxch               = "-1"
    backlight           = "-1"
    bapm                = "-1"
    benchmark           = "0"
    cik_support         = "1"
    connector_table     = "0"
    deep_color          = "0"
    disp_priority       = "0"
    dpm                 = "-1"
    dynclks             = "-1"
    fastfb              = "0"
    gartsize            = "1024"
    hard_reset          = "0"
    hw_i2c              = "0"
    lockup_timeout      = "10000"
    modeset             = "1"
    msi                 = "-1"
    mst                 = "0"
    no_wb               = "0"
    pcie_gen2           = "-1"
    r4xx_atom           = "0"
    runpm               = "-1"
    si_support          = "1"
    test                = "0"                                                                                                      
    tv                  = "1"                                                                                                      
    use_pflipirq        = "2"                                                                                                      
    uvd                 = "1"                                                                                                      
    vce                 = "1"                                                                                                      
    vm_block_size       = "12"                                                                                                     
    vm_size             = "8"                                                                                                      
    vramlimit           = "0"

    .altinstr_replacement= "0xffffffffc04b43ce"
    .altinstructions    = "0xffffffffc0531dac"
    .bss                = "0xffffffffc053f840"
    .data               = "0xffffffffc0532180"
    .exit.text          = "0xffffffffc04b43b1"
    .gnu.linkonce.this_module= "0xffffffffc053f500"
    .init.text          = "0xffffffffc0564000"  = "0xffffffffc04b7000"
    .orc_unwind         = "0xffffffffc050e8b8"
    .orc_unwind_ip      = "0xffffffffc04f9ec8"
    .parainstructions   = "0xffffffffc0531d80"           = "0xffffffffc053ef40"
    .rodata.str1.1      = "0xffffffffc04f22f6"
    .rodata.str1.8      = "0xffffffffc04e4588"
    .rodata             = "0xffffffffc04b7040"
    .smp_locks          = "0xffffffffc0531d08"
    .strtab             = "0xffffffffc057fc88"
    .symtab             = "0xffffffffc0565000"
    .text               = "0xffffffffc03d2000"
    .text.unlikely      = "0xffffffffc04b43ee"
    __bug_table         = "0xffffffffc053e800"
    __jump_table        = "0xffffffffc0532000"
    __mcount_loc        = "0xffffffffc052d7a0"
    __param             = "0xffffffffc04f9978"
    __tracepoints_ptrs  = "0xffffffffc0531e18"
    __tracepoints       = "0xffffffffc053f240"
    __tracepoints_strings= "0xffffffffc0531e70"
    __verbose           = "0xffffffffc053ee60"
    _ftrace_events      = "0xffffffffc053eed0"

…apparently a really rare piece of hardware only used in Dell Precision M6400 and M6500… sigh…

Mobility Radeon HD 4860 and Radeon HD 4750 uses the same RV740 “architecture”…

Is the “libvulkan_radeon” the driver used under TW? Any chance to try the older 17.2.4 version of this driver from anywhere? :slight_smile:

Just a shot in the dark:


Hi and thanks!

I have a file “10-amdgpu.conf”:

Section "OutputClass"
    Identifier "AMDgpu"
    MatchDriver "amdgpu"
    Driver "amdgpu"

What would be safe to test here? :slight_smile:

Your system isn’t using amdgpu, it’s radeon…

Hmm, but I don’t have any radeon files in /etc/X11/xorg.conf.d, only a 50-device.conf:

# Having multiple "Device" sections is known to be problematic. Make
# sure you don't have in use another one laying around e.g. in another
# xorg.conf.d file or even a generic xorg.conf file. More details can
# be found in
#Section "Device"
#  Identifier "Default Device"
#  #Driver "radeon"
#  ## Required magic for radeon/radeonhd drivers; output name
#  ## (here: "DVI-0") can be figured out via 'xrandr -q'
#  #Option "monitor-DVI-0" "Default Monitor"

…but apparently everything is commented-out here, or?

Correct, the system figures out the driver etc to use for your card (radeon) then if it’s an old one like yours additional tweaks may be required, either via kernel module parameters of a user created 20-radeon.conf file.

Would it be safe to try this as 20-radeon.conf:

Section "Device"         Identifier  "Radeon"
        Driver "radeon"
        Option "EXAVSync" "on"
        Option "TearFree" "on"

Does this have to be activated or is it active on boot automagically?

It will be, if you look at the output from lspci you can see what drivers are in use;

/sbin/lspci -nnk | grep -A3 VGA

The EXAVSync may/maynot cause issues (perhaps omit it for the moment) with your card, but you can also look at the Xorg.0.log file in ~/.local/share/xorg for what is happening.

I have here:

/sbin/lspci -nnk | grep -A3 VGA

01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] RV740/M97 GL [FirePro M7740] [1002:94a3]
        Subsystem: Dell Device [1028:02ef]
        Kernel driver in use: radeon
        Kernel modules: radeon

…but there is absolutely no xorg in the folder .local/share/

Do you mean I should try:

Section "Device"         
        Identifier  "Radeon"
        Driver "radeon"
        Option "EXAVSync" "off"
        Option "TearFree" "on" 

? Many thanks in advance…

Then the logs should be down in /var/log/xorg


Section "Device"         
        Identifier  "Radeon"
        Driver "radeon"
        Option "TearFree" "on" 

In the xorg.0.log I find nothing related to EXAVSync, while TearFree is set to auot, I guess:

63.506 (==) RADEON(0): TearFree property default: auto

Which may/maynot set it to off… so run with the 20-radeon.conf file and see if it helps.

Perhaps post your current Xorg log on SUSE Paste

…I copied this 20-file into the directory /etc/x11/… and rebooted. Wait’n see…

Here is the log

…log is an old one from yesterday, I forgot to say! Any need to see the log for the latest boot also?

Yes the latest one :wink: