ATI FirePro M7740 went unstable - any ideas?

…here we go

Anything interesting in there? :slight_smile:

So tear free in on, so have you noticed a change in the display output now? If not try adding the line omitted before and reboot…

I will have to wait at least 1 day, normally a crash happend recently every day… (today the second I wanted to copy this 20-file to its destination).

OK, next crash happend this second, screen turned gray, than background color without icons, taskbar etc. Totally dead at that point…

But this time the gray scree comes back again and again (never seen before). Seems like the machine tries to restart the graphics, but doesn’t succeed…

On Wed 22 Nov 2017 05:46:01 PM CST, suse rasputin wrote:

OK, next crash happend this second, screen turned gray, than background
color without icons, taskbar etc. Totally dead at that point…

But this time the gray scree comes back again and again (never seen
before). Seems like the machine tries to restart the graphics, but
doesn’t succeed…

When was the last time it was cleaned out of dust bunnies, sounds like
over heating…

What does the output from the sensors command show?

Was this with the added option or just TearFree?

Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
openSUSE Leap 42.2|GNOME 3.20.2|4.4.92-18.36-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below… Thanks!

Is cleaned twice a year, recently after the problem started, I cleaned it and installed a temp monitor tool. GPU is typically at 56°C, while HDDs are at 40°C. Only TearFree added yet. :wink:

Hmmm, well I have a systemd service that sets the power profile to low if the temperature starts increasing. But maybe the hardware is just showing the test of time?

zypper in

systemctl start radeon-power_profile.service
systemctl status radeon-power_profile.service
systemctl enable radeon-power_profile.service

The notebook has a 1920x1600 display, this is large, but also the reason, why I still use this machine and want to keep it. Do you think 56°C is high? Would your script already kick in here?

Have a read of the article I based it on:

Other forum users have reported the temperatures on the cards dropped… I would expect it to be down around the 45 Degree mark…

… I downloaded the .rpm from your repo and extracted it. Just to learn somethink about systemd, I wanted to install it “by hand” without zypper.

If I see this correctly, I can simply copy the three files to the respective directories in “/” and the start the service with the commands given in your post above, correct? :slight_smile:

Proprietary AMD and FOSS Radeon are not the only Xorg driver options for ATI gfxchips. Has the other been tried? It works fine for me with Radeon HD5450, which is only about a month newer than the M7740 FirePro. It should be used automatically by uninstalling xf86-video-ati, if nothing in xorg.conf or xorg.conf.d/ blocks it. It’s called modesetting, part of the Xorg server package.

Hi mrmazda

I have no idea how to switch graphics drivers under TW.

So what do you think I should check before removing xf86-video-ati? :slight_smile:

many thanks in advance…

If you’ve never installed the proprietary AMD drivers, at most, eliminating xorg.conf, 10-amdgpu.conf, 20-radeon.conf and 50-device.conf, ‘zypper rm xf86-video-ati’, and restarting the xorg server should be all it takes to make the switch to the generic modesetting driver. Eliminating those xorg.conf.d/ files may not even be necessary, depending on what they contain, if they even exist. Those containing only comments are totally inert. There is some slight possibility (which I doubt) the M7740 is too old be supported by the modesetting driver, in which case thexf86-video-ati driver would need to be reinstalled.

OK, I tried the low profile way first, installed it with zypper in, ignored the missing key, but I’m stuck with some error in the shell script:

When I do


I get

usage: radeon-power_profile 

Valid profiles:
  default (current)

When I do

radeon-power_profile low

I get

/usr/sbin/radeon-power_profile: line 32: echo: write error: Invalid argument

same when trying to start the service, I see with status:

systemctl status radeon-power_profile.service
● radeon-power_profile.service - Radeon Power Profile
   Loaded: loaded (/usr/lib/systemd/system/radeon-power_profile.service; enabled; vendor preset: disabled)
   Active: inactive (dead) since Thu 2017-11-23 14:39:57 CET; 4s ago
  Process: 2400 ExecStart=/bin/sh -c /usr/sbin/radeon-power_profile low (code=exited, status=0/SUCCESS)
 Main PID: 2400 (code=exited, status=0/SUCCESS)

Nov 23 14:39:57 xxxxxx systemd[1]: Starting Radeon Power Profile...
Nov 23 14:39:57 xxxxxx systemd[1]: Started Radeon Power Profile.
Nov 23 14:39:57 xxxxxx sh[2400]: /usr/sbin/radeon-power_profile: line 32: echo: write error: Invalid argument

Any idea what’s wrong?

If you look at the script, does TARGET (/sys/class/drm/card0/device/power_profile) exsist?

Yepp, it’s a text file with the content “default”…

Can I change this with an editor to “low” ?

Nope, you need to use echo…

echo "low" > /sys/class/drm/card0/device/power_profile

If it still errors then the card doesn’t support power profiles…

OK, there have been changes… try;

echo battery > /sys/class/drm/card0/device/power_dpm_state
echo low > /sys/class/drm/card0/device/power_dpm_force_performance_level

cat /sys/class/drm/card0/device/power_dpm_state 

cat /sys/class/drm/card0/device/power_dpm_force_performance_level 

See if that helps…

You may need to add radeon.dpm=1 to you bootloader kernel commandline options as well via yaST Bootloader

Those echo things cam back with “battery” and “low”, BUT Temp of GPU (is now in the 40ies°C) is now back to 50-55°C.Hmmm…

Although this script still shows power profile as “default”.

Don’t get the part with the kernel. Will that make this “low” persistent?

OT: Why did I get a XSS attack warning when trying to log in here:

[NoScript XSS] Sanitized suspicious request. Original URL [] requested from []. Sanitized URL: [].


Your current setting (from the systool output) is;

dpm                 = "-1"

Which is auto, reboot, but I would guess the will default back. I need to create a new script with more options and some checks…

So what is the actual temperature now? Lets see if that helps…

For the XSS query, please post in the forum feedback about this so it can be looked at.