ATI 9.1 Driver FINALLY Posted

I just installed on my opensuse 11.2 alpha0-
uninstalled my old ati driver first though no problems
although I am running a 32 bit machine. It seems like most
problems are with 64 bit boxes

well there are definite improvements but it still doesn’t work.

IBM T42P ATI Mobility Radeon 7600

9.1 does indeed have both 32bit and 64bit in the same file. hurrah!

Choosing the custom compiled version now compiles ok, installs and “atconfig --initial” runs just fine and doesn’t cause a segmentation fault! hurrah.

modprobe fglrx faults with “cannot allocate memory” grrrrrr.

sax2 -r -m 0=fglrx fails to start an X Server. grrrrr.

uninstall fglrx completely nice script to clear everything down! hurrah.

Use the precompiled version, install gets to 75% and fails with an error about “/usr/X11R6…modules/fglrx…so” already exists and the scripts terminates with a nice note about the error. grrrrr.

so a complete blank then!


note to self: must get a real hobby one day.

Okay i just install the driver on my 64bits suse 11.1 with a XT850 PE and it’s working really good (“compare to the last one”) …

No tricks needed to install on 64bits machine any more…

The only complain is , i still not able to watch movies using “xv” driver under any player “mplayer base” and vlc…when Desktop effects is on…

but it’s definally a better driver…lol!

Yeah, I don’t know what all the complaints are about. I’m guessing these people must have either not installed the dependencies, or they have desktop effects turned on, or they are somewhat lacking in patience.

For me it cleared up all my problems with video players. VLC works for no problem using XV. Do you by chance have OpenGL Overlay turned on in the Devices section of your xorg.conf rather then the video overlay option ?
Also note that for the ati proprietary driver it’s a good idea to have
Option “IgnoreABI” “on”
In the server flags section of the xorg.conf file. your /usr/share/ati/fglrx-install.log if the installation went wrong it will tell you what
1.a. correct the error
2.rerun the installer script and go with the recommendations
3. do aticonfig --initial
4. restart your display I use init 3 then init probably could alt control backspace*2
5. do not use sax instead run amdcccle
6. run fgl_glxgears to test

The driver installed without errors on my 32-bit Intel system with an MSI X3850. glxinfo shows the correct driver loaded. I made sure to remove all traces of the previous driver first. However, glxgears hangs the system hard and launching the GNOME System Monitor will cause a gnome to crash/restart (almost as if I did CTRL-ATL-Backspace). I saw the same behavior with the previous Catalyst 8.12 with this setup. The 9.1 works fine with my Thinkpad Z60M (Radeon X300 Mobility video). Are the xorg.conf tuning parameters from ATI - openSUSE still valid for this level of driver and hardware?:sarcastic:

I forgot a piece, I installed using the downloaded installer and generating a distro specific RPM for opensuse 11.1 32-bit.


Yes I have tried it all ways so far.

pre-compiled, the log file says no matching pre-compiled version and compiles a new one.

compiled, generates an RPM just fine in all cases the same issue.

modprobe fglrx results in “cannot allocate memory”.

I mean I know it could be me but

[fglrx] Maximum main memory to use for locked dma buffers: 1410 MBytes.
[fglrx:drm_alloc] ERROR [driver] Allocating 0 bytes
[fglrx:firegl_init_device_list] ERROR Out of memory when allocating device heads
[fglrx:firegl_init_module] ERROR firegl_init_devices failed
[fglrx] Maximum main memory to use for locked dma buffers: 1410 MBytes.
[fglrx:drm_alloc] ERROR [driver] Allocating 0 bytes
[fglrx:firegl_init_device_list] ERROR Out of memory when allocating device heads
[fglrx:firegl_init_module] ERROR firegl_init_devices failed

This kindof looks to me like it doesn’t work.

This is also a clean install 32bit 11.1 out of the box and yes it has the appropriate dependencies in place and then fully patched.

kernel source added and modules prepared.

I suppose there may be some settings somewhere to effect this but who knows? I shall have to get back to googling it.

Lovely to hear that other have this working just fine though!

best regards

Try a reboot. A lot of people say this is not needed, but I think in some situations it can be helpful and it’s not going to hurt anything.

Did you ever run, as superuser

aticonfig --initial -f


Yep done that, once the xorg.conf file point to using the fglrx driver, X fails to start.

when I repoint it back to Radeon, no problems.

I mean I assume my card is actually supposed to work?

01:00.0 VGA compatible controller: ATI Technologies Inc RV350 [Mobility Radeon 9600 M10]

It works flawlessly in OpenSuse 10.3 with the proprietary ATI driver but I am having to ensure no more patches just in case I lose my wizzy desktop.

The real shame is, I show off the wizzy desktop to everyone where I work and it would be a real shame to not have it as it opens peoples eyes to the quality of OpenSuse and Linux.

best regards

Definitely turn off desktop effects until after you get the driver working properly.

I would suggest uninstalling whatever you have installed so far. Recheck that the dependencies match you current kernel version. Reinstall the driver and play around with the aticofig and sax2 commands (sax2 -r and sax2 -r -m 0=fglrx).

Try installing both with the installer and by generating an RPM file. Some combination will eventually work.

Try the repo driver too.


yep did all that, then I cleared all down and tried the repo driver, that had exactly the same issue.

Back to the drawing board I guess.

I’ll go for a fresh install and try again I guess.


Tks for the tip “silenuz” but i try turning on and off openGl Overlay and video Overlay on and off both on both off alternating on and off but i could not make any player work propelly with “xv” and Desktop Effects at the same time…
this driver it’s really better then the last one but i just wish ATI don’t say something that they are not sure about… like “Composite support during video playback” …i already install the new driver on 3 machines and none has a propelly video playback with composite window … here’s my video cards “xt850 PE, x600 and x700” …
I have a felling that AMD devs r getting there…good luck guys


ok so I tracked down the 9.2 beta driver and it installed and X now starts ok. yay

fglrx does not do “cannot allocate memory”, yay

fgl_glxgears now runs and gives me a spinny box. yay

desktop effects don’t yet work. hohum



Just a followup

I now have full 3d desktop effects, yay

compiz --replace ccp &

run as a normal user worked!

emerald --replace &

And I have my desktop back as before, yay

best regards

Finally I got my ati drivers installed for my X1550 (well so far so good) my network card failed to connect automatically at boot after enabling ‘POSIX shared memory’ but now there’s a new thing on the ‘task bar’ or whatever it’s called on gnome that lets me choose which network. I’m totally new to linux - about 3 days on opensuse, initially I was very frustrated with the cd to navigate folders to find the ati drivers, but with the help of some webpages and some trial and error I finally figured it out. I’m looking forward to learning more about Linux and hopefully eventually dump XP entirely. If I can get Half-Life releases to work with Wine and find some new Audio Software for sequencing I’ll be more that happy. Sorry I obviously can’t offer any help here being new to Linux but at least the drivers do work, at least for X1550. And I would like to thank everyone for help on this forum.

Have a good day!

I hate to sound COMPLETELY ignorant but here is the deal. I started playing with Suse a couple of weeks ago. I was a linux virgin until then. I am in a Suse class at the local college…for version 10.2 OK, so here is whats going on. I have an old Acer travelmate C301 tablet with an Intel card. It took me about 100 times of reinstalling on Suse on my laptop until I got it right…getting 3d to work, updates, tablet functionality, etc. JUST THE BASICS. The good thing is I can probably set mine up in my sleep at thsi point. So I thought I could help my brother in law get his up and running via the telephone.

He has a Dell with an ATI 9000 card. Suse found everything and he was off to the races…except no 3D. After looking around for a couple of days I found tons of literature to read…but seeing as I must be completely ignorant, and he also doesnt know linux, we have had to reboot the system 4 times now. I dont understand how to do the things people are saying. Is there anyone, for the love of (insert your higher power here), that can give me a stupified version of how to find and uninstall the current driver for the ATI. Then could they, or someone else offer, in laymens terms which, exactly, driver should be installed and the EASIEST way to install it.
Once the new driver is installed do I then go to display settings and enable 3D. Or do I go to the desktop effects and enable, or do I go to the personal settings, desktop, default applications>window manager>use a different window manager, then what??? I think at this point you see where I am at in the learning process…So please someone help me keep my sanity and help a brother out…lol. As of this writing we have a black screen and can only start in failsafe…so we will be reinstalling again. I will have him set up in KDE 4.1 and the add the gnome desktop option, then have him disable auto login. So we will have the ability to do the uninstall of current package and install of new package in whichever desktop environment needed. And if anyone has a good RPM to link I would give my first born son…especially if there is no need to do an uninstall. BTW, part of the problem was tring to find the files needed prior to the driver install. So one last plea…PLEASE HELP. I am drowning…lol
Thanks in advance…

Radeon 9000 is not supported by the ATI driver, you need a 9500 or better. Check the release notes on the driver download page.

I would stick with the stock driver. Version 11.1 has a newer version of the driver which you might be able to get SOME 3d acceleration from, though not much and probably not enough for desktop effects.

You may also be able to get some 3d from the driver in 10.2. Did you run sax2 from text mode and try checking the “enable 3d” box?

I’m in the same boat with my 9250. Not supported, at least by ATI.

LOL…my old relic can do 3D, his cant…lmao. We enabled 3D. Not aware of the sax2 function. Please advise.
Thanks for the lead.