ASUS Laptop sound by harman kardon has no sound

Hi, my new ASUS laptop has sound by harman kardon. Sound of the built-in speakers is pretty good with Windows, but there is no sound with Leap 15.4. The sound system works, I can hear music by using a bluetooth headset, but no sound from the built-in speakers. Is this a known problem and are there any proposals to fix it?

Please show the results of

inxi -Axxx
zypper se -si pavu*
zypper se -si pulse*
zypper se -si pipewire*
zypper se -si wireplumber*

inxi -Axxx

Audio: Device-1: Intel Alder Lake PCH-P High Definition Audio vendor: ASUSTeK driver: sof-audio-pci-intel-tgl bus-ID: 0000:00:1f.3 chip-ID: 8086:51c8 class-ID: 0401
Sound Server-1: ALSA v: k5.14.21-150400.24.41-default running: yes
Sound Server-2: PulseAudio v: 15.0 running: yes
Sound Server-3: PipeWire v: 0.3.49 running: no

zypper se -si pavu*

Repository-Daten werden geladen…
Installierte Pakete werden gelesen…
Keine passenden Objekte gefunden.

zypper se -si pulse*

Repository-Daten werden geladen…
Installierte Pakete werden gelesen…

S | Name | Type | Version | Arch | Repository
–±----------------------------±------±-----------------±-------±----------------
i | pulseaudio | Paket | 15.0-150400.2.10 | x86_64 | Haupt-Repository
i | pulseaudio-bash-completion | Paket | 15.0-150400.2.10 | x86_64 | Haupt-Repository
i | pulseaudio-lang | Paket | 15.0-150400.2.10 | noarch | Haupt-Repository
i | pulseaudio-module-bluetooth | Paket | 15.0-150400.2.10 | x86_64 | Haupt-Repository
i | pulseaudio-module-gsettings | Paket | 15.0-150400.2.10 | x86_64 | Haupt-Repository
i | pulseaudio-module-x11 | Paket | 15.0-150400.2.10 | x86_64 | Haupt-Repository
i | pulseaudio-module-zeroconf | Paket | 15.0-150400.2.10 | x86_64 | Haupt-Repository
i | pulseaudio-setup | Paket | 15.0-150400.2.10 | x86_64 | Haupt-Repository
i | pulseaudio-utils | Paket | 15.0-150400.2.10 | x86_64 | Haupt-Repository

zypper se -si pipewire*

Repository-Daten werden geladen…
Installierte Pakete werden gelesen…

S | Name | Type | Version | Arch | Repository
–±-------------------------±------±------------------±-------±----------------
i | pipewire | Paket | 0.3.49-150400.1.5 | x86_64 | Haupt-Repository
i | pipewire-lang | Paket | 0.3.49-150400.1.5 | noarch | Haupt-Repository
i | pipewire-modules-0_3 | Paket | 0.3.49-150400.1.5 | x86_64 | Haupt-Repository
i | pipewire-spa-plugins-0_2 | Paket | 0.3.49-150400.1.5 | x86_64 | Haupt-Repository
i | pipewire-spa-tools | Paket | 0.3.49-150400.1.5 | x86_64 | Haupt-Repository
i | pipewire-tools | Paket | 0.3.49-150400.1.5 | x86_64 | Haupt-Repository
p> ```

zypper se -si wireplumber*

Repository-Daten werden geladen…
Installierte Pakete werden gelesen…

S | Name | Type | Version | Arch | Repository
–±------------±------±-------------------±-------±------------------------------------------------------------
i | wireplumber | Paket | 0.4.9-150400.3.3.2 | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
p> ```

Installiere das Paket pavucontrol mit

zypper in pavucontrol

und prüfe welche Ausgabegeräte verfügbar sind.

The installation of pavucontrol has worked, but the output confuses me.
Screenshot_20230212_110431
The text under the slider seems to imply that the speaker is muted, but I cannot unmute it. Hitting the button with the speaker and the red line switches the slider to grey, hitting it again restores the blue slider, but the “stumm” does not change.
When I change the setting of the slider, I see movements of the level bar, but I can´t hear the sound - there is no output from the speaker.
As mentioned before, the speaker itself is not broken. It works fine with Windows.

I do not see the “Stumm” on my system but I’m on openSUSE Tumbleweed so I might have a different version of pavucontrol. However the speaker-button shows the same behavior here.

What do you see when you select the “Konfiguration”-panel? Which profiles are available? Will a different profile make the speakers work?

There is only one profile to choose: Play HiFi quality Music
Screenshot_20230212_191944

The profile “Aus” does not help.

Seems obvious …

Have you tried to switch your sound server from PulseAudio to PipeWire ?

I doubt that the sound server is the problem. As mentioned in the initial post, I get sound with a bluetooth headset via bluetooth. The sound server seems to work fine. I suspect that the issue is located in the software layer closer to the HW, for example the driver. When looking for ways to change the sound server, I have started yast. An attempt to reconfigure the sound driver resulted in the following message:

Several seconds later, there was a message that the alder lake audio controller is activated and the red line of the speaker symbol in the control bar disappeared. Strange move, if there is no configured kernel module for the sound hardware.

Does the sound-chip firmware load correctly?

You can check (as “root” in a terminal) the log for related errors with

journalctl -b 0 | grep irmware

As far as I know the YaST sound module is obsolete. In openSUSE Tumbleweed it is gone already.

I switched to PipeWire by installing the PipeWire packages and enabling the PipeWire service for my user.

Another possibility to tackle your problem could be to use a more recent kernel (e.g kernel 6.1).

The output of “journalctl -b 0 | grep irmware” is:

Feb 19 12:53:30 localhost kernel: tpm tpm0: [Firmware Bug]: TPM interrupt not working, polling instead
Feb 19 11:53:33 localhost kernel: iwlwifi 0000:00:14.3: loaded firmware version 71.058653f6.0 so-a0-gf-a0-71.
ucode op_mode iwlmvm
Feb 19 11:53:34 localhost NetworkManager[1318]: [1676804014.0132] manager[0x5629565ae040]: monitoring
kernel firmware directory ‘/lib/firmware’.
Feb 19 11:53:34 localhost kernel: Bluetooth: hci0: Minimum firmware build 1 week 10 2014
Feb 19 11:53:34 localhost kernel: Bluetooth: hci0: Found device firmware: intel/ibt-0040-0041.sfi
Feb 19 11:53:36 localhost kernel: Bluetooth: hci0: Waiting for firmware download to complete
Feb 19 11:53:36 localhost kernel: Bluetooth: hci0: Firmware loaded in 1502454 usecs
Feb 19 11:53:36 localhost kernel: Bluetooth: hci0: Firmware timestamp 2022.12 buildtype 1 build 41819
Feb 19 11:54:35 Laptop-Peter-ASUS.fritz.box kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: Firmware info: vers
ion 2:0:0-b678a
Feb 19 11:54:35 Laptop-Peter-ASUS.fritz.box kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: Firmware: ABI 3:20:
0 Kernel ABI 3:18:0
Feb 19 11:54:35 Laptop-Peter-ASUS.fritz.box kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: Firmware info: vers
ion 2:0:0-b678a
Feb 19 11:54:35 Laptop-Peter-ASUS.fritz.box kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: Firmware: ABI 3:20:
0 Kernel ABI 3:18:0

There seem to be hints concerning other issues, but as far as I can tell, the audio firmware loads without issues.

So why does yast state problems with the initialization of the kernel module? Yast is a configuration tool for non-expert users and offers configuration of the audio HW. An error message stating that loading of an audio related kernel module did not work is not helpful if this module is not required to get the audio system working. At least confusing for non-expert users.

Anyway, I followed your suggestion and installed pipewire. After the restart, I checked that pipewire is used:

peter@Laptop-Peter-ASUS:~> pactl info
Server String: /run/user/1001/pulse/native
Library Protocol Version: 35
Server Protocol Version: 35
Is Local: yes
Client Index: 304
Tile Size: 65472
User Name: peter
Host Name: Laptop-Peter-ASUS.fritz.box
Server Name: PulseAudio (on PipeWire 0.3.49)
Server Version: 15.0.0
Default Sample Specification: float32le 2ch 48000Hz
Default Channel Map: front-left,front-right
Default Sink: alsa_output.pci-0000_00_1f.3-platform-skl_hda_dsp_generic.HiFi__hw_sofhdadsp__sink
Default Source: alsa_input.pci-0000_00_1f.3-platform-skl_hda_dsp_generic.HiFi__hw_sofhdadsp__source
Cookie: 2c43:039f

Unfortunately, this did not resolve the issue. There still is no sound from the speaker. By the way, the microphone is working. The level bar is moving when I make sounds:

Screenshot_20230219_125206

So the access to the built-in audio hardware works in the input direction but unfortunately not in the output direction. Is it possible that the Alder Lake PCH-P High Definition Audio Controller does not work properly, i. e. has problems with the speaker?

Concerning your other suggestion of using a more recent kernel . I usually use the kernel that comes with the respective release of OpenSuse. So I am not experienced with “using” more recent kernels. Is there a way to test more recent kernels without actually installing them, for example by downloading a live image and booting the laptop from an USB stick?

I want to use my laptop primarily for productive work and not for software testing. Using a very early kernel version may resolve one bug, but come with several others and a lot of work to find fixes for them. As you can see from the delays between my responses, I don´t find time every day to search for fixes for bugs and to try potential remedies.

How about the live images which you can find under alternative downloads?

Yes, you can just download the latest openSUSE Tumbleweed LIVE image, put it on a USB-storage-device and test it.

I have downloaded a live image, put it on an USB stick, made sure that the partition is bootable but I did not find a way to boot from the USB stick. The UEFI does not recocgnize the USB stick as a bootable device. Not a straight forward solution.

This is your problem.

Do not put the image in a partition. It must overwrite the entire USB. When you do it correctly, the USB drive will then have an EFI partition and it should boot with UEFI.

I have written the image on the USB using dd as described. The USB was not recognized by UEFI as a bootable device. So I used fdisk to check that the image is bootable, as described further down in the manual, chapter 7. fdisk showed an EFI partition which was marked as bootable. I deactivated the partition and reactivated it. Still the UEFI does not recognize a bootable device.

Did you check the boot order in your BIOS? It must be set to USB before HDD/DVD…

The boot order in UEFI just shows two options on the hard drive. No other source to choose from.

Did it ever work to boot from an USB pen drive on this particular machine?

When installing the OpenSuse Linux, I managed to boot from a DVD drive connected via USB. So far, I did not try to boot from an USB stick. I could write the live image to a DVD and try to boot this way, but I did not want to waste another DVD just for testing a live image. Hoped that booting from an USB stick will help me to reuse the storage device after testing.