Aspire 5741G crash

Hi!

I installed OpenSUSE successfully but during

zypper up

it crashed with the following message:

http://i.imgur.com/3h0RC37.jpg

Now I’m a beginner and I don’t know much but I did try lots of different distros and each time it would crash with a similar message (on Elementary OS and Fedora it was something about Bad RIP Value - Kernel Panic).

If you need any logs or info, I can provide it.
PS I should really clean that screen :slight_smile:

As I see mention of drm_kms_helper there and your laptop apparently has an nvidia graphics chip, it might be a bug in the nouveau driver.

Can you confirm whether booting to “Recovery Mode” works? You can find that in “Advanced Options” in the boot menu, the 2nd entry.

And please post the output of this, to confirm which graphics chip(s) you have:

/sbin/lspci -nnk | egrep -iA3 "VGA|3D"

The problem is, I don’t have an NVidia GPU. The GPU in the laptop is Ati Mobility Radeon HD 5470. Output of the command is:


01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Park [Mobility Radeon HD 5430/5450/5470] [1002:68e0]
    Subsystem: Acer Incorporated [ALI] Device [1025:036d]
    Kernel driver in use: radeon
    Kernel modules: radeon

Recovery mode seems to be working, it’s still loading…

EDIT: It says Reached target graphical interface and green OK left of it (along with other commands with mostly OK) and it hangs there.

Well, drm_kms_helper is used by all KMS drivers, so radeon as well.

I googled for your model and came up with an nvidia chip, but probably there are different variations.
That proves once again that just specifying the laptop model is not enough information… :wink:

Recovery mode seems to be working, it’s still loading…

EDIT: It says Reached target graphical interface and green OK left of it (along with other commands with mostly OK) and it hangs there.

Well, that’s bad. So you do have at least one other problem.

Can you get to a text mode login when pressing Ctrl+Alt+F1 and login there?

I just see that I misinterpreted your original post.
The picture is from the crash during the update, right?
Does a normal boot show the same crash?

Anyway, apparently the update has been interrupted somewhere in the middle, that’s probably why even recovery doesn’t work.
Try to run “zypper up” in text mode again to complete the update, the laptop should hopefully boot again then.

One problem might be to get an internet connection in text mode though.
How do you connect? A wired ethernet connection should just work, but if you use a wireless connection with NetworkManager, it’s a bit more difficult.

Okay, my problems with this laptop are really weird… That error did crash during zypper up but I can use the OS normally until it crashses. Right now, I managed to add a Chrome repo, and currently it’s installing. I also did zypper ref and zypper up and nothing crashed.

I’m used wired connection for installation but now I’m using wireless.

Do you have any other advice what to do to ensure that the system is running normally? I’ve been wanting to learn and use Linux for a very long time but each time I install any distro it just randomly crashes. And even though I do have experience with computers, random kernel panics make me really angry because I feel powerless since I have absolutely no idea what’s going on!

I mean I even updated my BIOS and VGA BIOS to see if that works, and it does in Windows (everything works flawlessly) but in Linux it keeps being weird!

Thanks!

So it is working now?
But it’s crashing randomly?

This mostly points to hardware problems (maybe overheating), or issues with some drivers, the graphics driver probably.

Since you have a Mobility Radeon HD 5430/5450/5470 according to your output, I would suggest you try to install AMD’s proprietary fglrx graphics driver.

This might give you better performance and stability, and supports your graphics chip powermanagement better, so the laptop should run cooler.
See here for how to install it:
http://en.opensuse.org/SDB:AMD_fglrx

If your system is running too unstable to even install that driver, try to switch off KDE’s desktop effects if you’re using KDE (press Shift+Alt+F12).

It is working now, however I’m expecting it to crash randomly. I would like to try AMD proprietary drivers but before I do that, is there something I can do in case it fails? Like make a system restore point or something (obvious Windows user here :slight_smile: ) which I could revert to in case anything bad happens?

If it doesn’t work, just uninstall the fglrx package again to revert to the same state as before.
But as it supports your chip it should just work.

Thank you! I’ll try it now, and report back if any problems occur!

Hi wolfi, I have another problem

I installed fglrx using one click install and even though it looked like it finished quickly it said that everything is successful.

After restarting my laptop and booting into normal mode I get a crash message saying that I should log out and try again.

I can access the CLI mode and login in as root. Do you have any advice?

EDIT: I’m using GNOME

EDIT2: When I do aticonfig --inital or just aticonfig it says that there are not adapters detected which is really weird!

Then apparently something has gone wrong with the driver installation.

Try to boot to recovery mode, and post the file /var/log/Xorg.0.log.old please.

I can access the CLI mode and login in as root. Do you have any advice?

You mean you can login as root in text mode?

You could remove fglrx there by running:

rpm -e fglrx64_xpic_SUSE131

Or use yast to remove it. (yes, yast works in text mode as well)

Although it would be interesting to know why it didn’t work.

EDIT: I’m using GNOME

Well, GNOME is rather picky about the graphics driver unfortunately.

I would like to know why it doesn’t work too!

I can log as root in text mode in recovery!

Here’s the log: http://susepaste.org/13774512

This is output of the file mentioned in the previous log: http://susepaste.org/32846553

Parse error on line 8 of section InputClass in file /etc/X11/xorg.conf.d/50-device.conf

50-device.conf doesn’t contain a “Section InputClass”.
So probably the error is in the previously loaded file.
This should be /etc/X11/xorg.conf.d/11-evdev.conf then.

Could you please post this as well?

Probably this file got truncated during your failed update.
Strange though that you could boot to graphics mode afterwards at all.
But maybe that’s what prevents recovery mode from working…

This is output of the file mentioned in the previous log: http://susepaste.org/32846553

That’s perfectly ok. But probably the error is in another file as mentioned.

PS: you could just remove that file.
It only contains a workaround for some particular keyboard, namely “IBM TPPS/2 TrackPoint|ThinkPad USB Keyboard with TrackPoint” it seems.

rm  /etc/X11/xorg.conf.d/11-evdev.conf

Here’s the output:

http://susepaste.org/15122925

That’s ok as well. So please do not delete it.

Hm. Then it’s either /etc/X11/xorg.conf.d/10-evdev.conf , or there’s another stray file in /etc/X11/xorg.conf.d/ causing this.
Can you please post a directory listing?

ls -l /etc/X11/xorg.conf.d/

[SUB]10-evdev.conf: [/SUB]http://susepaste.org/16657002

ls output: http://susepaste.org/53137679

Thanks!

Hm, I don’t see anything wrong there either. Even all the files have the correct filesize.

The only thing left that’s mentioned in your log is /usr/share/X11/xorg.conf.d/, this contains only /usr/share/X11/xorg.conf.d/10-evdev.conf here, so please post that as well, and verify that the directory contains nothing else.

Other than that I would suggest to just delete 50-device.conf, it only contains comments anyway, then reboot and post /var/log/Xorg.0.log if it still doesn’t work.

This is the output: http://susepaste.org/95973527

It’s the only file in that directory!
I’ll try deleting that file you mentioned and rebooting!

Well, that’s the original version as well.

I’ll try deleting that file you mentioned and rebooting!

Ok.
Maybe there’s something in there that got lost during pasting.
The same applies to /etc/X11/xorg.conf.d/11-evdev.conf as well though, so maybe do try to delete that one too if it still doesn’t work.
We can get files back easily enough afterwards, by just re-installing the corresponding packages.

Deleted and rebooted. I still get “Oh no! Something has gone wrong” windows when I try to boot to openSUSE.
I can still get to text mode.