Ark Troubles

Freshly Installed Opensuse 11 KDE 4 installation. Whenever I try to extract an archive with Ark (to anywhere) it either locks up or informs me that it “could not write to the destination file” Very frustrating… Any help would be greatly appreciated.

make sure you have permission to write to the directory.


Yeah I have had the same problem after installing 11.0 with KDE 4. I tried to get the latest version of ARK thru Yast and KDE updated to V4.1. Which was all well and good but ARK still did not work.

I checked permissions and they were all good.
I fixed it by re-installing and going back to KDE 3.5.9 - Nothing like stability!.

If anyone can fix this I will think of trying 4 again. But all my backups are in Zip files and I need ARK to work.

Try installing PeaZip. I ran into this issue and I could unzip my files without a problem once I installed PeaZip. I ran into this issue with KDE4 on Kubuntu 8.04 as well so I don’t think it’s a Suse 11 only issue.

I am having trouble with Ark as well. It either refuses to extract all of the contents or it extracts everything but ignores all the folder paths, resulting in all the files being in one directory. It’s really annoying. I am forced to use WinRAR under wine, but I will try PeaZip.

I too use winrar at the moment. Works fine. Never heard of peazip.
The packages will eventually come through for kde4, just be patient.

Ark is not working for me either. No matter what I extract I get:

“The extraction operation failed.” Followed by a list of files and their permissions. This is extracting to my user directory and affects every file I try to extract.

I guess I’ll stick with tar for now.

I’m having the exact same troubles. I’ve noticed that the permission errors only occur for .rar/.zip (so far). .tar.gz works fine, haven’t yet tried .bz2. I’m guessing it pops up the permission error when Ark doesn’t know how to decompress those file formats. I’ve installed unrar but still no luck.

I found something interesting out:
If you have kde3 installed too.
Even if running in kde4
Use kde3 konqueror file manager
right click extract here - works fine!

And some other interesting point:

If you work from root (don’t shoot me I know I shouldn’t do that) Ark works. So I gues it has something to do with rights.


I have the same problem with ark with the kde3-desktop. Does anybody know something about this? what shall I do now. I didn’t find the programm Peazip in the repositories.

I think to it is a permission problem, but running it under console didn’t work too. He says: an error occured while opening the zip-file ecc.

in kde3 install rar and zip and unzip, crumbs there are so many just keep installing, it will work.

Took me awhile to figure out this Ark thing when I first saw it…

Is fundamentally because of KDE4’s weird and hidden permissions which erects barriers between the User’s home tree and the rest of the file system.

Since FF downloads files to the desktop, you’re initially constrained to decompressing the file only to the desktop, and maybe a folder on the desktop. Yeah, that sucks.

Then I found that Konqueror in Super User mode can’t copy or move the file outside of the User’s Home tree. <IF> you can run Dolphin in Superuser mode, that app can copy or move the file outside the User tree, but launching Dolphin in Super User mode appears to be unstable (won’t always work).

:slight_smile: So, the solution I’ve found that works is…

  1. Copy or move the archive file outside the User Home tree using Bash (command line terminal)

  2. Then launch Ark. Sometimes just to be sure, I launch Ark in Super User mode (eg ALT-F2 to invoke the application launcher, then “kdesu ark”), you can then decompress the archive to any location anywhere you wish.

That works every time for me… HTH…

Can please someone tell me how i can change to the desktop, to work their with the zipped files? What is the command to change there? I’m new with Linux thank you

Having trouble trying to figure out what you mean?
Clarify please

From the command line type

cd ~
cd Desktop

This should change to the desktop directory with the icons on your current desktop.

Okay, KDE 4.1 is already at version 4.0.99, yet Ark is still not fixed. I am starting to worry that this MAJOR bug (I mean its practically unusable) will make it into the official release. I have trouble finding bug reports on it in because the stupid search box keeps complaining that you need to enter a search query longer than 3 characters.

My worst fears have been realized. Ark in KDE 4.1 release is still borked. Does anyone know any alternative QT4 based archive utilities?

Benjamin Xiao wrote:

> My worst fears have been realized. Ark in KDE 4.1 release is still
> borked. Does anyone know any alternative QT4 based archive utilities?

Ark for KDE3 is an excellent choice :-).

Ark is actually the only KDE3 application I still use regularly in KDE4, so I agree that a KDE4 Ark in shape is long awaited.


A solution that worked for me was to use unzip from the command line. To open a command line from suse’s menu structure select System > Terminal > Konsole. The basic form is: “unzip arkfile -d destination”
Everything was unzipped correctly.