Are we using "Xorg -configure" now???

I did some fooling around trying to get my Logitech Marble trackball mouse autodetected and set up. You can get the information on what udev detects with this command (make sure your scrollback is big, or pipe it to a file) ‘udevadm info --export-db’.

You then add a ‘snippet’ to /etc/X11/xorg.conf.d/ containing MatchVendor and/or MatchProduct lines (information gotten from udev above), and the xorg parameters for that hardware.

More detailed account is here-I got my mouse to work, but the snippet isn’t quite suitable for inclusion in the release::

It’s sort of black magic at this stage-apparently there is little documentation…

My problems mostly stem from screen resolution.
When I 1st installed M7 I was able to get the openchrome driver,& just drop in my old xorg.conf. On the reinstall I couldn’t find it.My original xorg.conf was set to openchrome.So I installed Unichrome instead. Knowing from past experience that I’d have no X if used my old xorg.conf(no Openchrome to find) I did this:
1.In /etc/x11/xorg.conf.d left all those for the mouse & keyboard as they were.
2.opened the 50-monitor.conf deleted everything in there then
3.Pasted this part of my old xorg.conf

Section "Monitor"
  DisplaySize  367 230
  HorizSync    29-81
  Identifier   "Monitor[0]"
  ModelName    "GATEWAY HD1700"
  Option       "DPMS"
  Option       "PreferredMode" "1024x768"
  VendorName   "GWY"
  VertRefresh  43-76
  UseModes     "Modes[0]"

Section "Modes"
  Identifier   "Modes[0]"
  Modeline 	"1024x768" 83.00 1024 1080 1192 1360 768 769 772 803
  Modeline 	"1024x768" 76.89 1024 1080 1192 1360 768 769 772 800
  Modeline 	"1024x768" 70.50 1024 1072 1104 1184 768 771 775 796 +HSync -VSync
  Modeline 	"1024x768" 70.07 1024 1080 1184 1344 768 769 772 798
  Modeline 	"1024x768" 64.11 1024 1080 1184 1344 768 769 772 795
  Modeline 	"1024x600" 64.04 1024 1080 1184 1344 600 601 604 627
  Modeline 	"1024x600" 58.65 1024 1072 1176 1328 600 601 604 625
  Modeline 	"1024x600" 55.00 1024 1072 1104 1184 600 603 613 622 +HSync -VSync
  Modeline 	"1024x600" 54.05 1024 1072 1176 1328 600 601 604 623
  Modeline 	"1024x600" 48.96 1024 1064 1168 1312 600 601 604 622
  Modeline 	"800x600" 50.32 800 840 928 1056 600 601 604 627
  Modeline 	"800x600" 45.93 800 840 920 1040 600 601 604 625
  Modeline 	"800x600" 44.75 800 848 880 960 600 603 607 622 +HSync -VSync
  Modeline 	"800x600" 42.33 800 840 920 1040 600 601 604 623
  Modeline 	"800x600" 38.22 800 832 912 1024 600 601 604 622
  Modeline 	"768x576" 46.12 768 808 888 1008 576 577 580 602
  Modeline 	"768x576" 42.06 768 800 880 992 576 577 580 600
  Modeline 	"768x576" 41.50 768 816 848 928 576 579 583 597 +HSync -VSync
  Modeline 	"768x576" 38.82 768 800 880 992 576 577 580 599
  Modeline 	"768x576" 34.96 768 792 872 976 576 577 580 597
  Modeline 	"640x480" 31.13 640 664 728 816 480 481 484 502
  Modeline 	"640x480" 29.75 640 688 720 800 480 483 487 498 +HSync -VSync
  Modeline 	"640x480" 28.83 640 664 728 816 480 481 484 500
  Modeline 	"640x480" 26.60 640 664 728 816 480 481 484 499
  Modeline 	"640x480" 23.86 640 656 720 800 480 481 484 497
  Modeline 	"1440x900" 106.00 1440 1520 1672 1904 900 903 909 934 +HSync -VSync

Section "Screen"
  DefaultDepth 16
  SubSection "Display"
    Depth      15
    Modes      "1024x768" "1024x600" "800x600" "768x576" "640x480" 
  SubSection "Display"
    Depth      16
    Modes      "1024x768" "1024x600" "800x600" "768x576" "640x480" 
  SubSection "Display"
    Depth      24
    Modes      "1024x768" "1024x600" "800x600" "768x576" "640x480" 
  SubSection "Display"
    Depth      8
    Modes      "1024x768" "1024x600" "800x600" "768x576" "640x480" 
  Device       "Device[0]"
  Identifier   "Screen[0]"
  Monitor      "Monitor[0]"


This has worked!
Apparently, the driver list is in one place the instructions to run it in another in this case the 50-monitor.
This is definitely not noob friendly but for those who can you can get an idea of how & where to write a xorg monitor section from scratch in M7.
I hope this helps somebody!

Well done, and it all helps the body of knowledge here.

The openchrome driver at M7 I used from a factory repo failed to load. I would really like to know where you sourced openchrome driver from for your first M7 install. AFAIK it’s not on the DVD/liveCD, so what repo and what driver release if known? :question:


When I originally installed M7 about 1.5-2weeks ago the Openchrome driver was here:

Being the beta that M7 is I looked under Factory. I found there was no Openchrome there now. So I typed in Unichrome & used that, my post was then the rest of the story.

Hello, I have read fast through the postings.
If I have not missed anything:
the openFATE thread
#308357: Replacement for Sax2 in 11.3](
had not been mentioned before, had it?
Greetings pistazienfresser

Well, that last comment ( #5 ) in that openFate thread is mine :slight_smile:

Thanks, but WTF is going on! I think it was there when I checked over a week ago.

When I tested M5 (IIRC) both openchrome and chrome9 drivers were in OBS Factory, but they both failed with loading errors. Unichrome driver was installed from the distribution snapshot oss repo. That worked ok. When I upgraded to M7 using zypper dup at the announcement weekend (i.e. early), I checked OBS factory and the same openchrome and chrome 9 releases were still there, so I used my installed versions and they still failed to load, and used unichrome again.

When you picked up openchrome from OBS factory, you may have got an updated one being tested, if it loaded correctly. The fact it’s gone again may hopefully mean it’s being upgraded for RC1, due very soon. Chrome9 (unreliable) and unichrome (better) are there in OBS factory now. However unichrome is included in the Milestone’s oss repo, best to use it from there I would have thought.

BTW, openchrome has gone from OBS 11.2 as well as factory. IIRC that user tends to provide same driver release for both those repos. Hopefully it will be back in there soon. With 11.2 milestones, openchrome wasn’t available much before final release and has never been delivered with the distro :(.

Looks like the debate is over on sax2 :-(. I just started testing in earnest today 11.3 RC 1 and am stuck. I tried to compile the NVidia driver from source (aka “the hard way”) and it compiles fine, but I can’t “rmmod” the “nouveau” driver! And the card doesn’t seem to recognize my monitor.

On 11.2 I simply fired up sax2, poked in a VESA 1152x864 monitor, saved everything, and it worked. I think my preferred workaround is to get the proprietary NVidia driver up - that’s what I’m using on 11.2 on this machine and it does everything. I’m willing to try nouveau if it can do all the Compiz eye-candy :wink:

So where do I start? How can I get the nouveau driver out of the way?

Its difficult to give good advice, not knowing (1) your PCs hardware, and (2) your experience level with Linux and with openSUSE.

So with my not knowing anything, please do NOT take insult if I say too much, or too little. You probably could start by reading this to be more familiar with graphic drivers and openSUSE: openSUSE Forums - View Single Post - openSUSE Graphic Card Practical Theory Guide for Users

Now assuming the noveau driver is not working, the first thing to try is to boot with the “nomodeset” option that is clearly described in the 11.3 release notes. Note this is NOT nomodeset=1 (as I mistakenly typed above), but just ‘nomodeset’ . That should allow your PC to boot with nVidia driver.

You can try to tune that driver by using the 11.2 xorg.conf on 11.3.

Back to the release notes, I quote:

Initializing Graphics with KMS (Kernel Mode Setting)

With openSUSE 11.3 we are switching to KMS (Kernel Mode Setting) for Intel, ATI and NVIDIA graphics, which now is our default. If you encounter problems with the KMS driver support (intel, radeon, nouveau), disable KMS by adding nomodeset to the kernel boot command line. To set this permanently, add it to the kernel command line in /boot/grub/menu.lst. This option makes sure the appropriate kernel module (intel, radeon, nouveau) is loaded with modeset=0 in initrd, i.e. KMS is disabled.

In the rare cases when loading the DRM module from initrd is a general problem and unrelated to KMS, it is even possible to disable loading of the DRM module in initrd completely. For this set the NO_KMS_IN_INITRD sysconfig variable to yes via YAST, which then recreates initrd afterwards. Reboot your machine.

On Intel without KMS the Xserver falls back to the fbdev driver (the intel driver only supports KMS). On ATI for current GPUs it falls back to radeonhd. On NVIDIA without KMS the nv driver is used (the nouveau driver only supports KMS).

For the proprietary nvidia driver you need to black list the nouveau driver in the /etc/modprobe.d/50-blacklist.conf (ie add the line: blacklist nouveau). After that you should be able to build the driver successfully.

  1. The nouveau driver is working. I get a screen and it’s 1024x768. I want it to be 1152x864, which is what it is on 11.2 / NVidia driver.
  2. I tried booting with “nomodeset” but the nouveau driver is still getting loaded and is still not removable. I’ll try the blacklist next.
  3. The 11.2 xorg.conf doesn’t help either. I copied it over from the 11.2 partition, changed the driver from “nvidia” to “nouveau” and rebooted. Still stuck at 1024x768.

OK - this is what I’m about to try. But shouldn’t the other stuff have worked with the nouveau driver?

This is bizarre - I added “blacklist nouveau” and the nouveau driver is still loaded and still unremovable! But in looking at 50-blacklist.conf it is also blacklisting every known framebuffer driver!

list all framebuffer drivers, some of them tend to crash during boot

they are either compiled into the kernel, or vesafb is active

X works fine without them, rcfbset can load them if really required

sed -e ‘//drivers/video/..(o|ko)$/{s@^./@@;s@..*$@@;p};d’

If it helps, here’s an “lspci”

00:00.0 RAM memory: nVidia Corporation MCP61 Memory Controller (rev a1)
00:01.0 ISA bridge: nVidia Corporation MCP61 LPC Bridge (rev a2)
00:01.1 SMBus: nVidia Corporation MCP61 SMBus (rev a2)
00:01.2 RAM memory: nVidia Corporation MCP61 Memory Controller (rev a2)
00:02.0 USB Controller: nVidia Corporation MCP61 USB Controller (rev a2)
00:02.1 USB Controller: nVidia Corporation MCP61 USB Controller (rev a2)
00:04.0 PCI bridge: nVidia Corporation MCP61 PCI bridge (rev a1)
00:05.0 Audio device: nVidia Corporation MCP61 High Definition Audio (rev a2)
00:06.0 IDE interface: nVidia Corporation MCP61 IDE (rev a2)
00:07.0 Bridge: nVidia Corporation MCP61 Ethernet (rev a2)
00:08.0 IDE interface: nVidia Corporation MCP61 SATA Controller (rev a2)
00:08.1 IDE interface: nVidia Corporation MCP61 SATA Controller (rev a2)
00:0d.0 VGA compatible controller: nVidia Corporation C61 [GeForce 6150SE nForce 430] (rev a2)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:06.0 Mass storage controller: Silicon Image, Inc. PCI0680 Ultra ATA-133 Host Controller (rev 02)
01:0e.0 FireWire (IEEE 1394): Texas Instruments TSB43AB23 IEEE-1394a-2000 Controller (PHY/Link)

and a dmesg

0.000000] Linux version 2.6.34-9-desktop (geeko@buildhost) (gcc version 4.5.0 20100604 [gcc-4_5-branch revision 160292] (SUSE Linux) ) #1 SMP PREEMPT 2010-06-03 18:33:51 +0200
0.000000] Command line: root=/dev/disk/by-id/ata-HDT722525DLAT80_VDR41BT4FL1Z8J-part1 apm=off noresume edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe vga=0x317


0.475211] vesafb: framebuffer at 0xe0000000, mapped to 0xffffc90003100000, using 3072k, total 262144k
0.475218] vesafb: mode is 1024x768x16, linelength=2048, pages=1
0.475222] vesafb: scrolling: redraw
0.475226] vesafb: Truecolor: size=0:5:6:5, shift=0:11:5:0
0.475494] bootsplash 3.1.6-2004/03/31: looking for picture...
0.475498] bootsplash: silentjpeg size 157558 bytes
0.490169] bootsplash: ...found (1024x768, 80639 bytes, v3).
0.512375] Console: switching to colour frame buffer device 124x44
0.519542] fb0: VESA VGA frame buffer device


3.114843] [drm] nouveau 0000:00:0d.0: Detected an NV40 generation card (0x04c000a2)
3.119744] [drm] Initialized nouveau 0.0.16 20090420 for 0000:00:0d.0 on minor 0

and lsmod|grep nouveau

nouveau 553248 0
ttm 65906 1 nouveau
drm_kms_helper 33008 1 nouveau
drm 221762 3 nouveau,ttm,drm_kms_helper
i2c_algo_bit 6728 1 nouveau
button 6989 1 nouveau

Well - I re-installed using the “minimal server” configuration - no X at all - and I still see “drm” and “nouveau” getting loaded and not capable of being removed with “rmmod”. Are they compiled into the kernel by some chance?

I’m going to go over to the bug database - something’s dependent on something here.

Please read this post of mine in case it might help:
openSUSE Forums - View Single Post - 11.3 -RC1 nvidia driver

Yeah - NO_KMS_IN_INITRD got the NVidia proprietary driver installed and my screen to 1152x864. So I suppose I should try backing out “nvidia” and seeing if the xorg.conf will play with “nouveau”. Or is this card a known non-compatible for “nouveau”??

The “nouveau” is in fact, quite new, and I think it fair to say we are all learning about what it can and what it can not do, and we are all learning about what cards it works well with, and which ones it does not like. For example it seems to like my GeForce 8400GS and it seems to like my GeForce GTX260. But it does NOT like my GeForce FX5200.

Could it be there is something OTHER than the resolution in your old xorg.conf file that causes the “nouveau” driver to not accept a resolution higher than 1024x768? I assume you changed the device driver from what ever you had in 11.2 to “nouveau” for 11.3 in that file?

Also note, in 11.3 there are a series of directories under /etc/X11/xorg.conf.d/ such as the 50-device.conf where one can take selected entries from the 11.2 xorg.conf and add them there in 11.3. It is possible by a judicious selection of such entries out of 11.2’s xorg.conf into 11.3’s directory mentioned, you can tune the nouveau driver to the resolution you are looking for.

This sort of “tuning” is something that is new to all of us, and anything users in our community can learn, and then turn around and share with the community, would benefit all of us.

Good luck with your efforts, and thank you for contributing to the testing of openSUSE-11.3 RC1.

If you’re still having problems with screen res, rather than C&P your whole xorg.conf. Why not try what I did in post 22? When I did that it didn’t seem to matter what driver was in place.

Yeah - once I get everything else shaken down, I might go hunting for a way to configure “nouveau”. So far I’ve only found one other issue in RC1 - “fftw” (2) seems to be missing from the repo. I had to get it from the 11.2 repo.

Still, I will probably need the NVidia proprietary driver in the end, since I will want to experiment with CUDA and OpenCL and don’t know if “nouveau” is even supporting all that magic yet. I’ve also got a laptop with an ATI card that I’ll need to test, but I’m not expecting any difficulties with that because Linux recognizes the “monitor”.

The funny thing about all this is that the openSUSE used to recognize this monitor. I was experimenting with some NVidia Xen stuff and it just stopped working. Either the data got pulled from the open source tables because there was an IP issue, or something in the circuitry got trashed but not enough to totally smoke the monitor.

“Bizarre NVIDIA HANNS G monitor problem - openSUSE Forums

Hello Oldcpu

digging for configuration videocard i stumbled upon this link

Xorg - ArchWiki

I think you will find a few answers to the questions in this thread.

Thank, there is a lot of good stuff there !!

What needs to be done is to go through it all, to see which parts are applicable to the openSUSE implementation.

I suspect a separate wiki page will need to be made of any entries associated with editing files under the /etc/X11/xorg.conf.d/ directory.

In fact I have started writing an openSUSE graphics configuration wiki on what to do in 11.3 when graphics do not work (where there is no sax2 available) to address the action on me in openSUSE bug 608237 but I have not “gone public” with this because it NEEDs work on the UDEV section (which I may just remove as I do not think I will have time to learn this) and it NEEDs to be moved to an area different from where it is located (under ‘oldcpu’ is NOT the right place) and it NEEDS to be submitted to the wiki team for review

… I have not advised wiki team yet of its existence because I do not think I have the stamina to put up with the "hey your format is garbage, you ignored the guidelines , we have a process, … why are you ignoring it …etc etc … " this may get from the wiki team. Nor do I have the time to dig out and review the massive wiki team guidelines. … So at the moment, I’m not exactly sure where I will go from here, … 1/2 of me says just delete the entire thing and forget the entire thing … The other 1/2 of me says to just say the heck with it and dump this incomplete wiki on the wiki team and ask for a volunteer to polish it and have it complete/approved for the openSUSE-11.3 GM release. I watched the wiki team mailing list for a while and quickly learned I could not follow what was going on, and also learned that anyone who criticized the complexity of their process was immediately criticized back with inference that they were lacking a few brain cells :cry: with a note that the wiki process was not complicated … and I need none of that comment on my already agreed lack of brain cells :P. Hence I’m thinking of just quiting here and deleting what I thru together.

I have NOT posted about this yet in the wiki team area because I am NOT ready for that criticism/comment. Maybe in a day or two I will be ready.