Alienware 15(2015) 2 x M.2 SSD + SSHD, Grub fails to recognize W10

Hello, I gave in and decided to get myself a gaming laptop, this is an Alienware 2015, 15" laptop.

I decided to give it 2 M2 sticks and 1 SSHD.

One M2 stick has W10 and formatted SSHD with 2 partitions. One Windows dedicated partition and one Shared.
One M2 stick has OpenSUSE LEAP 42.2.

I first had some issues even booting from installed LEAP 42.2 since the W10 was automatically installed as Intel Secure Boot setting, and AHCI boot incapable. Eventually, I was able to access the M2 with OpenSUSE on it. At the initial boot, the Boot Loader and Grub detected W10 Windows Boot Manager.

After checking LEAP installation(which I will ask for help in another thread), I gave it a reboot. At the reboot the Windows Boot Manager from GRUB menu disappeared. It seems to have been gone for good.

W10 seems 100% fine, I can boot from it fine. Also, if I interrupt the boot, and boot from OpenSUSE M2, it boots fine to OpenSUSE.

Since then, os-prober does not detect W10, and Boot Loader is not detecting W10 either.

I have no idea what’s going on. How did it detect the OS the first initial boot after fresh install, but never again? Could someone help me shove the Windows Boot Manager back to the Grub Menu please?

You probably installed in MBR mode instead of EFI. Different OS can not see on another to chain if using different boot methods

BTW what is a M2 stick?? Something Alien :stuck_out_tongue:

I don’t think it’s MBR, because there is no “usual” MBR partition on the W10 M2

M.2 SSD I mean.

Please provide more details on how you managed to achive that.

I’m not quite sure what you did here: Using the UEFI boot selection?

Please provide more information.

Start your openSUSE system, open a terminal, become “root” and provide the results returned by the following commands:

# dmidecode -t 1
#  -d /sys/firmware/efi ] && echo "EFI boot" || echo "Legacy boot"
# od -An -t u1 /sys/firmware/efi/vars/SecureBoot-8be4df61-93ca-11d2-aa0d-00e098032b8c/data
# efibootmgr -v
# parted -l



There is no such thing as a MBR partition there can be and should be a EFI partition on the boot drive if any of the os boot EFI

If booting in EFI mode you should see grub2-efi in the Yast boot section not just grub2

the W10 Drive has:
100MB EFI partition, 450MB Recovery and classic C partition.

This is an extension to:

As for achieving boot on linux drive this is how it happened simplified:

  1. W10 fresh installed on one M2.
  2. SSHD partitioned and loaded
  3. with external DVD drive, OpenSUSE LEAP 42.2 KDE installed on the other M2. 2 Partitions. SWAP and Root.
  4. Could not boot from the OpenSUSE SSD.
  5. Changed W10 to AHCI compatible
  6. BIOS set to AHCI mode
  7. BIOS secure boot disabled
  8. BIOS Legacy boot enabled
  9. BIOS Legacy allowed me to boot from OpenSUSE. OpenSUSE boot loader could see the Windows Boot Manager
  10. Initial update + reboot, and OpenSUSE could no longer read Windows Boot Manager.

As for output from terminal commands. I will do that as soon as I am booting from OpenSUSE again, right now I am still tweaking things on W10.

Legacy is MBR boot You must boot the installer media in EFI mode to boot the result in EFI mode all OS must use the same boot method to be able the chain between them

There should be a EFI boot partition on the drive that has Windows use that for you openSUSE EFI boot mounted at /boot/efi (note do not format that partition!)

Right now, re-installing OpenSUSE is definitely a viable option, because I spent very little time setting it up, because I only bought this laptop this past Friday.

Should I re-install OpenSUSE in EFI mode with just / and swap?

Sounds like MS Windows 10 was installed to boot with UEFI.

So openSUSE ist installed to be booted in Legacy mode.

You switched your UEFI to Legacy mode in order to boot openSUSE. So, did you switch it back to UEFI mode in order to boot MS Windows 10 again or can you boot MS Windows 10 while your UEFI is still switched to Legacy mode?

As far as i know you have to use UEFI boot mode for openSUSE as well if your MS Windows is installed in UEFI mode.

But there is no need to reinstall openSUSE in order to switch it from Legacy boot mode to UEFI boot mode.



When I switch back to UEFI mode from BOOT,
there is literally no option to boot from OpenSUSE SSD.

I know even from UEFI boot, I can at least access boot from each drive, but not this case. I can only boot into the 2nd SSD only in Legacy mode.

I am not sure if this is alienware bios problem, or linux problem.

I never ran into the same issue on lenovo nor panasonic.

I’ve only done one UEFI W10 + LEAP installation, so my experience is limited. IINM besides installing in UEFI mode, the disk you’re installing the system on has to be gpt, not mbr.

Yes, that wont work as long as your openSUSE is not properly setup to be booted in UEFI mode.

I can’t tell you how to make MS Windows 10 to be booted in Legacy mode.

But i can help you to set up your openSUSE (i.e. GRUB2) so that you can boot it in UEFI mode. This then will enable you to start MS Windows 10 from the GRUB2 boot menu as well.

However, without the information i asked for i can’t give you any proper advice.



Just a note, though strictly speaking you do not have to have a separate home it is recommended you have /home on its own partition because that isolates your data and settings from the system in case you want to switch OS or reinstall. Also DO NOT use a Windows partition for /home the Windows file systems are not designed for Linux and things will break :’(

Hello susejunky,

can we set up the EFI for OpenSUSE after it has laready been installed with / and swap partitions only?

gogalthorp. I appreciate the suggestion for separate /home but personal history and experience taught me so far, due to the customization I do, having separate /home partition would be extremely inefficient for me compared to just cloning /home into a back up drive, because often distribution upgrade or changing distribution completely breaks the OS for me. I rather save/backup the data for specific computer to be installed specifically somewhere, but having a separate /home if anything has always given me grief due to unflexible size of partitions.

dmidecode -t 1
# dmidecode 3.0
Getting SMBIOS data from sysfs.
SMBIOS 2.8 present.

Handle 0x0001, DMI type 1, 27 bytes
System Information
        Manufacturer: Alienware
        Product Name: Alienware 15
        Version: A00
        Serial Number: GDDXK12
        UUID: 4C4C4544-0044-4410-8058-C7C04F4B3132
        Wake-up Type: Power Switch
        SKU Number: Alienware 15
        Family: Alienware 15

 -d /sys/firmware/efi ] && echo "EFI boot" || echo "Legacy boot"
Legacy boot
od -An -t u1 /sys/firmware/efi/vars/SecureBoot-8be4df61-93ca-11d2-aa0d-00e098032b8c/data
od: /sys/firmware/efi/vars/SecureBoot-8be4df61-93ca-11d2-aa0d-00e098032b8c/data: No such file or directory

efibootmgr -v
Fatal: Couldn't open either sysfs or procfs directories for accessing EFI variables.
Try 'modprobe efivars' as root.
parted -l
Model: ATA ST2000LX001-1RG1 (scsi)
Disk /dev/sda: 2000GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 1      1049kB  1783GB  1783GB  primary  ntfs         type=07
 2      1783GB  2000GB  218GB   primary  ntfs         type=07

Model: ATA SAMSUNG SSD PM85 (scsi)
Disk /dev/sdb: 128GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: pmbr_boot

Number  Start   End     Size    File system     Name     Flags
 1      181MB   8768MB  8587MB  linux-swap(v1)  primary
 2      8768MB  117GB   109GB   ext4            primary  legacy_boot

Model: ATA WDC WDS250G1B0B- (scsi)
Disk /dev/sdc: 250GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size    File system  Name                          Flags
 1      1049kB  473MB  472MB   ntfs         Basic data partition          hidden, diag
 2      473MB   578MB  105MB   fat32        EFI system partition          boot
 3      578MB   595MB  16.8MB               Microsoft reserved partition  msftres
 4      595MB   250GB  249GB   ntfs         Basic data partition

Reviewing this, should I really re-install and MAKE SURE that it is EFI mode? Also, could someone explain how to verify that, I usually always installed with / and swap, with just one SSD in at a time, and never had to change much from the installation configuration.

I do recall installing boot in MBR for my toughbook installation where a 500GB SSD holds all 2 OS + Shared partition.

To boot in EFI mode you must have a efi boot partition some where to handle the boot code handoff from the UEFI

Ways to know if using EFI boot

1 there is a /boot/efi directory
2 Yast-bootloader shows boot code to use grub2-efi not just grub2

If you do not have the above you boot legacy (MBR)

I think you can change by first setting to mounting the efi boot partition at /boot/efi in Yast Note you can have your own efi boot partition on the same drive as openSUSE or use the existing one and share with Windows. Note2 that an efi boot partition has special type EF00 that shows it is the EFI boot and is FAT32 formatted. Note3 if you want to use secure boot be sure to check the box for it.

then in the bootloader section change the boot code to grub2-efi and be sure scan for foreign OS box is checked that should reinstall grub in efi mode

I found a problem.

has no efi directory. Is there any way to load something there after installation.

If you say no, I’ll take that as a que to re-install right away.

No, /boot/efi of type ef00 and formatted vfat is a unique partition between 100~260MB (Think it can be up to 512MB) on a gpt type disk.

Then the system BIOS/UEFI will recognize and when the systems install, eg openSUSE, Win7 up if the system is a) set to UEFI booting and b) install media is booted from a medium that is designed to boot for a UEFI system. For example if a Win disk is prepared via say Rufus you can select either/both UEFI or Legacy (MBR) boot disks. The openSUSE install medium will take it’s lead from the BIOS settings UEFI/Legacy on what method to use.

So, from your output Windows is booting in uefi mode, so in your install you need to use /dev/sdc2, set the partition to /boot/efi and NOT TO FORMAT… Or create a partition on /dev/sdb say 100MB set the type to ef00 and format to vfat, then re-install…

So in your case;

/dev/sdb1 swap
/dev/sdb2 /boot/efi
/dev/sdb3 /
/dev/sdb4 /home

Here is one of my test setups;

sda      8:0    0  29.1G  0 disk 
├─sda1   8:1    0   260M  0 part /boot/efi <- Common efi for SLE/WinX
├─sda2   8:2    0    16M  0 part <-WinX reserved
├─sda3   8:3    0  20.9G  0 part <- WinX
└─sda4   8:4    0     8G  0 part [SWAP] <- swap never used but there...
sdb      8:16   0 111.8G  0 disk 
├─sdb1   8:17   0    40G  0 part / <- SLED 15
└─sdb2   8:18   0  71.8G  0 part /data <- My data (no /home...)