After using Yast sound to add sound card . . . no sound?

Folks:

Yesterday, while trying to listen to a voicemail message in TW as it installs I could barely hear the sound. I added a “volume” applet in theMATE toolbar and sound was set for maximum volume, but barely audible.

I looked for a “sound” preferences app and found nothing. Then looking through the long list of Yast items, found “Yast sound” . . . in there were two options for “sound card”?? I clicked edit and then the “add item quickly” ??? (something like that) . . . and it showed as “card 0”???

I tried to again listen to the voicemail, but this time, silence.

I “quickly added” the second line item, showing as “card 1”??? and clicked go in the message . . . again, total silence.

So, TW went from barely able to hear the sound to no sound after adding the card(s)???

Is this a known issue in TW? I long ago added Packman repo to this install.

I rebooted into Manjaro yesterday in the same machine and sound was there. I’m in LM this morning . . . sound is working. How to get basic sound working in TW??

Hi
Using pulseaudio or pipewire?


inxi -A

I use just pipewire along with JamesDSP…


inxi -A


Audio:
  Device-1: Intel C610/X99 series HD Audio driver: snd_hda_intel
  Device-2: AMD Baffin HDMI/DP Audio [Radeon RX 550 640SP / 560/560X]
    driver: snd_hda_intel
  Device-3: NVIDIA driver: snd_hda_intel
  Sound Server-1: ALSA v: k5.18.6-1-default running: yes
  Sound Server-2: PipeWire v: 0.3.52 running: yes

@malcolmlewis:

Had to reboot out of LM to check that in TW.

I didn’t “make any conscious decision” on that choice. Whatever “the system” had selected. Back in the PPC day we had to fiddle with ALSA to get sound fired up after a fresh install. I don’t listen to music or videos much, but I would hope for basic sound functionality . . . .

:~> inxi -A
Audio:
  Device-1: Intel 82801JI HD Audio driver: snd_hda_intel
  Device-2: NVIDIA GK110 High Definition Audio driver: snd_hda_intel
  Sound Server-1: ALSA v: k5.18.6-1-default running: yes
  Sound Server-2: PulseAudio v: 16.0 running: yes


@non_space

Does the following produce anything?


speaker-test -c 2

Your on MATE? If so nothing in the settings?

Yep, in MATE . . . added the sound applet to the toolbar, set to max volume. I just checked the Google Voicemail message again, and this time there was “sound” . . . but barely audible. So, possibly shutting down and rebooting back into TW, now some recognition of the sound card that didn’t take place after running Yast?

Some sound is better than “no sound” . . . I don’t know if this is a “Frontier Communications” problem, in other words the rep from Frontier was barely speaking?? I’ll have to see if I can play music or something . . . .

But, running your speaker-test command, did produce, what “pink noise” . . . and it repeats the test until I ctrl -c’d out of it??

> speaker-test -c 2

speaker-test 1.2.7

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
Using 16 octaves of pink noise
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 96 to 1048576
Period size range from 32 to 349526
Using max buffer size 1048576
Periods = 4
was set period_size = 262144
was set buffer_size = 1048576
 0 - Front Left
 1 - Front Right
Time per period = 10.947866
 0 - Front Left
 1 - Front Right
Time per period = 10.945983
 0 - Front Left
 1 - Front Right
^C


[edit:] Checked a YT video and there is now sound. This might be pointing to the Frontier reps voice as being inaudible?? But, then, again, after running the Yast move there was “no voice.” Anyway, now there is voice. Don’t know if any reason to go to pipewire?? [/edit]

[edit:] Checked a YT video and there is now sound. This might be pointing to the Frontier reps voice as being inaudible?? But, then, again, after running the Yast move there was “no voice.” Anyway, now there is voice. Don’t know if any reason to go to pipewire?? [/edit]

For the majority of users, there should be no reason to require audio driver configuration with YaST. If you still think there are issues, run the alsa-info.sh diagnostic script as described here…
https://en.opensuse.org/SDB:Audio_troubleshooting#First_method_to_run_script
…and post the link (to the output) that it generates here.

@deano_ferrari:

Thanks for the follow-up on it . . . I’ll check into it when I get back to TW. Seemingly, there were no GUI settings for Sound that showed up in MATE edition TW . . . and, then compared to LM this morning, the Sound applet did not link to >Preferences . . . it just shows the cig bar to raise and lower the volume.

As I mentioned, back in the day, ten years or so back in PPC linux, ALSA had to be launched from the console and fiddled with there. Not spending too much time with sounds in TW, when I had this semi-important phone voicemail to listen to while in TW . . . combined with barely speaking agent . . . created the attempt to use YaST Sound to “get better sound” . . . which perhaps “un-did” something to then create . . . silence???

This reads more like a level setting than a driver config issue. Since you are using PulseAudio, I would start with checking such levels via the graphical pavucontrol utility.

@deano_ferrari:

So, now that I’ve sobered up . . . my only excuse is that in one of the recent large TW package upgrades the OEM “main menu” in the toolbar was removed?? and I had to add a “compact” or “brisk” menu to the toolbar . . . which is a bit “different” . . . and in fact there is a “Sound & Video” option, and in there is “Sound” and the level is set at 100% . . . . I tested the “speakers,” only “front left” worked . . . if that means anything . . . figuring that the machine is a “mono” speaker?? “Front right” did not work.

I looked for “pavucontrol” and that doesn’t show in the GUI . . . I tried to launch it in the console by typing “pavucontrol” . . . that didn’t work. I put “pulseaudio” in the console and it said, “Already running” . . . no graphical controls showed up in the console . . . .

Anyway, I think it’s “under control” . . . it was a series of errors caused by responding to a barely audible gal leaving a message that set off other errors . . . .

I still recommend that you run the alsa-info.sh diagnistic script as already advised. Share the link that it provides here, and someone can check all the pertinent details.

I looked for “pavucontrol” and that doesn’t show in the GUI . . . I tried to launch it in the console by typing “pavucontrol” . . . that didn’t work.

No errors of any kind (when launched from the user console)? Anyway, perhaps show us the output from

pactl list

I put “pulseaudio” in the console and it said, “Already running” . . . no graphical controls showed up in the console . . . .

There should be no need to do that - the daemon is already running from when you logged in to your preferred desktop. :wink:

@deano_ferrari:

So I ran the script and went through the steps to get:

Your ALSA information is located at http://alsa-project.org/db/?f=be31d8973c32e9ce0a6b923231aa4f8cca8f3447
Please inform the person helping you.

“pactl list” shows a very large list of data . . . numerous modules and so forth. Sound is now working, so I don’t believe there is any need to scroll down through a long list???

[edit]: I see now in running a zypper update that I must have locked “pipewire” some time back when there was some dependency issue with pipewire??? [/edit]

Yes, if sound is now working there is no point wasting any further time on it. :wink:

@deano_ferrari:

Well, I only ran that script because you wanted me to . . . sound was working then . . . etc. : - ))

I found my previous thread about the issues with “pipewire” where I guess someone must have recommended that I lock it for that zypper could upgrade the TW system . . . . Has that issue been resolved so that pipewire could be unlocked??

Or, no reason to mess with it . . . pulseaudio and/or ALSA are all over the sound production aspect of the system???

Yep, I get that…however these steps are for your own diagnostic education :wink:

No need to trawl through such output when things are now reported as working.

I found my previous thread about the issues with “pipewire” where I guess someone must have recommended that I lock it for that zypper could upgrade the TW system . . . . Has that issue been resolved so that pipewire could be unlocked??

I’ve been using pipewire (openSUSE Leap 15.3) for months with no issue. I have no idea about what you encountered, but easy enough to switch over to it. If you need guidance with that, I recommend starting a new thread dedicated to that.

Thanks for the pointers . . . SUSE still is “a whole new bag” in my linux learning process . . . .

OK on the new thread for pipewire . . . . I don’t really do enough with sound to make it a “need to know” . . . I just saw malcolmlewis’ comment about "I use pipewire && JB Morgan for my sound effects . . . " ??? Something like that. It only came on my radar awhile back when it caused a jam up for zypper . . . .

zypper readily installed whatever it took to make it happen:

karl@erlangen:~> systemctl list-unit-files --user '*wire*' 
UNIT FILE                        STATE    VENDOR PRESET
pipewire-pulse.service           **disabled disabled     **
pipewire-session-manager.service **alias    **-            
pipewire.service                 **enabled  ****disabled     **
wireplumber.service              **enabled  enabled      **
wireplumber@.service             disabled disabled     
pipewire-pulse.socket            **enabled  enabled      **
pipewire.socket                  **enabled  enabled      **

7 unit files listed. 
karl@erlangen:~> systemctl list-units --user '*wire*'      
  UNIT                   LOAD   ACTIVE SUB     DESCRIPTION                       
  pipewire-pulse.service loaded active running PipeWire PulseAudio 
  pipewire.service       loaded active running PipeWire Multimedia Service 
  wireplumber.service    loaded active running Multimedia Service Session Manager
  pipewire-pulse.socket  loaded active running PipeWire PulseAudio 
  pipewire.socket        loaded active running PipeWire Multimedia System Socket 

LOAD   = Reflects whether the unit definition was properly loaded. 
ACTIVE = The high-level unit activation state, i.e. generalization of SUB. 
SUB    = The low-level unit activation state, values depend on unit type. 
**5 loaded units listed.** Pass --all to see loaded but inactive units, too. 
To show all installed unit files use 'systemctl list-unit-files'. 
karl@erlangen:~> 

When running pulseaudio the audio applet in the system tray frequently experienced surprising changes upon upgrading the system. Since switching to pipewire the applet looks the same. No more changes encountered.

karl@erlangen:~> inxi -Ay132 
**Audio:     Device-1:** AMD Baffin HDMI/DP Audio [Radeon RX 550 640SP / 560/560X] **driver:** snd_hda_intel 
           **Device-2:** Advanced Micro Devices [AMD] Starship/Matisse HD Audio **driver:** snd_hda_intel 
           **Sound Server-1:** ALSA **v:** k5.18.6-1-default **running:** yes 
           **Sound Server-2:** PipeWire **v:** 0.3.52 **running:** yes 
karl@erlangen:~> 

@karlmistelberger:

Thanks for showing those commands . . . oddly, today I’m in Gecko Plasma rolling and checking those commands there brought “nothing found” . . . and same for “inxi” . . . “command not found”???

I guess I didn’t install it yet? And perhaps it isn’t using pipewire? I believe it comes with Packman already installed . . . .

Anyway, it’ll be a day or so before I rotate back to straight TW to check out the sound status . . . . As you mentioned it did seem like the sound applet was changing . . . intermittently . . . . Perhaps I’ll try to unlock pipewire then and see how that fares??

@et al:

I recently unlocked pipewire and running “inxi -A” now shows extra stuff . . . .

~> inxi -A
Audio:
  Device-1: Intel 82801JI HD Audio driver: snd_hda_intel
  Device-2: NVIDIA GK110 High Definition Audio driver: snd_hda_intel
  Sound Server-1: ALSA v: k5.18.9-2-default running: yes
  Sound Server-2: PulseAudio v: 16.0 running: yes
  Sound Server-3: PipeWire v: 0.3.54 running: yes

Ok, but there should be no need to have PulseAudio active (for most application use cases). Instead you can install “pipewire-pulseaudio” to cover for that scenario, and use pipewire exclusively. (That will remove the pulseaudio package.)

@deano_ferrari:

Alrighty, thanks for the suggestion on it . . . traditionally I have been a “belt AND suspenders” kind of a guy, so I guess now I am a “belt, suspenders, and belt” person??

I don’t mess with sound stuff too much, basically just trying to “keep up” with the TW rolling upgrades . . . but somewhere in the history pipewire got into dependency issues . . . now seemingly on the other side of them.

I’ll look into this combo package when I rotate back to TW . . . tomorrow possibly . . . .