Acer aspire 5738G, no sound, not correct resolution

I am a new Linux user and have a Acer aspire 5738G and i’m an opensuse 11.1 user.
I have problems with the resolution and the sound.

When i select in Sax2 the type of the screen (LCD 1366X768) the resolution menu under doesnt show this resolution to choose and i have to choose 1024X768 that is not correct.
Also when i login a message on the screen says:“The HDA intel ALC 888 Doesnt work” and a have no sound.

If anyone knows something about this problem please, help me because i’m a big SuseFan but i dont have yet good linux knowledge.

Reference your graphics, what driver are you using? Vesa ? Intel ? I note this linlap section on the 5738G: Acer Aspire 5738, 4736 [Linux Laptop Wiki]

You can check to see what driver is being used by typing:
grep -i driver /etc/X11/xorg.conf

Now, reference your sound, you could try working your way through the openSUSE audio troubleshooting guide:
SDB:AudioTroubleshooting - openSUSE

Note, when testing if you have sound, please copy and paste the following speaker-test into a Gnome terminal or a kde konsole:

speaker-test -Dplug:front -c2 -l5 -twav
Note Linux is case sensitive, and “D” is not the same as “d”. To stop the above test, while the konsole/xterm has the mouse focus, press <CTRL><C> on the keyboard. Note you should check your mixer settings (kmix if using KDE, and alsamixer if using Gnome) to ensure that PCM and Master Volume are set around 95%. Once you have basic sound established you can back off to lower volume levels. Note the test for surround sound is different.

If that test yields errors (and its not uncommon to get errors there), try instead this more simple test: speaker-test -c2 -l5 -twavYou should hear a female voice saying ‘FRONT LEFT’, ‘FRONT RIGHT’ five times. Its quite common that one of those speaker tests will work and one will NOT work, so don’t be distressed if that is the case. IF that test gives sound, stop now, post that the sound test gives sound, and we will look at other possible causes for your applications not giving you the sound you want (such as missing codecs, using the wrong packaged version … etc … ).

Or alternatively, for testing the simple playback, use aplay program. Prepare a WAV file and simply run like:

aplay -vv somefile.wav

With the option -vv, aplay shows the verbose information of the PCM device, and a VU-peak meter during playing the file.

Try those speaker-tests as both a regular user, and also with root permissions. If you have a headset, try with your headset plugged in, and also with your headset not plugged in (for speakers).

Assuming no sound, can you provide more very detailed information so a good recommendation can be given? For openSUSE-11.1, you can do that, with your laptop connected to the internet, by opening a gnome-terminal or a kde konsole and twice copy and paste the following into that terminal/konsole


Run it the 1st time with root permissions. It will ask if you wish to do an update of the script. Select YES.

Then run it again (as either a regular user or as root). This time it will diagnose your PC’s hardware and software configuration for audio, and it will post its output on the Internet/web. It will give you the URL of the web site. Please post that URL here. JUST the URL.

Also, please copy and paste the following commands one line at a time into a gnome-terminal or a konsole and post here the output: rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound… with that information I may be able to make a recommendation.

If you type:
that will show more information on your resolution (it won’t solve the problem, rather it will show information).

Thank you very much for your help

About Graphics
My graphics card is nvida geforce g105m cuda 512Mb

grep -i driver /etc/X11/xorg.conf

Driver “kbd”
Driver “synaptics”
Driver “mouse”
Driver “fbdev”


Screen 0: minimum 1024 x 768, current 1024 x 768, maximum 1024 x 768
default connected 1024x768+0+0 0mm x 0mm
1024x768 76.0*

About Sound

I didnt hear anything from the test commands

ALSA-Info script has been updated to v
To view the ChangeLog, please visit
Please re-run the script

I rerun the script but it didnt show anything

rpm -qa | grep alsa

rpm -qa | grep pulse

rpm -q libasound2

uname -a
Linux linux-klzm #1 SMP 2008-12-04 18:10:04 +0100 x86_64 x86_64 x86_64 GNU/Linux

cat /etc/modprobe.d/sound

options snd slots=snd-hda-intel

u1Nb.Fok4Y2QakF0:82801I (ICH9 Family) HD Audio Controller

alias snd-card-0 snd-hda-intel

Thanks , but I need that URL ! Its important !!

Was your PC connected to the internet when you ran it? Please, connect your PC to the Internet, and run it again. If it asks if you wish to share the information, select YES. It WILL give you a URL when it finishes.

If you can not get your PC connected to the Internet, then this will be VERY DIFFICULT. You can obtain the diagnostic file that way by typing
** /usr/sbin/ --no-upload **
which will then put the information under /tmp/alsa-info.txt and you can then take that file and copy and paste it to a paste bin site pastebin - Type, paste, share. and pass the URL, but this is a long and difficult way to do it.

Just run:
with your PC connected to the internet. It will give you a URL if you elect to share the information.

Dejavu …

… are you logged on this forum also using another handle (user = Aroda)? Thread here: Asus K50IN : No Sound No Graphic Driver - openSUSE Forums

anyway, the fbdev is the frame buffer driver and it is a VERY BASIC driver. Typically for a nVida graphic device, Note that:

  • vesa - the vesa driver. works on most graphic cards (nvidia, intel, ati), but is slow in performance. Comes with openSUSE.
  • nv - the open source (openGL) nividia graphic driver. Reasonable (average) performance in most cases. Comes with openSUSE.
  • nvidia - the proprietary nVidia driver. The best performance, but can be tempermental during kernel updates or xorg updates.

Please advise if you have no graphical desktop.

I am going to assume the “nv” openGL driver did not work, which is why you still have the frame buffer driver.

I recommend you reboot your PC, and when the green grub boot menu appears (where you select windoze, or openSUSE or openSUSE fail safe) select the openSUSE boot and press the “3” key (no quotes) to enter the value 3 in the options line. That will force a boot to run level 3, which is an text/ascii boot level.

When you get to the login prompt, log in as a regular user and enter your password. Then type ‘su’ (no quotes) and enter the root password in order to get root permissions.

Then backup your /etc/X11/xorg.conf file (just to be safe) noting that Linux the characters are case sensitive. You can backup by typing:

cp /etc/X11/xorg.conf /etc/X11/xorg.conf.mybackup

Once you have the backup, then try to see if the VESA driver will work. You do that by typing:

sax2 -r -m 0=vesa

and if that works, exit sax2. Note that is “zero equals vesa”.

Note it is slow so do not rush it. Note that assumes your PC has only 1 graphic hardware device. Note the last four characters in that command are “zero equals vesa”.

Then restart your pc by typing “shutdown -r now” and this time do NOT type 3.

If that does not work, try to force the vesa driver to a lower resolution. You can do that by typing:

sax2 -r -l -m 0=vesa

where that is “zero equals vesa” and that is a lower case “L” in “-l”.

Again, restart your pc with ‘shutdown -r now’ and do not type “3” this time.

In addition to restarting, you can also shutdown (halt) your PC by “shutdown -h now”

I am connected to the internet,
when i type /usr/sbin/ i dont see anything

kostas@linux-klzm:~> /usr/sbin/

no, im logged as konstantinoskyritsoglou

i tried both the two commands and sax2 turned my resolution to 800X600 without the selection of the proper resolution

Then adopt the second approach I noted in the above post:

Did not the first command give you the option to NOT accept its resolution? In which case it will take you to another menu item with resolution and monitor selections.

The second command (sax2 -r -l -m 0=vesa) will give 800x600. So that is expected for the second.

If the 800x600 is no good then restore the frame buffer if you prefer that.

And start consider the idea of installing a proprietary nVidia driver per the guidance here: NVIDIA - openSUSE I prefer the “hardway” approach, but many like the “repository” approach.

Can you also do me a favour … and that is run the command:

and then do a screen dump, and paste that screen dump to this site: ImageBam - Fast, Free Image Hosting and Photo Sharing and provide here the URL of the screen print.

I’ve had other users state they do not see a URL when the script completes (after one commands the script to UPLOAD/SHARE the uploaded data by moving the cursor to the left with the arrow key when the second acknowledgment occurs) and I want to see why myself via the screen dump what they get. Either there is a bug in the script, or users are making the same mistake all the time, or my explanations are pathetic. I suspect you are NOT selecting UPLOAD/SHARE (which I thought was intuitively obvious)

The problems with graphics card have solved
I 'm not sure if the 24bit colours that i selected are working right
Thank you very much

about the sound problems
with the screen dump you mean printscreen and paste to a file?

Great. Are you using the proprietary drivers now?


I’m mainly interested in the output of the diagnostic. If you run it with the no-upload option, it will create a text file. Post that text file on a pastebin site (I provided you a URL for the paste bin site) and then after you paste it, the paste bin site will give you a URL. Post that URL from the paste bin site here.

Then, I want to figure out WHY the script is not automatically posting its output on the web. It is supposed to. If you selected the SHARED/UPLOAD option (by moving the cursor over with your keyboard arrow key) it should paste the contents on the web, and give you a URL. I want to see a screen print when the script finally completes, because it SHOULD give you a URL. It does not according to you (and in some cases some others have encountered this) and I want to see EXACTLY what it does give via a screen print. You DID select the SHARED/UPLOAD option? Right?

One thing I do note which is obvious to me, but probably not to you, is you MUST remove alsa-driver-unstable-kmp-default. Many times having alsa-driver-unstable-kmp-default installed at the same time as alsa-driver-kmp-default WILL BREAK a users sound.

Do NOT install both.

After removing alsa-driver-unstable-kmp-default, you may need to re-install alsa-driver-kmp-default, … then reboot and test your audio.

Even if that does not work, do NOT re-install alsa-driver-unstable-kmp-default. It DOES NOT BELONG!

The first time i gave the command it gave me a URL:
ALSA-Info script has been updated to v
To view the ChangeLog, please visit Git - alsa-driver.git/history - utils/
Please re-run the script

Is this the URL you want?

No. Thats the change log. Please re-run the script.

I removed alsa-driver-unstable-kmp-default and there is no change.
the script /usr/sbin/ doesnt give me any URL

Please, can you follow what I asked in this post:

I think I was pretty clear about the no-load option. ie:

You can obtain the diagnostic file that way by typing

/usr/sbin/ --no-upload 

which will then put the information under /tmp/alsa-info.txt and you can then take that file and copy and paste it to a paste bin site pastebin - Type, paste, share. and pass the URL, but this is a long and difficult way to do it.

This is the 3rd time I have asked for this. If you can not figure this out, then I will bow out of this thread, as its intuitive to me, and I can not make it any more simple.

Maybe write a bug report on your sound, and maybe while helping you with your sound they can explain to you how to run the script. This is so easy for me, but its not working for you. Clearly my ability to explain this has failed (and I tried at least 3 times!) and I do not want to waste your time, nor my time, any more.

There is guidance how to write a bug report here:
Submitting Bug Reports - openSUSE

I believe thats because your pc is either not connected to the internet, or you are refusing to move the cursor over with your keyboard arrow key when asked if you wish to SHARE/UPLOAD the information.

Anyway, this is a waste of time.

Write a bug report.