Accessing @/home subvolume from live usb

Hi.

I’m using openSUSE Tumbleweed. After today’s update wifi stopped working, so I’ve decided to return to an earlier snapshot, foolishly without updating my backups. Now my system won’t boot at all. Before doing anything drastic, I want to recover a few new & updated files.

So I’ve booted into a Fedora live usb I\ve got at hand and mounted the system drive following this guide: https://www.cyberciti.biz/faq/linux-mount-an-lvm-volume-partition-command/. But I can’t see any files or folders under /home, even as root.

I found this post from 2022: /home is empty when exploring from bootable usb. Running sudo mount -o subvolid=5 /dev/nvme0n1p3 /mnt/rhome/ gives me the following error:

mount: /mnt/rhome: unknown filesystem type 'LVM2_member'.
       dmesg(1) may have more information after failed mount system call.

I can list btrfs subvolumes, and @/home is there:

ID 256 gen 31 top level 5 path @
ID 257 gen 210378 top level 256 path @/var
ID 258 gen 210269 top level 256 path @/usr/local
ID 259 gen 201739 top level 256 path @/srv
ID 260 gen 210374 top level 256 path @/root
ID 261 gen 210378 top level 256 path @/opt
ID 262 gen 210374 top level 256 path @/home
ID 263 gen 205446 top level 256 path @/boot/grub2/x86_64-efi
ID 264 gen 107806 top level 256 path @/boot/grub2/i386-pc
ID 265 gen 210374 top level 256 path @/.snapshots
ID 266 gen 210381 top level 265 path @/.snapshots/1/snapshot
...

Can anyone help me with this? Thanks.

Addition: I can see the files using Btrfs Assistant.

Update: First unmounting the disk and then directly mounting the sub-volume worked!

You need to provide the subvolume id in your mount command, but the command you use is using not the correct syntax to my understanding.

mount /dev/nvme0n1p3 -o subvolid=*<ID for path @>* /mnt/my-home

Extensive details: SDB:BTRFS - openSUSE Wiki

1 Like

That’s what I’ve tried. I think the problem was that I was mounting the whole volume first. Only mounting the home sub-volume worked.

Thanks.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.