zypper hangs at install

Hi Suse,

All zypper commands seem to work correctly, except update (and install). It hangs at the installation step, and doesn’t die.

It hangs after all this (hangs meaning nothing happens for ~4hours):

Loading repository data...
Reading installed packages...
Resolving package dependencies...

The following package is going to be upgraded:

Overall download size: 53.0 K. No additional space will be used or freed after the operation.
Continue? [YES/no]: YES
Retrieving package expat-2.0.1-88.16.1.x86_64 (1/1), 53.0 K (149.0 K unpacked)
Retrieving delta: ./rpm/x86_64/expat-2.0.1-88.15_88.16.1.x86_64.delta.rpm, 8.0 K
Retrieving: expat-2.0.1-88.15_88.16.1.x86_64.delta.rpm [done]    
Applying delta: ./expat-2.0.1-88.15_88.16.1.x86_64.delta.rpm [done]
Installing: expat-2.0.1-88.16.1 [0%]

Double ctrl-C kills the foreground process but there is the following rpm still running (which can be kill -9’ed only)

# ps aux | grep zyp
root      4446  0.0  0.0  30652  3248 pts/8    D    01:03   0:00 rpm --root / --dbpath /var/lib/rpm -U --percent --force --nodeps -- /var/cache/zypp/packages/repo-update/rpm/x86_64/expat-2.0.1-88.16.1.x86_64.rpm

My version details are:

# rpm --version
RPM version
# zypper --version
zypper 1.0.2
# cat /etc/issue
Welcome to openSUSE 11.1 - Kernel \r (\l).

thanks for the help,

> Applying delta: ./expat-2.0.1-88.15_88.16.1.x86_64.delta.rpm [done]
> My version details are:
> # cat /etc/issue
> Welcome to openSUSE 11.1 - Kernel \r (\l).

this may be a stupid observation/question (if so, please excuse my
ignorance, for i can’t see the answer to my Q in your post)…the
package to be installed is for a 64 bit system, is yours?

if yours is 64, then maybe try installing expat via YaST…and, if
that works ok you can assume something is flaky in zypper, and use
YaST to ‘update’ all currently installed yast bits (just right click
the box to the left of each piece and select the ‘update’
icon…then press accept…that should repair any funny bits…(some
say to first delete then install…you pick, that may be better…)

Have a lot of fun…

Thanks pall.

It is 64bit, yes, good point.

Expat is obviously an example, it hangs for any package.

And most importantly, YaST2>Software>Online Update also hangs at the “Loading the Package Manager” stage!

Quick fix: I was wrong about where YaST2 hangs. It hangs after “Check for Available Update” stage.

When I kill (ctrl+C) it, it shows on an “xmessage window”:

YaST got signal 2 at YCP file /usr/share/YaST2/clients/online_update_select.ycp:93

Fwiw, here is the ps ax output right before I kill YaST

# ps ax | grep -vE '(sshd)|(bash)'

    1 ?        Ss     0:02 init [3]  
    2 ?        S<     0:00 [kthreadd]
    3 ?        S<     0:00 [migration/0]
    4 ?        S<     0:00 [ksoftirqd/0]
    5 ?        S<     0:00 [migration/1]
    6 ?        S<     0:00 [ksoftirqd/1]
    7 ?        S<     0:07 [events/0]
    8 ?        S<     0:09 [events/1]
    9 ?        S<     0:00 [khelper]
   10 ?        S<     0:00 [kintegrityd/0]
   11 ?        S<     0:00 [kintegrityd/1]
   12 ?        S<     0:00 [kblockd/0]
   13 ?        S<     0:00 [kblockd/1]
   14 ?        S<     0:00 [kacpid]
   15 ?        S<     0:00 [kacpi_notify]
   16 ?        S<     0:00 [cqueue]
   17 ?        S<     0:00 [kseriod]
   18 ?        S<     0:00 [kondemand/0]
   19 ?        S<     0:00 [kondemand/1]
   20 ?        S      0:00 [pdflush]
   21 ?        S      0:12 [pdflush]
   22 ?        S<     0:24 [kswapd0]
   23 ?        S<     0:00 [aio/0]
   24 ?        S<     0:00 [aio/1]
   25 ?        S<     0:00 [kpsmoused]
   58 ?        S<     0:00 [ata/0]
   59 ?        S<     0:05 [ata/1]
   60 ?        S<     0:00 [ata_aux]
   63 ?        S<     0:00 [scsi_eh_0]
   64 ?        S<     0:07 [scsi_eh_1]
  195 ?        S<     0:00 [ksuspend_usbd]
  196 ?        S<     0:00 [khubd]
  583 ?        D<     0:09 [kjournald]
  653 ?        S<s    0:00 /sbin/udevd --daemon
 1364 ?        S<     0:00 [kauditd]
 1379 ?        S<     0:00 [kstriped]
 1428 ?        S<     0:00 [kjournald]
 1908 ?        Ss     0:00 /sbin/syslog-ng
 1911 ?        Ss     0:00 /sbin/klogd -c 1 -x
 1922 ?        Ss     0:00 /bin/dbus-daemon --system
 1934 ?        Ss     0:00 /sbin/acpid
 1998 ?        Ss     0:01 /usr/sbin/hald --daemon=yes
 2001 ?        Ssl    0:00 /usr/sbin/console-kit-daemon
 2002 ?        S      0:00 hald-runner
 2152 ?        S      0:00 hald-addon-input: Listening on /dev/input/event6 /dev/input/event5 /dev/input/event4
 2195 ?        S      0:00 hald-addon-acpi: listening on acpid socket /var/run/acpid.socket
 2196 ?        S      0:10 hald-addon-storage: polling /dev/sr0 (every 16 sec)
 2795 ?        Ss     0:00 /sbin/rpcbind
 2802 ?        S<sl   0:00 /sbin/auditd -s disable
 2804 ?        S<sl   0:00 /sbin/audispd
 2815 ?        S<     0:00 [rpciod/0]
 2817 ?        S<     0:35 [rpciod/1]
 2826 ?        S<     0:53 [nfsiod]
 2841 ?        Ss     0:00 /usr/sbin/rpc.idmapd
 2844 ?        Ss     0:00 rpc.statd --no-notify
 2846 ?        S<     0:00 [lockd]
 3158 ?        Ss     0:00 avahi-daemon: running [fermi-login.local]
 3208 ?        Ss     1:28 /usr/sbin/irqbalance
 3364 ?        Ss     0:00 /usr/sbin/cupsd
 3426 ?        Ss     0:36 /usr/sbin/ntpd -p /var/run/ntp/ntpd.pid -g -u ntp:ntp -i /var/lib/ntp -c /etc/ntp.conf
 3514 ?        Ss     0:00 /usr/lib/postfix/master
 3536 ?        S      0:00 qmgr -l -t fifo -u
 3545 ?        Ss     0:00 /usr/sbin/cron
 3550 ?        S      0:00 /usr/sbin/smartd
 3671 tty2     Ss+    0:00 /sbin/mingetty tty2
 3674 tty3     Ss+    0:00 /sbin/mingetty tty3
 3676 tty4     Ss+    0:00 /sbin/mingetty tty4
 3677 tty5     Ss+    0:00 /sbin/mingetty tty5
 3680 tty6     Ss+    0:00 /sbin/mingetty tty6
 4251 tty1     Ss+    0:00 /sbin/mingetty --noclear tty1
 9067 ?        S      0:00 pickup -l -t fifo -u
 9264 pts/2    S      0:00 su -l
 9400 pts/2    S      0:00 dbus-launch --autolaunch d2f223773c984c89331a62fa493ee8fd --binary-syntax --close-stderr
 9401 ?        Ss     0:00 /bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
 9603 pts/1    Ss+    0:00 -tcsh
11518 pts/2    S      0:00 /usr/lib/YaST2/bin/y2controlcenter -S
11547 pts/2    Sl     0:02 /usr/lib/YaST2/bin/y2base online_update -S qt
11551 ?        S      0:00 /usr/lib/GConf/2/gconfd-2
12095 ?        Ss     0:00 kdeinit Running...                           
12098 ?        S      0:00 dcopserver [kdeinit] --nosid --suicide       
12100 ?        S      0:00 klauncher [kdeinit] --new-startup            
12102 ?        S      0:00 kded [kdeinit] --new-startup                 
12110 ?        S      0:00 kio_file [kdeinit] file /tmp/ksocket-root/k  
12148 pts/5    S+     0:00 vi frag2-41-disp-bp86.batch
12152 pts/2    R+     0:00 ps ax
12154 pts/2    R+     0:00 kate -i
16995 ?        S      0:00 su
17697 ?        S      0:00 su rgb8
17778 ?        S      0:00 su
17808 ?        S      0:00 su rgb8
19498 ?        D      0:00 kded [kdeinit] --new-startup                 
21258 pts/0    S      0:00 su -l
21515 ?        Ss     0:00 /bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
23002 ?        Ss     0:00 /bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
23702 ?        D      0:00 ls --color=tty -ltr

Sorry for triple post but here is another bit of information, fwiw.

I thought I lost this, but the terminal where I first observed this problem was still open. It reads:

$ zypper up python
Loading repository data...
Reading installed packages...
Resolving package dependencies...

The following package is going to be upgraded:

Overall download size: 268.0 K. After the operation, additional 673.0 K will be used.
Continue? [YES/no]: YES
Retrieving package python-2.6.0-2.21.1.x86_64 (1/1), 268.0 K (1.1 M unpacked)
Retrieving delta: ./rpm/x86_64/python-2.6.0-2.19_2.21.1.x86_64.delta.rpm, 172.0 K
Retrieving: python-2.6.0-2.19_2.21.1.x86_64.delta.rpm [done]
Applying delta: ./python-2.6.0-2.19_2.21.1.x86_64.delta.rpm [done]
Installing: python-2.6.0-2.21.1 [error]
Installation of python-2.6.0-2.21.1 failed:
(with --nodeps --force) Error: Subprocess failed. Error: RPM failed: Command was killed by signal 9 (Killed).

Abort, retry, ignore? [A/r/i]: Killed

where, of course, I initiated the kill after several hours of waiting.

Thanks much.

> 1 ? Ss 0:02 init [3]

all above my head…sorry…

usually if there is a problem with yast it can be repaired with
zipper, or a problem with zipper is often repairable with yast…but,
when both are broke, and thousands and thousands are not, one has to
wonder what happened to yours!

is this a new install? or did it work for months and suddenly break?
(what did YOU do just before it broke?)

which version did you install? 11.1 or what??
what kinda hardware you on? did it run the openSUSE Live CD flawlessly?

how did you install? where did you get the install media?
downloaded–from where, opensuse.org or some other place? did you
md5sum check the iso prior to buring the disk? was it 100% perfect?
did you check the disk after burning also? any problems during the
install (any warnings you ignored?)

did you follow all the great advice in http://tinyurl.com/ycgm2bx ?

speak please, is very hard to guess which way to go to repair BOTH
zypper and yast on an unknown version, on unknown hardware with some
strange sort of unknown situation…

are you trying to run in a VM? which, what version, what is the host
OS/version? so many unanswered questions and i can’t get my crystal
ball tuned just right… :slight_smile:

Have a lot of fun…

Have you tried upgrading python using a standard rpm command as opposed to zypper up?

More importantly, is there anything in the YaST log file that might indicate any reasons for the failure? (/var/log/YaST2/y2log)

Also, have you checked the Python RPM it’s trying to install?
> rpm -qip python-2.6.0-2.19_2.21.1.x86_64.delta.rpm

You could also try a test upgrade and see if it indicates anything:
> rpm -Uvh --test python-2.6.0-2.19_2.21.1.x86_64.delta.rpm

Thanks for trying Palladium. No sarcasm, really.

I posted all relevant versions before. Should I post more? What else is relevant, I don’t know.

This is healthy installation, and zypper worked fine before. Sorry if this wasn’t that obvious.

Yes, a crystal ball would have been useful, and I am glad to find out you don’t have one,

… or what else could be useful is one of you out there might have observed similar symptoms and got a solution, or advice on where to look. However arbitrary, might work for me as well.

Perhaps a suggestion of “check this, check that” type could help. I don’ know I am guessing here, but could it be some PAM stuff (if so, what to reset/disable etc?), some corrupt DB (which?), or any logs that might indicate what is wrong (where?). You know, that kind of advice would really help here…


Here are zypper logs

The last one is trimmed to include last month only. Full log goes back to 8/26 and is too big.

Please see if these make any sense to anyone.

Just did this test:

# cd /var/cache/zypp/packages/repo-update/rpm/x86_64
# ls
expat-2.0.1-88.16.1.x86_64.rpm  python-2.6.0-2.21.1.x86_64.rpm  subversion-1.5.7-0.1.1.x86_64.rpm

# rpm -qip python-2.6.0-2.21.1.x86_64.rpm
Name        : python                       Relocations: (not relocatable)
Version     : 2.6.0                             Vendor: openSUSE
Release     : 2.21.1                        Build Date: Tue Feb  3 15:51:18 2009
Install Date: (not installed)               Build Host: adalid
Group       : Development/Languages/Python   Source RPM: python-2.6.0-2.21.1.src.rpm
Size        : 1186111                          License: X11/MIT
Signature   : RSA/8, Tue Feb  3 15:51:49 2009, Key ID b88b2fd43dbdc284
Packager    : http://bugs.opensuse.org
URL         : http://www.python.org/
Summary     : Python Interpreter
Description :
Python is an interpreted, object-oriented programming language, and is
often compared to Tcl, Perl, Scheme, or Java.  You can find an overview
of Python in the documentation and tutorials included in the python-doc
(HTML) or python-doc-pdf (PDF) packages.

If you want to install third party modules using distutils, you need to
install python-devel package.

    Guido van Rossum <guido@python.org>
Distribution: openSUSE 11.1
root@fermi-login /var/cache/zypp/packages/repo-update/rpm/x86_64
12:23:41$ rpm -Uvh --test python-2.6.0-2.21.1.x86_64.rpm

# rpm -Uvh --test python-2.6.0-2.21.1.x86_64.rpm

Guess what happens after the last command? Nothing, it hangs!


sly5 wrote:
> Here are zypper logs

exactly when did this problem begin?

from THAT date work backwards in the Zypper logs and see if there were
any updates which might have introduced a problem…(btw, i don’t
what was thinking about earlier…YaST is a GUI front end for
zypper…if zypper is broke then yast must be too…)

think hard, what might you have done…like, how many different repos
are currently enabled?

execute the following and post the results back to here:
zypper lr -d

have you done any one-click installs?

consider installing smart, and using it to reinstall zypper

i’m reaching…

Have a lot of fun…

> Guess what happens after the last command? Nothing, it hangs!

i think that means your system is running a fever, and needs a real

i’m outta here.

Have a lot of fun…

If one of your NFS mounts died and it’s not in soft mode, this is normal. (See: rpm in D state. nfs kthreads visibile.)

I noticed, when looking through the zypper log, and then reading your posts following, has confirmed my suspicion. The problem is not with zypper. Zypper is making calls to rpmdb and rpmdelta. My guess is that your rpmdb is corrupted. I would try rebuilding the rpmdb.

 *rpmdb* --*rebuild

Thanks for the help everyone (esp @jengelh).

The problem seemed to be related to NFS, and went away after a manual kernel upgrade.

Thanks for the help everyone (esp @jengelh).

The problem seemed to be related to NFS, and went away after a manual kernel upgrade.

I had the same problem today - rpm (and consequently also zypper) was hanging. I found this blog entry which pointed me in the right direction: RPM hanging for no (apprent) reason?? | aikesommer.name

When I checked it turned out that one of the NFS shares I had mounted wasn’t responding. When I fixed the problem (which turned out to be with the NFS server) zypper and rpm started working again immediately. I don’t understand why rpm installation is dependent on NFS but it is a useful thing to know.


danbretherton wrote:
> it is a useful thing to know.

and, to me it sounds like a bug begging to be submitted…


Thanks a lot danbretherton. That was a life-saving hint :smiley: