Zypper dup wants to install Gimp and LibreOffice (160 packs) and reinstall 37? Why?

I did not update my Tumbleweed for a few days and I could not find any Info on this (last 3 Snapshot posts did not load). I am going from 20230412-020230418-0

Why is zypper dup trying to install all of LibreOffice and Gimp (and all the rest)?

The following 160 NEW packages are going to be installed:
  apache-commons-logging dvd+rw-tools fixmath flute gimp gimp-help
  gimp-help-en_GB gimp-lang gimp-plugins-python gnome-music gnome-music-lang
  gnome-text-editor gnome-text-editor-lang google-carlito-fonts
  gstreamer-plugins-libav gstreamer-utils java-11-openjdk
  java-11-openjdk-headless javapackages-filesystem javapackages-tools
  kernel-default-6.2.10-1.1 libabsl2206_0_0 libabw-0_1-1 libavfilter8 libbase
  libboost_date_time1_81_0 libboost_date_time1_81_0-x86-64-v3
  libboost_filesystem1_81_0 libboost_filesystem1_81_0-x86-64-v3
  libboost_iostreams1_81_0 libboost_iostreams1_81_0-x86-64-v3
  libboost_locale1_81_0 libboost_locale1_81_0-x86-64-v3 libbox2d2 libburn4
  libcdr-0_1-1 libclucene-contribs-lib1 libclucene-core1 libclucene-shared1
  libdv4 libe-book-0_1-1 libeditorconfig0 libeot0 libepubgen-0_1-1
  libetonyek-0_1-1 libexttextcat libexttextcat-2_0-0 libfonts libformula
  libfreehand-0_1-1 libgimp-2_0-0 libgimpui-2_0-0 libglade-2_0-0 libglslang12
  libgpgmepp6 libgupnp-igd-1_6-0 libisoburn1 libisofs6 libixion-0_17-0 libjte2
  libkate1 liblangtag1 liblavfile-2_2-0 liblavjpeg-2_2-0 liblavplay-2_2-0
  liblavrec-2_2-0 liblayout libloader liblpsolve55-0 libmariadb3 libmng2
  libmng2-x86-64-v3 libmspub-0_1-1 libmwaw-0_3-3 libmypaint0 libmypaint-lang
  libmythes-1_2-0 libnumbertext-1_0-0 libnumbertext-data libodfgen-0_1-1
  liboggkate1 libopenssl1_1 liborcus-0_17-0 libpagemaker-0_0-0 libpcre1
  libpostproc56 libpython2_7-1_0 libquicktime0 libqxp-0_0-0 librasqal3 librdf0
  libreoffice libreoffice-base libreoffice-branding-openSUSE libreoffice-calc
  libreoffice-draw libreoffice-filters-optional libreoffice-gnome
  libreoffice-gtk3 libreoffice-icon-themes libreoffice-impress libreofficekit
  libreoffice-l10n-en libreoffice-l10n-en_GB libreoffice-mailmerge
  libreoffice-math libreoffice-pyuno libreoffice-share-linker libreoffice-writer
  librepository librevenge-0_0-0 librevenge-stream-0_0-0 librubberband2
  libSDL-1_2-0 libSDL_gfx15 libserializer libshaderc_shared1
  libSPIRV-Tools-2023_2 libstaroffice-0_0-0 libvidstab1_1 libvisio-0_1-1
  libvmaf1 libwmf-0_2-7 libwpd-0_10-10 libwpg-0_3-3 libwps-0_4-4 libxmlsec1-nss1
  libzimg2 libzmf-0_0-0 mjpegtools myspell-dictionaries myspell-en myspell-en_GB
  myspell-en_US myspell-lightproof-en patterns-desktop-imaging
  patterns-desktop-multimedia patterns-gnome-gnome_multimedia
  patterns-gnome-gnome_office patterns-office-office pentaho-libxml
  pentaho-reporting-flow-engine python python2-pycairo python-base
  python-gobject2 python-gtk python-xml sac timezone-java typelib-1_0-Goa-1_0
  typelib-1_0-Grl-0_3 typelib-1_0-GstAudio-1_0 typelib-1_0-GstPbutils-1_0
  typelib-1_0-GstVideo-1_0 typelib-1_0-MediaArt-2_0 typelib-1_0-Tracker-3_0
  vorbis-tools vorbis-tools-lang xml-commons-apis

and also reinstall 37 Packages?

The following 37 packages are going to be reinstalled:
  adwaita-qt5 boost-license1_81_0 gio-branding-openSUSE glibc glibc-extra
  glibc-lang glibc-locale glibc-locale-base gnome-menus-branding-openSUSE
  gtk2-branding-openSUSE gtk3-branding-openSUSE gtk4-branding-openSUSE
  icewm-theme-branding libadwaitaqt5-1 libappindicator3-1 libboost_thread1_81_0
  libboost_thread1_81_0-x86-64-v3 libdbusmenu-glib4 libdbusmenu-gtk3-4
  libfftw3-3 libfftw3_threads3 libjavascriptcoregtk-4_1-0 libmetis5
  libopenblas_openmp0 libpoppler127 libpoppler-cpp0 libpoppler-glib8
  libwebkit2gtk-4_1-0 NetworkManager-branding-openSUSE nscd poppler-tools
  QGnomePlatform-qt5 qtdeclarative-imports-provides-qt5
  typelib-1_0-JavaScriptCore-4_1 typelib-1_0-WebKit2-4_1
  webkit2gtk-4_1-injected-bundles WebKitGTK-4.1-lang

1.26 GB and needs 1GB of additional space after the update.

I am trying to keep my Install minimal but Tumbleweed gives me a hard time on that task.

A minimal tumbleweed iso that keeps itself minimal would be so great. I know MicroOS is pretty minimal but I don’t want to rely on Flatpaks and I want to update my System with a command and not automatically.

How can I prevent zypper dup from installing all that stuff. I don’t know what packs I need and what I don’t need except for Gimp and LibreOffice which I don’t need at the moment.

And what are these reinstalls? Why was that removed in the first place if it is needed? Or isn’t it needed?

To keep a minimalist installation requires including the following configuration:

# grep onlyR /etc/zypp/zypp.conf
 solver.onlyRequires = true

About apparently random package reinstallations I’ve never investigated.

1 Like

@mrmazda … what’s your thoughts to also check this setting to be :

In /etc/zypp/zypper.conf , change the installRecommends option :


I will try that out. Can I just coppy and paste into a terminal?

I was reading a lot about this and many said it can break the system cause it might not install important packages.
But I don’t really know

It is impossible to answer without knowing exact packages installed on your system. But the first guess is that you installed something with --no-recommends in the past, this “something” got updated and zypper now tries to install recommended packages. If you really want to know, check

zypper search -ix --recommends-pkg ...

for each new package.

Those packages were indeed rebuilt even though version did not change. No idea why or how it is possible (so far my understanding was that release number is increased every time package gets rebuilt).

It may be will not “break”, but you may miss functionality that you get for granted.

I mention it because it’s documented in SLES (the Enterprise version) documentation … I know, not TW, but for corporate use.

And yes, being cautious is a good thing :+1:

@Speciolution likely changes in the GNOME patterns.

Never did that. I uninstalled all the Games and Apps I don’t need with Yast and marked them as “Taboo”

About the “no recommends” @myswtest
I think it will also NOT install x86-64-v3 packages.
That is why I don’t want to change this setting

Not sure if “solver.onlyRequires = True” does the same, which would be bad.
I want improvements but no bloat. No apps and no services I don’t need.

It seems complicated to achieve that and really time consuming. And nobody really knows how to do it properly.

@Speciolution where does MicroOS insist you use flatpaks?

It doesn’t insist but it says everywhere you install Programs with Flatpak. One of the main Devs says it in his Videos.
Sure you can add ppas and install in otherways but then you miss the point of MicroOS I guess

@Speciolution I run flatpaks, but also use rpms for the likes of rtl-sdr and gqrx etc, my MicroOS Minecraft server has no flatpaks… it runs at multi-user level :wink:

The self install MicroOS image and combustion script to set up the system how you want it is all that is needed.

Sorry about that. I usually forget the other exists:

# grep -E 'onlyR|tallR' /etc/zypp/zyp*.conf | grep -v \#\#
/etc/zypp/zypp.conf: solver.onlyRequires = true
/etc/zypp/zypper.conf: installRecommends = no

I keep configs on my lan server to copy to new installations, so they can all run on the same settings, and don’t get looked at or edited very often. :stuck_out_tongue:

1 Like

Achieve what and do what?

libreoffice belongs do default desktop patterns and is installed by default. If it is not present on your system, you could not avoid --no-recommends in the past.

It appears to be one off bug, details are in

1 Like

keeping the system minimal but still getting the updates that improve the systems performance/stability/compatibility

I did not install it by default - probably unmarked it in the installer. But I never did and update with “no recommends” and my system is up for a few months now. It never tried to install LibreOffice or Gimp.

Do we have to do something about it. If I did not update yet should I wait or will it be fixed with a next update?

Disable recommended packages and install exactly what you want.

No. Just update as usual.

1 Like

Okay, so for now I left the recommended but did solver.onlyRequires = true and it did NOT want to install all these 160 packages but only 2.

I will leave it like that for the moment.
If I would change it though will it still give me the x86-64-V3 packages?

1 Like

Tumbleweed users who performed a distribution upgrade or zypper dup the last weeks on the rolling release with “recommended packages” enabled (the default) and matching hardware received a new package named patterns-glibc-hwcaps-x86_64_v3 automatically installed. This is a new Tumbleweed feature which will also automatically install the “recommended” package named with the -x86-64-v3 name suffix that provides the optimized version of the library.

Here is the news about x86-64-v3 support and it says only when recommended packages are enabled.
I am not sure what the solver.onlyRequires option exactly does. I have to keep an eye open on the updates to see if I still get new V3 packages.
Just in case anyone else cares :grin:

1 Like