Zenmap on Windowz, only see's port 80 open

Hey, Y’all!

I’ve been fighting for weeks to get tightvnc, then tigervnc, and for my latest trick, I installed tightvnc in Wine…

I opened the necessary ports on the firewall, but nothing. Nada. Zip!

Finally I ran Zenmap, and it shows port 80 is the only one open.

Just now I disabled the firewall completely, and I still only see port 80!

What package did you install? Sounds like you might’ve installed the client rather than the server.

It’s the server.
Even zenmap locally can’t find anything


On the host running the server, if you run lsof -i -P | grep LISTEN, what’s the output?

I’m not familiar with zenmap as a tool, but as a frontend to nmap (which I am familiar with), it may be that looking at localhost (which resolves to may not be showing all the listeners, since that doesn’t represent all network interfaces.

nmap is usually used for outbound probing, not looking at what ports are in use on the local system - lsof gives you a definitive picture of that with the parameters I’ve suggested here.

I get:
winserv 18992 pauly 226u IPv4 43135 0t0 TCP *:5900
winserv 18992 pauly 236u IPv4 43138 0t0 TCP *:5800

I should clarify; I ran zenmap from Windows first, and she only see’s port 80, so I tried it on Suse, too.

Weird, huh?

Ha! Look close at the image from zenmap. I typed lovalhost, not localhost! Just ran it again on the localhost, and it see’s everything I would expect.

Zenmap from Windows, still shows only port 80.

I had wondered if I was misreading ‘lovalhost’. :smiley:

But if you ran to localhost on the Windows box…then you’re looking at the Windows box (I’ve learned over the years not to make assumptions :wink: ).

But that means you should run the Linux version on Linux rather than using WINE - no idea if the Windows version on WINE will actually work.

Depending on which desktop you’re running, though, you wouldn’t need to use a separate VNC server package - you can just enable remote administration and that should give you what you’re looking for there. But keep in mind that VNC is not a secure protocol - it’s not unusual to use SSH to tunnel and not expose the port - that’s what I do with my systems.

So you do something like:

ssh -L5900:localhost:5900 myhostname

And then use your VNC client to connect to localhost:0 (5900 is display :0, 5901 is display :1 and so on - that’s the default anyways).

Then the connection is encrypted using SSH, and your keystrokes can’t be sniffed unless the system is otherwise compromised - and if that’s the case, then this would be the least of the issues.

LOL… No, I ran zenmap on windows to check suse, and all I saw was port 80. Then after I took spelling lessons, I ran zenmap on suse to check suse, (again) and saw what I would expect, ie, ports, 80, 5900, 5901, 5800, and 5801.

Dunno what you mean by, “depending on which desktop you’re running,” Suse is tumbleweed.

Now, regarding this ssh -L5900…etc. has me totally confused with the localhost:5900 myhostname.

Know that both Windows and suse are on my private network, and in fact behind a Cisco Pix firewall. 'Tis why I felt comfortable disabling the firewall on suse. Which, one would think, would allow me to see all the open ports.

I know for sure the firewall on suse is disabled, because I can see in services manager that it’s dead.

Since I do see the ports for vnc open from suse, I imagine it’s working in wine. However, before I tried it on wine, (Which, I might add, this issue is causing me to drink) I tried both tightvnc, and tigervnc, with the same results. Zenmap can’t see them from windows. Figured I just didn’t get any of the install and configure tutorials online, I must be doing something wrong, so I tried wine.

I “think” I understand the idea behind using ssh, I don’t think it necessary, since it’s all behind an excellent firewall.

Okay, here’s the deal. Love to cook. Even went to culinary school after I retired. Needed to justify getting a new PC. I sit in the garage all day, vaping and drinking 4 gallons of milk a week.

Also wanted to play with Linux again. Little googling and found several good online cookbook recipe apps. BINGO! Told the wife, if I had a new computer, I could put the laptop in the kitchen for recipes, and she fell for it.

So, I wanna be able to access suse from the garage.

Weather or not if I’m using a secure connection isn’t the issue. The issue is that Windows can’t see any open ports on suse, except port 80.

Blows my mind!

KDE, GNOME, something else. :slight_smile:

SSH can be used to forward ports. The -L switch means to forward a local port to a remote host:port combination. The syntax is localport:remotehost:remoteport, so -L5900:localhost:5900 says "forward local port 5900 to port 5900 on the system the remote host resolves as localhost (ie, its own loopback interface,

For an example, let’s say your system win is what you’re connecting from, and suse is what you’re connecting to.

  1. Connect to suse from win using ssh, and forward port 5900 on win to port 5900 on suse’s localhost address (suse’s (ssh -L5900:suse:5900 user@suse)
  2. Use the VNC client on win to connect to win:0 (ie, port 5900 on win). That connection is forwarded to suse’s port 5900 on suse’s address (itself).

This means you don’t need to open the port in the firewall on suse and can still connect, and the connection is encrypted.

I do this myself even when I’m on my own secured network, and I can leave the firewall in place either way.

Now, if you still want to connect to 5900 directly from win to suse…let’s see the full output from lsof -i -P | grep LISTEN on suse. It may also be useful to check that the open ports are in the right zone in the firewall - the default zone is public, so if you opened the ports in a different zone, that might explain why you’re seeing what you’re seeing as well.

The firewall has been disabled to see if I was opening the ports incorrectly.

This is what I get from zenmap locally.

Ah, the format looks a little weird to me because it’s missing (LISTEN), and it’s not preformatted, so the spacing looked strange to me. :slight_smile:

(The </> button in the toolbar is really useful for terminal output and other preformatted text)

The output from lsof indicates it’s listening on all ports. The nmap command you’re running is only running on the loopback interface (ie,, so it’s not showing what’s open on the network card’s interface. That’s one of the reasons I prefer lsof to nmap for something like this - different ports can be open on different interfaces.

What happens if you just use telnet from the windows system to suse:5900? Does it connect, or does it refuse to connect? (That’s a sure way to see if the port is responding or not)

Yep. I can telnet to localhost on port 23.

Damn it. Did it from suse. DON’T get old!

No, I cannot telnet from Windows. Everything always says refused.

Try not to port 23, but to port 5900. That’s the port we want to check. :slight_smile:

(I would also be inclined to disable the telnetd service, as it’s a completely insecure service; ssh is what should be used instead)

I just setup the telnet server for testing purposes. Like I said, I’m behind a Cisco Pix. and we have no wireless.

Many moons ago I ran Cat5 to every room in the house and garage. Even the kitchen and dinning room are wired. Don’tworry, I’ll remove it if I ever get this to work.

No, I cannot telnet to 5900. Says connection refused.

Can you confirm if you’re using the WINE version or the native version of your VNC server software?

I would switch to the native version if you’re using the WINE version - that adds a layer of complexity that might be complicating things here.

Also, are you looking to just access a desktop remotely or the logged-in desktop? The VNC server software defaults to creating a new graphical session rather than letting you access the logged-in desktop. That’s where the ‘remote administration’ option that I noted earlier. It looks like you’re probably using KDE (from your screenshots), so I’m not sure exactly how you would enable that (since I use GNOME), but that may be a better option than installing a VNC server.

Well, that’s easily remediated, and as I’ve been wondering what gnome feels, like, I’ll reinstall:)

Wouldn’t that be interesting? First I tried yast’s remote admin with no love, then I tried tightvnc, then tigervnc, then finally tightvnc via wine. I uninstalled each time, but who knows what settings in the config files I didn’t remove?

I have an app from Terabyte Unlimited called Image for Windows, that makes an image of my system to an external drive in around 15 minutes. Rather than remove one app, then trying another, I’ll just restore the fresh install, and then try another. I’ll fool y’all into thinking I’m smart yet!

Note, however, that tigervnc viewer can connect, to tightvnc in wine, but I get a black screen, so yeah, there could be remnants of prior installs, so I cannot confirm that it’s the wine install that’s responding.

Yeah, I just wanna access it from the garage, not share a desktop. I just wanna play. Try again at that Active Directory, and samba…etc.

Gimme an hour and I’ll try again with gnome and remote admin.

Could you be persuaded to give me instruction on how exactly to enable and configure remote admin?

Looked pretty straight forward, but It’s not entirely out of the realm of probability that I missed something.

Makes sense that you’d get a black screen when using the Windows version with WINE - reading the screen on Windows vs. on Linux is going to be very different and likely doesn’t translate through the WINE API layer.

I’d used it in the past, and it was pretty straightforward. But now it seems I can’t get it to work either (I typically use x11vnc to connect to my desktop from my tablet - that reads the screen and does desktop sharing, and I can initiate it from a ssh session). It’s in the GNOME settings under ‘system’ (used to be under ‘sharing’ as I recall, seems they moved it).

Might need more research on what I’m missing, because now it also says it’s RDP, but the Android version of MS Remote Desktop doesn’t connect to it.

Which also begs my question, are the ports visible from remote?