yt-dlp no longer working

yt-dlp (youtube download application) has stopped working.

nick@shuttle:~> yt-dlp -o "%(title)s-%(id)s.%(ext)s" pOcfW0zv7cY
DeprecationWarning: Python version 3.6 is no longer supported! Please update to Python 3.7 or above pOcfW0zv7cY: Downloading webpage
ERROR: module 're' has no attribute 'Pattern'

As far as I can see, Python 3.7 or above is not available for openSUSE Leap 15.4.

How do I overcome this problem?

have you tried here?

You did not explain where this program comes from, how you installed it, whether it worked before and when it stopped working so any answer will be just a wild guess. Anyway, quick test using version included in openSUSE works here:

bor@localhost:~> yt-dlp -o "%(title)s-%(id)s.%(ext)s" pOcfW0zv7cY pOcfW0zv7cY: Downloading webpage   8.2% of 504.92MiB at  1.83MiB/s ETA 04:12^C
ERROR: Interrupted by user

I removed yt-dlp, then installed opt-python37 from the repository you linked to. It installed packages opt-python-libpython3, opt-python311 and opt-python37. I then reinstalled yt-dlp, but I get the same ouput.

Do I need to do something to connect yt-dlp to python37?

I had updated to the latest version from the Packman repo. I’ve now gone back to the openSUSE version, which works.

Thanks for your help.

Assuming it’s from the Packman third party repo, there is a fix on the way, see their mailing list for details: [packman] yt-dlp 2022.08.08 broken on 15.3

Thanks, Malcolm. I’ve solved the problem temporarily by reverting to the non-Packman version

Which is rather different from what was shown in original post.

Kudos to all involved - I see that the latest yt-dlp update for openSUSE 15.3 in Packman repo is notated:

  • Force python 3.9 on anything older than Tumbleweed

It works here.


Thanks for the info, Tallowwood. Have reinstalled from Packman, which installed python 3.9. Now working fine.