youtube, myvideo...-videos are jerking

there’s a Acer Travelmate 201T with the following specifications:
CPU: Intel Celeron 600 MHz
RAM: 512 MB
VGA: ATI RAGE Mobility M AGP 2x 4MB with 800x600 24-Bit TFT-Display

and i’ve installed openSUSE 11.0.
The graphic setup was automatically and were set to:
graphic driver: ati (no 3D-acceleration)
resolution: 800x600 24-Bit (16,7 million colors)

glxgears runs with 30 fps, but videos on myvideo, youtube are jerking.

i’ve recognized that cpu usage is at 95,3 % when watching
a youtube video. when i zoom out, so that the video is decreased,
the cpu usage goes down.

is the cpu to slow? or is there a way to watch youtube-videos
with this laptop without jerking? (maybe other java-version)

thanks in advance

Are these HD videos on YouTube?

I recall reading recently a criticism of YouTube, in comparison to Vimeo, noting YouTube HD videos tended to be more jerky.

Still you should check to ensure there is nothing in your system that is slowing this down … ie disable ipv6, remove beagle.

You CPU is slow but I’ve recently read a piece explaining why Vimeo videos are better than most other sites; it is to do with the implementation of H264 on these sites.

Sorry I can’t remember where I read it.

I saw this article and when I checked it out, the OPPOSITE was true. Didn’t bother to follow up since I didn’t see much of interest at vimeo.

On a related note, I think I saw an H264 update come through zypper yesterday.

There was a bunch of stuff from packman a few days ago, that included x264

Not sure if it’s related but I’ve had the same kind of problem with the CBBC iPlayer, in “normal” screen size, the video plays just fine but put to full screen and BOOM! Jerks about like crazy.

I updated my Flash player and Nvidia graphic card drivers and it was worse! it’s not the PC as under windows, this plays just fine in F/Screen.

Any ideas what it could be please?
Suse 11.0 NV6200 (yes I know, not the best!), P4HT 3GHZ and 1GB ram. Firefox 3.5(.2 I think) and latest flash and NV drivers.

If it helps, youtube videos play fine in full screen.
Thanks and sorry to hijack this thread!

I can tell you when I was back with 11.0 I got choppy flash from bbc. But it’s ages ago now. 11.1 is fine

Hmm, I heard that 11.1 broke Nvidia drivers?
I might find a small 40GB hdd and give it a whirl - as the machine’s not the most powerful in the world, would you think it’s best for me to stay with KDE3.5 or move to 4.x (2?)

You could use this live cd: “KDE Four Live” CD](

You may prefer the dvd like me, but if you want kde, I would go with this. To me kde3 is getting depreciated support. And is probably more heavy than kde4

IMHO that hardware will not smoothly play many HD videos, at least not without using a proprietary graphic driver and vdpau. … and the only player that I know of that will play using nVidia’s vdapu technologoy currently is MPlayer (as xine/vlc are still under development for this).

The play back of HD movies is an area where Windoze players are signficantly ahead of Linux (in man respects due to superior graphic drivers).

I’m sorry, i think i confused the matters with my post - these are NOT HD videos, just “standard” resolution ones. I installed WinXP and the same videos play just fine.

OK, by “standard resolution” I assume you mean 320x240 or something small like that?

Comparing to winXP is not a great comparison, as I noted in my previous post, where I noted:

No these are not HD videos and it is even jerking in window mode.
There are no other things slowing down the cpu:
beagle is completely uninstalled (incl. firefox plugin) and
the system is up to date…

I remember the time before, it ran fine with Windows 2000 Pro
on 64MB.

Are there other options to disable to make the system faster?

I have the same Problem…

…still looking for a way to combat jerky youtube vids…

Have you tried another linux distro e.g (k)ubuntu as part of troubleshooting? This is a serious suggestion.

My video H/W (VIA Unichrome Pro) is different to what’s been posted here. I had perfect internet video including BBC iplayer on 10.3 with 60% cpu utilization. On early 11.1 and kde 3.5 (missed out 11.0) it’s choppy/jerky with 90-96% cpu utilization. With speech, the video lags slightly behind the sound (perfect). This is at 16bit colour depth, as 24bit is worse. BTW, local video is fine. There have been slight improvements over 8 months with performance update to Xorg, xorg-server is at 1.5.2, but it’s still jerky at around 88-93% cpu. Over the 8 months, especially recently, I have spent more time researching and troubleshooting than I care to recall, with little progress except to isolate components. It’s also as bad using two different drivers: openchrome, and chrome9 (VIA’s attempt at open source) . On 11.2 M1 it was almost perfect, but on M2/3/4 it became jerky again (xorg-xserver at 1.6.2).

I multiboot with* kubuntu 9.04* (upgraded from 8.04) and kde 4.2. Its internet video using BBC iPlayer is perfect at 24bit depth, CPU utilization similar to opensuse 10.3, on the same H/W same video driver version (openchrome driver). xorg-server is different at 1.6.0, but I am not yet convinced this is the (only) problem.

There are several other S/W components involved, and there could be in the case of your H/W. In my case this is what I found.

Although internet video (BBC iplayer) is I assume 2D only, there may be more S/W components involved than just xorg and the video driver. In my case, the driver takes care of 2D acceleration, but AGP DMA can be used for 2D (and 3D). Driver options involving DMA require that DRI is enabled. This brings in other components such as libdrm and two cooperating kernel driver modules, drm.ko and a H/W specific* via.ko*.

On 11.1 and 11.2, although DRI installation completes according to Xorg.0.log,

(II) CHROME(0): [DRI] installation complete

However this only holds for a few more messages, but then, checking if direct rendering is working (even in theory), “grep rendering /var/log/Xorg.0.log” shows:

(II) CHROME(0): direct rendering disabled

Enabled by default, driver option “EnableAGPDMA” enables the AGP DMA functionality in DRM, forcing 2D and 3D acceleration to use AGP DMA. However, on 11.1/11.2, when checking if the kernel DRM modules are loaded and functional, “dmesg | grep -e agp -e drm” shows the following error (see last line):

Linux agpgart interface v0.103
agpgart-amd64 0000:00:00.0: AGP bridge [1106/0204]
agpgart-amd64 0000:00:00.0: AGP aperture is 64M @ 0xf0000000
[drm] Initialized drm 1.1.0 20060810
[drm] Initialized via 2.11.1 20070202 on minor 0
agpgart-amd64 0000:00:00.0: AGP 3.0 bridge
agpgart-amd64 0000:00:00.0: putting AGP V3 device into 8x mode
[drm:via_do_init_map] *ERROR* failed to find dma buffer region!

Having got this far in august, I searched for openSUSE 11.1 bugs and found bug #521382. Ignoring the rant there about drm etc., it’s clear that very early 11.1 release drm kernel module(s) were patched, but libdrm wasn’t, and that appears to be problematic. I haven’t found any mailing list conversations to explain why this was done, who requested it, or how (if ever) it was tested and by whom. Also, there is no explanation as to why the unichrome driver (inferior support and useless) was included in openSUSE distro (11.1), and openchrome (superior feature support) wasn’t. Eight months of total bloody secrecy >:(.

I included my specific details above in case it gives you any clues as to where to look, or may help you to diagnose the cause of your jerky internet video. I could be on the wrong track, so if anyone wants to disagree or confirm, feel free. :slight_smile:

In case something wrong with the bug link in my post above, please find it here.

so . if I read you correctly - in order to run youtube vids smoothly I’ve got to wipe my PC and install another distro?

I can’t speak for your H/W, so I was really talking about the faultfinding steps you could take. If you find another distro works for youtube vids, it would be your choice as to how you proceed, switching distros temporarily or dual booting, until openSUSE fixes any problems.

No I wasn’t saying to wipe your PC, unless it’s spare. Alternatively, do you not have a spare partition to install another distro for testing purposes? 5 or 6GB max should be enough for testing something like (k)ubuntu or another comparable distro, with a default install taking up 3-3.5GB. It can be a primary or extended partition. I multibooted, so kept my everyday openSUSE, and it doesn’t include Windows. I can, and have multibooted with 5 additional distro versions. Before attempting it, you should become familiar with the Grub bootloader.

If you cannot easily identify the cause of your problem on openSUSE, it can be quicker to try the same H/W on another distro, preferably using the same video driver version in both cases. If it works on the new distro, at least you can be reasonably confident the problem lies within openSUSE and it’s S/W components. (k)ubuntu 9.04 is probably a good choice, because Xorg will be at a newer release than on 11.1. A lot depends on your H/W, so do check the new candidate distro’s support and forum for that.

> …still looking for a way to combat jerky youtube vids…

are you asking for help or just complaining?

wanna mention your hardware/software specifics? graphics driver you
are running, etc…maybe there is a solution with your hardware or
maybe you need newer/stronger…see:

cpu speed, ram?
what browser? version?
is beagle running?
which version of flash is installed?
has IPv6 been disabled in firefox and OS?
what happens if you turn off desktop effects?
what have you done to try to solve it?

question guide


I hear you - dont be the problem, be part of the solution!

The Flash is the newest version, I downloaded it a couple of days ago
The Beagle(no- I have no Idea what it does) I now tried toggeling it on and off a couple of times and don’t seea difference, but I#ll leave it off for now.
The Desktop effects are turned off.

Its a Intel(R) Pentium(R) 4 with a 1.80GHz CPU and a cache of 512 KB.

I’ll try the IPv6 thing (Disable IPv6 for Firefox - openSUSE) and check back in to tell you if it worked.