Yet another Tumbleweed secure boot problem

I’ve researched and tried to educate myself on the subject but haven’t found a solution and believe my situation has some unique quirks …

I have an old but still very fast Dell Precision M6500 laptop with Nvidia Quadro FX 3800 graphics that I want to install Tumbleweed on. It has been running Leap 15.1 for many years, and boots several different Leap 15.4 ISO images from USB successfully.

But all the Tumbleweed ISOs I’ve tried hang during boot. The BIOS (it’s not a UEFI system) has nothing about “Secure Boot” but does have options to enable/disable “TPM Security Trusted Platform Module” and “Virtualization Support Trusted Execution” among others. I’ve tried dozens of permutations of these but boots always hang with messages such as:

[ <time>][ T1] Loading compiled-in module X.509 sertificates
[ <time>][ T1] Loaded X.509 cert 'openSUSE Secure Boot Signkey: fd9f2c12...469e'
[ <time>][ T1] zswap: loaded using pool lzo/zbud
[ <time>][ T1] page_owner is disabled
[ <time>][ T1] Key type .fscrypt registered
[ <time>][ T1] Key type fscrypt-provisioning registered
[ <time>][ T1] Key type encrypted registered

or, if TPM is disabled:

[ <time>][ T1] ima: No TPM chip found, activating TPM-bypass!
[ <time>][ T1] Loading compiled-in module X.509 sertificates
[ <time>][ T1] Loaded X.509 cert 'openSUSE Secure Boot Signkey: fd9f2c12...469e'

So … questions:

  1. Is there any Boot Option that might get me past this point?
  2. Is the problem related to whatever Nvidia driver is in the boot image? Successful boots transition to a smaller font around this point in the process.
  3. Is this a fatal incompatibility between this hardware/BIOS and the new Secure Boot signed kernels, drivers, GRUBs, boot sectors, etc.?
  4. If so, will this laptop be stuck forever on old releases once Leap 15.5, ALP, and/or other distros catch up to where Tumbleweed seems to be now?

Thanks for any answers or insights.

@OldButNotGuru wrote:

It always helps to publicly advertise one’s ignorance. On a whim I just tried adding “nomodeset” (with a new download of the latest openSUSE-Tumbleweed-DVD-x86_64-Snapshot20230422-Media.iso, not that it probably made any difference) and got past the hang to at least the first few of the graphical install screens.

Apologies for wasting anyone’s time. Maybe search will help someone having the same problem in the future. I’ll go through the full install (my plan is to try nouveau first and then nvidia – the “easy” or “hard” ways) and might come crawling back here with any further problems … after first quintuple-trying every possible solution I can think of. (In my defense I did work for 24 hours on this before posting.)

Thanks again.

1 Like

I’m glad you found a workaround.