Yast2 GUI over ssh in multi-user.target

Hello,

I appologize in advance if this forum is not the apropriate one.

Problem:

  • Yast remote over ssh defaults to gui only when system is in graphical.target but not in multi-user.target

Background:

  • X11 forwarding is enabled in sshd_config
  • client uses -X option
  • other applications (i.e xterm) work regardless of the init target.

Other details:

  • yes forcing with --qt works

Why asking:

  • I do expect if I am using X11 forwarding that an app will default to gui.

Thanks

Maybe I misunderstand your question, but in order for X11 forwarding to work an X-server needs to be running on the remote machine. The multi-user.target relates to setting up a system in non graphical (console) multi-user mode, while graphical.target is for setting up graphical multi-user system with network services.

From the following reference
https://www.freedesktop.org/software/systemd/man/systemd.special.html

multi-user.targetA special target unit for setting up a multi-user system (non-graphical). This is pulled in by graphical.target.
Units that are needed for a multi-user system shall add Wants= dependencies for their unit to this unit during installation. This is best configured via WantedBy=multi-user.target in the unit’s [Install] section.

graphical.targetA special target unit for setting up a graphical login screen. This pulls in multi-user.target.
Units that are needed for graphical logins shall add Wants= dependencies for their unit to this unit (or multi-user.target) during installation. This is best configured via WantedBy=graphical.target in the unit’s [Install] section.

An overview of X11 forwarding…
https://goteleport.com/blog/x11-forwarding/

You have not indicated what commands you used.

I tested this, making my best guesses. And it worked.

I am using Leap 15.4, and my main desktop computer is running X.

I booted up my laptop to multi-user mode. I did this by appending a “3” to the kernel command line.

From my main desktop, I did:

ssh -X root@laptop

and then from the command line at that ssh session, I ran:

yast2

It worked as expected.

Sorry about the commands.
1st time i noticed

  • remote default boot target = graphical
ssh -X root@remote 
yast2

worked as expected the GUI interface appeard
however after

systemctl isolate multi-user.target
yast2

only TUI unless

yast2 --qt

then I changed the remote default boot mode = multi-user
rebooted and the result was same behaviour as above i.e only TUI unless forced with --qt

please note that xterm works as axpected.

I was wandering how yast detects X11 and what the defaut precedence is in terms of interface selection

Actually X server does not need to exist on remote only on the local system where the display is.