Yast2, firefox, thunderbird don't work after update


Some time ago I did an automatic update and after that firefox, thunderbird and yast2 don’t start. It’s not that there is an error message or sth. Their icons just start jumping and after a while it stops without anything opened. I tried even removing the .mozilla directories and so on but it doesn’t help. Of course I tried to simply reboot the machine and strangely enough, still does not work. Opera works though and I am ok with that, however yast2 not opening is more annoying. I do all the stuff that I want from the console, but of course that’s not the point.

So, does anyone have any ideas what might be the problem?

Thanks in advance.


Try running them from terminal and see what errors pop up.

Best regards,

Good idea :slight_smile:

So, for Firefox throws this message
/usr/lib64/firefox/firefox: symbol lookup error: /usr/lib64/gio/modules/libgiolibproxy.so: undefined symbol: g_proxy_resolver_get_type

For Thunderbird is the same.

For yast2, when I start it from the terminal it opens a text GUI inside the terminal. When I go for the software management option it throws this exception
Error while creating client module sw_single

Could You paste here the result of

zypper lr -d

Are You running 32bit or 64bit version of openSUSE ?

uname -a

To check that.