Yast / Zypper / Network issues

I’m new to posting to the forum but have looked here many times for help and learned along the way.
I’ve been using OpenSuse since 12.1. Mostly the GUI.

My system:

Operating System: openSUSE Leap 15.4
KDE Plasma Version: 5.24.4
KDE Frameworks Version: 5.90.0
Qt Version: 5.15.2
Kernel Version: 5.14.21-150400.22-default (64-bit)
Graphics Platform: X11
Processors: 4 × Intel® Core™ i5-2400S CPU @ 2.50GHz
Memory: 7.6 GiB of RAM
Graphics Processor: Mesa DRI Intel® HD Graphics 2000

Never had problems getting or installing regular updates until the weekend when I received hundreds of updates. Major fixes I thought.
Since then the Task Manager Software Updates shows “Your system is off line”
Logged into Yast Admin Settings. Clicking on any icon fails to return results.
Tried zypper and here are the results:

jim@localhost:~> sudo zypper
[sudo] password for root:
zypper: symbol lookup error: /usr/lib64/libzypp.so.1722: undefined symbol: _ZN4YAML6detail9node_data12empty_scalarB5c

[FONT=arial]I do regular backups of my home directory and am about ready to reinstall Leap 15.4 but thought I’d pick some brains here and learn something new.



It might be that you have a problem with your repositories. Please post (asw root):

zypper lr -d

As you suggested I get the same results

zypper: symbol lookup error: /usr/lib64/libzypp.so.1722: undefined symbol: _ZN4YAML6detail9node_data12empty_scalarB5c

Yes, that is really broken somewhere.

It is very strange that you should have had hundreds of updates when you say you update on a regular base. It looks more like you have wrong repos, maybe added using some 1-click install.

BTW you do not explain how you do (did) those updates. zypper patch, zypper up or YaST > Software > Online Update, or …

To get an idea about your repos without asking zypper:

ls -l /etc/zypp/repos.d/


grep baseurl /etc/zypp/repos.d/*.repo

I thought it was a lot since i thought I was staying current.

I have used 1-click in the past when I can’t find what I’m looking for in the Yast Software Manger. I avoid the experimental pkgs.

Updates come from Task Manager Notifications on the desktop and sometimes zypper to make sure I’m current.

My repos:

jim@localhost:~> sudo ls -l /etc/zypp/repos.d/
[sudo] password for root: 
total 88
-rw-r--r-- 1 root root 204 Aug  8 04:48 'ftp.gwdg.de-openSUSE_Leap_$releasever.repo'
-rw-r--r-- 1 root root 183 Aug  8 04:48  http-download.opensuse.org-629a0695.repo
-rw-r--r-- 1 root root 178 Aug  8 04:48  http-opensuse-guide.org-845fa742.repo
-rw-r--r-- 1 root root 171 Aug  8 04:48  https-download.opensuse.org-7ddb002e.repo
-rw-r--r-- 1 root root 176 Aug  8 04:48  openSUSE-Leap-15.3-3.repo
-rw-r--r-- 1 root root 244 Aug  8 04:48  repo-backports-debug-update.repo
-rw-r--r-- 1 root root 200 Jul  6 04:10  repo-backports-debug-update.repo_1
-rw-r--r-- 1 root root 199 May 27 19:56  repo-backports-update.repo
-rw-r--r-- 1 root root 199 Jul  6 04:10  repo-backports-update.repo_1
-rw-r--r-- 1 root root 179 Aug  8 04:48  repo-debug-non-oss.repo
-rw-r--r-- 1 root root 157 Aug  8 04:48  repo-debug.repo
-rw-r--r-- 1 root root 183 Aug  8 04:48  repo-debug-update-non-oss.repo
-rw-r--r-- 1 root root 162 Aug  8 04:48  repo-debug-update.repo
-rw-r--r-- 1 root root 178 Aug  8 04:48  repo-non-oss.repo
-rw-r--r-- 1 root root 167 Aug  8 04:48  repo-oss.repo
-rw-r--r-- 1 root root 222 Aug  8 04:48  repo-sle-debug-update.repo
-rw-r--r-- 1 root root 209 Jul  6 04:10  repo-sle-debug-update.repo_1
-rw-r--r-- 1 root root 208 May 27 19:56  repo-sle-update.repo
-rw-r--r-- 1 root root 208 Jul  6 04:10  repo-sle-update.repo_1
-rw-r--r-- 1 root root 160 Aug  8 04:48  repo-source.repo
-rw-r--r-- 1 root root 183 Aug  8 04:48  repo-update-non-oss.repo
-rw-r--r-- 1 root root 165 Aug  8 04:48  repo-update.repo


jim@localhost:~> grep baseurl /etc/zypp/repos.d/*.repo


Please use

zypper lr -d

or something similar to show your Repo list with the URL.

That’s one of the problems, all zypper codes I’ve tried return an error

jim@localhost:~> sudo zypper lr -d 
[sudo] password for root:  
zypper: symbol lookup error: /usr/lib64/libzypp.so.1722: undefined symbol: _ZN4YAML6detail9node_data12empty_scalarB5cxx11E 

Sounds like this old bug… https://bugzilla.opensuse.org/show_bug.cgi?id=1178332

As root user, no sudo please, so;

su -
zypper lr -d
rpm -V -a --nofiles

A few remarks.

It is not the fact tyhat you install packages from non-standard repos, but the fact that you do so using 1-click that may be worrying. The 1-click tends to add new repos and leave them enabled (also it asks to leave them, but many just click that away). And new repos may have much more software then you need. And that may bork sometimes. So be cautious with 1-click. Better use more clicks/commands, to add a new repo, install what you need an disable that repo. From time to time you may want to enable to see if there is a new version of what you have from it.

Most people here are not using the KDE applet (i do not even have installed it, nor the software it is based on: Packagekit). At the most for telling them there are updates. But real updating is then only done using YaST/zypper.

Now the improvised repo list. it is not easy to study it (due to all the longs URLs), but as far as I can see


have the same URL when you replace $releasever in the second with 15.4 (which is done on a 15.4 system). So the first one can be removed.

Then I see Packman and KDE3. I doubt that KDE3 can be the reason of your problem. All the rest looks normal to me, but I may miss something.

Maybe a forced install of all zypper might help, but OTOH someone may come with a good idea her, so just wait a bit.


He did in post #3 (although he forgot to include the command within the copy/paste). Zypper does not work at all for him.

Here is the return from above:

**localhost:~ #** su - 
**localhost:~ #** zypper lr -d 
zypper: symbol lookup error: /usr/lib64/libzypp.so.1722: undefined symbol: _ZN4YAML6detail9node_data12empty_scalarB5c
**localhost:~ #** rpm -V -a --nofiles 
/etc/cron.d/: cannot verify root:root 0755 - not listed in /etc/permissions 
/etc/cron.daily/: cannot verify root:root 0755 - not listed in /etc/permissions 
/etc/cron.hourly/: cannot verify root:root 0755 - not listed in /etc/permissions 
/etc/cron.monthly/: cannot verify root:root 0755 - not listed in /etc/permissions 
/etc/cron.weekly/: cannot verify root:root 0755 - not listed in /etc/permissions 
/usr/bin/clockdiff: cannot verify root:root 0755 - not listed in /etc/permissions 
**localhost:~ #**



I’m still learning…
So I can just remove


reboot and see if I get some function back with Yast or zypper?


Cleaning up repo files will not fix a broken zypper command or zypp library. This is a pretty serious failure that will probably be easier to fix by reverting to a snapshot, and if that’s not possible, doing an offline upgrade using installation media. A hand-ons expert could probably fix it using rpm, but I don’t want to try to explain that to anyone, and there’s no guarantee of success anyway.


rpm -q libyaml-cpp0_7

As others explain, this is really a side step, that better is corrected after your main problem is solved.

The results:

jim@localhost:~> sudo rpm -q libyaml-cpp0_7 
[sudo] password for root:  
package libyaml-cpp0_7 is not installed 

It’s beginning to look like my knowledge and experience here isn’t enough to save my current installation, even with help from the folks here.
It will probably be quicker and less prone to to errors on my part to do a clean install.
I’ll be doing another backup of my home directory and reinstall 15.4 Sunday morning.

I appreciate the time taken by those to look into these issues for me.


Oops should be 6:

rpm -q libyaml-cpp0_6

Re-posting with 6:

jim@localhost:~> sudo rpm -q libyaml-cpp0_6 
[sudo] password for root:  

A newer version is on the mirrors:

You could download it manually to the current directory and try to install it thus:

sudo rpm -Uvh libyaml-cpp0_6-0.6.3-150400.4.3.1.x86_64.rpm

First, check in /var/cache/zypp/packages/* to see if it was already downloaded but not installed, if you do find it there, look around for zyp packages that also may have not yet been installed.