Yast to install KVM Hypervisor libvirt-daemon not installed from GUI or pattern kvm_server kvm_tools

I think a bug using yast to install KVM Hypervisor libvirt-daemon not installed from pattern kvm_server kvm_tools Tumbleweed DVD x86_64 Snapshot20230428

  • 1st using yast gui did not work …

  • 2nd after reinstall opensuse from the same dvd using command line .

sudo zypper install -t pattern kvm_server kvm_tools

running Virtual Machine Manager it complained not finding libvertd after research and troubleshooting I installed libvert-daemon

sudo zypper install libvirt-daemon 
sudo systemctl daemon-reload
sudo systemctl enable libvertd.service
sudo systemctl start libvertd.service

Virtual Machine Manager worked :slight_smile:

1 Like

Welcome aboard to the forum !

Thanks for this post … always good to see folks posting a solution / workaround so others can benefit :+1:

No, that is not a bug. libvirt supports either monolithic libvirtd or modular virt${DRIVER}d daemons. The pattern kvm_server pulls in modular daemons which is also preferred way today.

Well, that can be considered a bug in YaST module. I do not know to which extent this module is still supported, but you may submit a bug report.

First, it’s libvirtd, not libvertd (I would not comment if it was just one typo). Are you sure it fails due to missing libvirtd or simply the necessary daemon (educated guess - virtproxyd) was not started?

1 Like

:thinking: looks interesting can you point me to the direction to read about the difference between monolithic and modular in libvirt I would like to know more .

Maybe I have to test it I will reinstall Tumbleweed today to test it .

1 Like

First thanks for the link :people_hugging:.
After reinstalling Opensuse Tumbleweed implementing https://libvirt.org/daemons.html#id10 worked for me :grinning:

  • 1 Running the following commands as root
zypper install -t pattern kvm_server kvm_tools
  • 2
for drv in qemu interface network nodedev nwfilter secret storage
    systemctl unmask virt${drv}d.service
    systemctl unmask virt${drv}d{,-ro,-admin}.socket
    systemctl enable virt${drv}d.service
    systemctl enable virt${drv}d{,-ro,-admin}.socket
  • 3
for drv in qemu network nodedev nwfilter secret storage
    systemctl start virt${drv}d{,-ro,-admin}.socket
  • 4
systemctl unmask virtproxyd.service
systemctl unmask virtproxyd{,-ro,-admin}.socket
systemctl enable virtproxyd.service
systemctl enable virtproxyd{,-ro,-admin}.socket
systemctl start virtproxyd{,-ro,-admin}.socket
1 Like

I’ve tried both things mentioned in this post, but neither work.

I am on a fresh install of openSUSE Tumbleweed. When I start virt-manager I get this error:

When I try to run sudo systemctl enable libvertd.service I get the error:

Failed to enable unit: Unit file libvertd.service does not exist.

What am I doing wrong?

You are using the wrong name. There is no libvertd.service.

So far you showed only one thing you tried, and it was obviously wrong (you mistyped the service name).

Can I hit myself? I’m gonna go ahead and slap myself. I swear, I really should stop trying to do things past my bedtime.

I’m sorry. Thank you!