Yast: Retracted Installed Packages highlighted when starting Software Management

When I go the Yast>Software Management the window opens at View>Retracted Installation Packages and highlights kernel-default, kernel-default-extra and kernel-default-optional in red and ticked as enabled.

Please could somebody tell me what to do. Should I accept and why is this happening when I do always do sudo zypper up and follow the instructions?

Why happening what? What exactly is your question?

@Budgie2 yes it was retracted, so it needs to fix things by installing the fixed kernel.

Hi and thanks but does this mean I accept what is shown or delete. At present I have a highlighted tick arrow. If I change this and delete will it crash my system. I had understood the package manager would tell me what to do but no.

@Budgie2 yes, accept and let it do it’s thing, or use the command line and zypper -vvv up and it will give all the info.

Hi Malcolm,
Thanks for the replies but I am still confused. If I just accept what is shown with no action from me I get the same result on rebooting.

If I click on the arrows to update the three packages the packages in parenthesis are removed from the screen and if I then accept I get the same screen with Retracted Installed Packages showing.

The only option I have not yet tried is to remove the three packages which is why I asked and if I select this there are numbered choices given which seem to give me what I started with.

I conclude I just accept and proceed but all very strange.

@Budgie2 so if you run uname -a it’s not the same version trying to be deleted?

If that kernel is working for you, then just ignore that it is retracted. It will eventually disappear when there is a new kernel. Maybe it takes two kernel updates before it goes away.

As far as I know, the problems for this kernel are that some systems in Intel graphics won’t boot, and there are some issues with NFS. If it boots and you don’t use NFS, then no worries.

I do use NFS but have not had any problems with the links I have at present. The system boots fine so I am just going to ignore and assume the problem will go away in due course as you suggest.
Many thanks.

Have you tried to read the help of YaST Software? The green arrow (assuming you mean that, this is the only arrow symbol I can find in YaST Software) means “update or reinstall”. As there is no update, at most the same packages are reinstalled and you get exactly the same state as before.

I do not understand what “I started with” means, but you get standard zypper choices to resolve dependency problems. If you mark kernel-default for removal, it causes error because kernel-default-extra needs it. If you mark kernel-default-extra for removal you get error because kernel-default-optional needs it. Just read the question and answer it accordingly. Hint - if you try clicking “remove” from bottom to top, there will be no “numbered choices” because then packages will be marked for removal in the “correct” order - at each step you will be “removing” package that is not needed by any other package.

Hi and many thanks.
I didn’t think to tick them in the bottom to top order but what you suggest make sense now you point it out.

Will look at this again but I do wonder why this issue has become apparent in this manner. It is the first time I have ever seen this whereas there have been quite a few occasions when a package has been removed during the up process. Is this because on those occasions it has been replaced during the process whereas this only makes a downgrade possible?

There are differences in our hardware so I will limit myself to what happened to my system. My system would not boot with the latest update. However I was able to boot by selecting the older version ----.46.1 at Grub level.

I removed the retracted kernels and was automatically given a kvmsmall kernel. On rebooting I could not access the internet!! even the earlier kernel ---- .46.1 would not access internet. I would follow nirickert’s advice and let sleeping lions lie.

Hi PrakashC,
Many thanks for the reply and your experience. I have decided to take the expedient route of “if it aint broke, don’t fix it”
Whatever the issues causing this problem I have not had any issues with my system so far and am just assuming that the fault will be fixed in due course.

55.3 kernel has been released.

Hi mrmazda many thanks for the update notice. I didn’t have to wait too long and no problems meanwhile.

I removed the retracted kernels and was automatically given a kvmsmall kernel.

I think you have delete the whole kernel-default package in Yast and not marking kernel-default and going to the Version Tab to delete only the bad Version…

Yes, that is what happened.