Yast Repositories/Update Problems

Having problems with adding/updating repositories 11.1/64bit.

After getting errors popping up on the desktop about repositories unaccessible I go into Yast to delete and re-add repos for nvidia, update, videolan, etc.

When I add > community I get an error


Unable to download list of repositories or no repositories defined.

If I go to Yast and try to refresh repos I get:
Download failed:
Download (curl) error for ‘http://download.opensuse.org/update/11.1/repodata/repomd.xml’:
Error code: Connection failed
Error message: Couldn’t resolve host ‘download.opensuse.org

Yet in the browser I can get Index of /

Can anyone tell me how I might clear this up?


AS a follow up to my original post I should add:

A. I can ping download.opensuse.org and access it in F/ireFox yet Yast and zypper can’t

B. I have a second laptop with 11.1 that updates fine using the same router and DNS settings.

C. zypper has same problem access repos.

Hope these clues help someone who understands how the update process gets it’s DNS .


Sounds like a firewall is not allowing those programs access.

did you tell it to retry on those repositories a few times when zypper couldn’t do it

when it came up with the abort, retry ignore option.

Hit retry on the respository the r key

I get that with packman and the nVidia repository sometimes and hitting a retry gets me on.


I don’t see anything in the firewall setup that specifically blocks certain packages from http access.

Firefox and ping both get to download.opensuse.org


Yes I’ve tried retry and ignore endlessly without change.

thanks for the ideas:)

Try removing the repo’s and add them back in.

If that doesn’t work, consider using a mirror rather than the defaults.

openSUSE Download Mirrors - Overview

Tried that cat4926.

When changing to mirrors2.kernel.org Yast reports host nor found ‘mirrors2.kernel.org

Yet I can brows the repos in FireFox without issue.

Very strange.

Has to be some sort of cache issue with Yast/zypper but I haven’t found it so far.


from a su terminal

rpmdb --rebuilddb

then try

zypper refresh

Here’s what I’ve done this morning as a workaround.

Deleted the update, packman, OSS and NON-OSS download.opensuse.org repos using yast.

Added these repos back successfully using ftp IP of mirrors1.kernel.org as server name

Yast processes these repos Ok in this format

I’m stuck adding Packman, however, because I can’t get the IP

I’ll try your suggestion cat4926 and report results


This works without error and zypper refresh reports

linux-23z0:~ # zypper refresh
Repository ‘NON-OSS’ is up to date.
Repository ‘OSS’ is up to date.
Repository ‘Update’ is up to date.
All repositories have been refreshed.

However when I try to add the Packman repo back in Yast > Software > Repositories > Community

Yast says
Unable to download list of repositories
or no repositories defined.


try adding by the default URL option

use this
Index of /pub/packman/suse/11.1


URL option seems to work, if I first go to the URL in Firefox.

it seems once Yast tries the URL it doesn’t resolve and subsequent tries returns host not found, regardless if the URL

If I reboot.

Open the repo URL in the Firefox.

Then go to Yast and add Specify URL and copy/paste the URL from FireFox it works:)

Thanks for that Tip!

Yast/zypper seem to extremely buggy since 11.0.

As I noted above I have another laptop on this same lan that I installed 11.1/64 bit with identical packages and it works PERFECTLY!

Just found others with same problem here

Update broken in 11.1 - openSUSE Forums

I getting the same repository error, I am working with two different systems. I’m installing Opensuse 11.1 on both of them and I’m getting the Repository error that was listing the beginning of the thread. Except its with both the Nvidia Repository and the ATI repository, one system using an ATI crossfire chipset and the other using NVIDIA 2200 Pro Chipset. I tried my 11.0 disc and I had no problems adding the repositories

It seems to be well known that openSUSE/YaST/zypper is very fragile when it comes to updates from networked mirrors/repo’s.
this is supposed to be worked on for 11.2, In the mean time you seem to have to live with this fact.

A work around is:

  1. Identify the ‘bad/slack mirrors’. In a bash shell as root, run:
 iftop -i eth1

This will show you when you are connecting to said problem mirror hosts.

  1. Keep away from this mirror. Still as root:
  cp /etc/hosts /etc/hosts.backup
  echo "       mirror.name.org">>/etc/hosts 

Now you won’t avoid having to constantly choose: a/r/i
But you will avoid the timeout delays and you will also avoid mirrors that ‘respond’ but are terribly slow, like downloading 15MB at 2Kb/s…

Finally. Once you are done with your updates, etc.

  1. Once more in bash as root:
  cp /etc/hosts.backup /etc/hosts

There must be a better way to organize things. I have some ideas I’ll float in another thread, but that would be off topic here.