yast not starting properly

Yast was not starting up properly so I killed all Yast processes (graceful kill) and now when I go to Yast{2}-> Software -> Software Management, the Software Management interface don’t come up properly - it start the refresh and goes back to the Yast screen.

in /var/log/messages I can see kernel: rpmmd2solv[9959]: segfault at b7c429d1 ip b7e8095d sp bfcdb8b8 error 4 in libc-2.9.so[b7e0d000+155000] - this message comes two times when I click Software Management from Yast.

How can I resolve this issue?


As root, try a “rpm --rebuilddb” and see if this changes anything.


Hi there, here’s my two cents worth…
I am receiving the same error message, and I tried to rebuild the rpm --rebuilddb command, and still no resolve.

I had found in google that the pacman repo has caused issues, but being production servers, I had not setup the pacman or the videolan repos, just the standard four repos.
OSS, Update, Source, and Non-OSS repos… I disabled them all and still to no avail did it work correctly.

Any ideas from someone who is less baffled than myself.
(BTW I did have auto update enabled on my two servers and both are experiencing the same issues)

Thanks for your help.

Try booting to level 3
Login at the prompt as user
Then go su and do:

zypper ref
zypper up

If it’s going to fails it will probably fail on the first one

If zypper fails it’s unlikely the other option to start yast will work:


Also check this, see if changing this package helps: http://forums.opensuse.org/applications/408103-yast-software-manager-segfaults-2.html#post1955079
Let us know what happens

I have not tried the suggested link, however I received the following when running “zypper ref”

paris:~ # zypper ref
Repository ‘openSUSE-11.1-Update’ is up to date.
Building repository ‘openSUSE-11.1-Update’ cache [done]
Error building the cache:
‘repo2solv.sh’ ‘-o’ ‘/var/cache/zypp/solv/repo-update/solv’ ‘/var/cache/zypp/raw
/usr/bin/repo2solv.sh: line 325: 4253 Broken pipe ( echo ‘<rpmmd>’;
for i in primary.xml* susedata.xml*;
test -s “$i” || continue; case $i in
gzip -dc “$i”
bzip2 -dc “$i”
cat “$i”
esac; echo; break;
done; for i in susedata.xml
test -s “$i” || continue; case $i in
gzip -dc “$i”
bzip2 -dc “$i”
cat “$i”
esac; break;
done; echo ‘</rpmmd>’ )
4254 | grep -v ‘?xml’
4256 | sed ‘1i&lt;?xml version=“1.0” encoding=“UTF-8”? >’
4257 Segmentation fault | rpmmd2solv $parser_options > $primfile

Skipping repository ‘openSUSE-11.1-Update’ because of the above error.
Could not refresh the repositories because of errors.

I can tell that today there is a solver update in the update repo, let me post you the info:

2009-06-11 03:57:32|install|satsolver-tools|0.13.7-0.1.1|i586|root@linux-khq3|repo-update|42ad2dbdf32b315354c4bc2a3836f4ae12ec2b5f
2009-06-11 03:57:38|install|libzypp|5.30.3-0.1.1|i586||repo-update|2465a430882001f8a8de6eb0e9c827417c957e07

Things to try:
Manually download those and rpm install them

Rename the folders _old at /var/cache/zypp
try again

I should also note, after reading the post about yast2-qt-pkg … that’s for the GUI interface, and I’m not having an issue with the gui really; in the fact I generally just SSH without X-Server forwarding, and just use the console mode.

Fine. I just put it there for your ref:

Okay… I know I’m not the originator of the thread, but she’s working again.

Here’s my steps:
1.) Downloaded

2.) Copied to my /root folder
3.) Entered a console as root
4.) ran the commands:

rpm -i --force ./satsolver-tools-0.13.7-0.1.1.i586.rpm
rpm -i --force ./libzypp-5.30.3-0.1.1.i586.rpm

5.) Ran Yast, entered software management… worked.

Thanks alot everyone for your help!
Much appreciated!

Great - Happy we sorted it for you;)

The power of the community !!