Yast Not Responding in 13.2 Upgrade

OK, first I am not knowledgeable at all about Linux. I am trying to setup Opensuse on an ESXi 5.03u server. I installed 13.1 successfully but I was having many issues so thought I would upgrade to 13.2.
I am thinking I need to start fresh as I have probably really messed the install. When I open Yast now, click on something on the left and the try to access anything on the right I get two circles rotating for a few seconds and then nothing.
My ultimate goal for OpenSuse is to share an HP MSA20 disk array using CIFS shared to a Windows 2012 R2 server. Since the array is Ultra SCSI 320 I cannot do it directly to my new server. Seems SCSI is a thing of the past. LOL.

Should I just blow this away and start over or is there a fix? I saw in the forum a warning not to use BTRFS, not sure if I did or not.

Since this is a VM issue you should ask in the VM section of the forum.

I’d say it is likely that there is a fix.
First you should post the last lines of /var/log/YaST2/y2log, this should point to the problem.

And since this was an upgrade, you might still have some old YaST UI packages installed, causing it to fail.
What does this say?

rpm -qa libyui*

And please post your repo list as well:

zypper lr -d

I saw in the forum a warning not to use BTRFS, not sure if I did or not.

If you upgraded you most likely do not use BTRFS. An upgrade doesn’t change the partitioning or filesystems.

wolfi323,
Thanks for the prompt reply.
Please bare with me as I don’t have a clue what i am doing.
Sorry, I have not figured out how to copy and paste from ESXi to Windows yet. But here is a screen shot of those two commands you suggested. Looks like a lot of 13.1 stuff hanging around.
And this is what I get when I use Dolphin to get to the Log: “could not enter folder /var/log/Yast2”
When I logged into Terminal as SU I was able to get to the directory VAR, but when I tried LOG, it said no such directory or folder.

sorry cannot seem to insert images into fourum either. will try another browser.

Hm, no idea how to enable clipboard sharing with ESXi, never used that.

But you should remove all 13.1 repos with “sudo zypper rr X Y Z”, where X, Y, Z are the numbers shown by “zypper lr -d” (you can specify more than one repo to remove)…
Then, if you only have 13.2 repos left (the 4 standard ones in particular), run “sudo zypper dup” which should update all packages to the 13.2 versions.

If you upgraded with some 13.1 repos active, it is likely you have a mixture of packages now.
See here for how to correctly upgrade your openSUSE installation online:
https://en.opensuse.org/SDB:System_upgrade

And this is what I get when I use Dolphin to get to the Log: “could not enter folder /var/log/Yast2”

You need root privileges to open that folder. So use “Filemanager - Superuser Mode”.

When I logged into Terminal as SU I was able to get to the directory VAR, but when I tried LOG, it said no such directory or folder.

Please note that file/directory names are case sensitive on Linux. So LOG is not the same as log…
Try this:

sudo tail /var/log/YaST2/y2log

sorry cannot seem to insert images into fourum either. will try another browser.

Inserting images here is not possible.
You have to upload them to some picture sharing site like http://susepaste.org and post a link.

Something I forgot:
Try to run the text mode version of YaST in a terminal window:

sudo yast

Does that work?
If yes, check that libyui-qt6 and libyui-qt-pkg6 are installed, and install them if not. You probably still have the 13.1 versions (ending in 5) then.

I just restarted again andselected options. I have:
OpenSUSE 13.1, with Linux 3.16.6-2-desktop
OpenSUSE 13.1, with Linux 3.16.6-2-desktop (recovery mode)
OpenSUSE 13.1, with Linux 3.11.10-25-desktop
OpenSUSE 13.1, with Linux 3.11.10-25-desktop (recovery mode
Looks like a mess, no?

I tried SUSEPaste and got this:
http://susepaste.org/33394954

No, that’s “normal”.

The “openSUSE 13.1” is a user-definable string that isn’t changed on upgrades. You can change it to anything you like in YaST->System->Boot Loader (when it is working :wink: ). A fresh 13.2 installation uses just “openSUSE” to prevent that “issue” in the future.

And by default the previous kernel is kept on kernel updates, so you can boot that if there would be problems with the new one.
As you just freshly upgraded from 13.1, the previous kernel is of course the 13.1 one. But the kernel is not really specific to a particular openSUSE version, you can perfectly fine use 13.1’s kernel with 13.2 and vice-versa (though it’s of course not recommended).

For: sudo tail /var/log/YaST2/y2log I got,
several lines , but this is interesting:
“67 Looking for libyui-qt.so.6”
And then: cold NOT find libyui-qt.so.6 by looking recursive inside /usr/lib64/yui
And then cout not load UI plugin "qt:; libyui-qt.so.6

So I need to get that it looks like.
thanks, back tomorrow for more fun.
Any idea why my SUSEPaste is not working? Domain Policy?

Well, you used the URL to your susepaste page (which is not an image), not the URL to the actual image.
But I managed to find it… :wink:

http://susepaste.org/images/33394954.pngUnfortunately the right side is truncated, so this doesn’t tell anything at all for some repos.
You do still have all the 13.1 repos (and no 13.2 ones) active though, so how did you actually do the upgrade?

Follow the instructions on the page I linked to to really upgrade your system.
YaST should hopefully work then, if not check the libyui-qt packages as mentioned earlier.

Yes. As I already suspected, you don’t have libyui-qt6 installed (probably libyui-qt5 from 13.1). Install it (and libyui-qt-pkg6) and YaST should work:

sudo zypper in libyui-qt6 libyui-qt-pkg6

But you definitely should switch all your repos to 13.2 as well.

Any idea why my SUSEPaste is not working? Domain Policy?

No.
It is working.
But you posted the URL of that HTML page inside the [noparse] tags, not the URL of the picture.
I.e. http://susepaste.org/33394954 instead of http://susepaste.org/images/33394954.png (click on both links in your browser to see the difference… :wink: ).
You can get the URL of the picture by right-clicking on the picture and selecting “Copy picture URL” (or similiar, depending on your browser).

wolfi323,
Yast is working again after that command. Fantastic, thanks so much for sticking with me.
Have a great day.