Yast network settings ruby 2.5.0 error

How can I solve this?

Caller: /usr/lib64/ruby/2.5.0/ipaddr.rb:649:in `in6_addr’

Yast network settings gives this error

I suspect your IPv6 address is being set up incorrectly.
Do you know how your IP address is assigned to you?
Are you setting up a static IP address instead of usng DHCP?
Have you made any manual changes to your YaST network settings or Network Manager or are settings still the install default?


I have a static IPv4 address, the IPv6 is dhcp.
How can I renew the ipv6 dhcp?

Oh yes, I sometimes use a VPN connection

Is there some reason why you’re not standardizing on using DHCP or not for both?
And, are you sure you’re using DHCP for IPv6? And is there a reason to do so? This is because when IPv6 is supported, no DHCP or even configuration is needed unless you want to support incoming connections… An auto-generated IPv6 “link-local” address is always generated and configured so you have IPv6 connectevity without doing anything.

In other words…
If you really do have IPv6 DHCP configure somehow and don’t need it… Disable that. You’ll still have IPv6 network connectivity if you need it.


I am not sure about the IPv6 configuration.
Only make a IPv4 static adress.

Explaining what you were doing (the more details the better) that resulted in this output and providing full output and not just random line would be a good start. Best if you copy-paste full command and its output from terminal.

the error comes when i start yast network settings and then read device configuration.

Internal error. Please report a bug report with logs. │ │
│ │Run save_y2logs to get complete logs. │ │
│ │ │ │
│ │Caller: /usr/lib64/ruby/2.5.0/ipaddr.rb:649:in `in6_addr’ │ │
│ │ │ │
│ │Details: invalid address

Sorry but after trying through things I don’t have a network at all so I did a clean install.
Problem solved for me.
Thank you all for thinking along.