Yast Install/remove software crashes when trying to install gnome


I tried to install gnome and make it my default DE. I started up the Yast “Install/Remove Software” application, Switched to View->Patterns picked gnome desktop environment and pressed “Accept”. It was crunching away until it got stuck and it was stuck for a solid 30 minutes. My internet connection was working, so i killed the process and tried again. But since then when I press Accept the app just crashes.

What should I do?

Do you allready have an idea why it crashes ? Did you check logfiles for error messages ? Did you start the app from command line ( IIRC “yast2 sw_single”) and watch the output there ? Mightbe it is also something like “disk full”.

This is the error message:

2019-04-24T10:41:05.144356+02:00 linux-x277 kwin_x11[2267]: qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 46052, resource id: 104857728, major code: 18 (ChangeProperty), minor code: 0

This could be a KDE crash? because I saw Kwin related error message, can you try login in through the ICEwm session and trying the same steps?

It works! Thank you! How can I fix the KDE problem?

Nevermind it works.