Yast hangs in "controlling the environment" in HTTP-server module

I’d like to use Yast to configure my (already existing) HTTP-stack on Apache2. But Yast hangs (for a couple of hours now) on “controlling the environment” (my translation of Dutch “De omgeving wordt gecontroleerd”).
I’ve tried it with a running and not running http-server, both times the same result.

The last messages from yast2log are

[Ruby] modules/HttpServer.rb:299 DNS server is not correctly configured via YaST.
[Ruby] modules/HttpServer.rb:304 DNS running and configured: false
[ag_http_server] YaPI is deprecated, do not use it anymore! It will be removed soon.
-e] CERT_ERROR[1802:/usr/share/YaST2/modules/YaPI/HTTPD.pm] Er is voor deze host-ID geen CA-certificaatbestand geconfigureerd.
-e] CERT_ERROR[1719:/usr/share/YaST2/modules/YaPI/HTTPD.pm] No certificate file configured for this host ID.
-e] CERT_ERROR[1760:/usr/share/YaST2/modules/YaPI/HTTPD.pm] Voor deze host-ID is geen certificaat-sleutelbestand geconfigureerd.
(Translated: No certificate key file configured for this host-id)
[bash] ShellCommand.cc(shellcommand):78 Vim: Waarschuwing: Uitvoer gaan niet naar een terminal
(Translated: Vim: Warning: Output does not go to a terminal)
[bash] ShellCommand.cc(shellcommand):78 Vim: Waarschuwing: Invoer komt niet van een terminal
(Translated: Vim: Warning: Input does not come from a terminal)

I don’t see further error messages in yast2log, but that may be my ignorance.

Any ideas here?

FWIW: on TW 20190121 I don’t see this issue. Any additional repos involved ?

I’m on 20190121 too.

Besides the standard TW-repo’s I have only Nvidia TW and Packman TW repos active, the last only for vlc, codecs and that lot.
So, I don’t see anything odd for Yast ot its modules here.

You could probably start by configuring and verifying DNS… Are you running Wicked or NM (generally speaking, you should probably be running Wicked when setting up a web server, although it shouldn’t be a critical issue to use NM).

Make sure you’re set up with a static IP address, or possibly a reserved lease and then assign your web server configuration to that address.