xvid codec Failure !!

i have got Xvid codec from the one of the repotries out the Suse software search …

But the Videos are not playing in Banshee … nor the Thumbnails are Displaying …

… Other codec’s are playing well in Banshee … and the Thumbnails are diaplaying …

can any one tell me where can be the wrong … i have got 3 different codecs sources for xvid codec … the source was not the problem, if there any extra configuration … please let me know …

Have you already used;
Restricted Formats/11.2 - openSUSE-Community

I have the same problem. I can watch avi files with xvid codec in vlc but not in totem or banshee. the movie never starts. in vlc everything is ok. why that?

Yeah used that tooo … But same error …

This is Because the Banshee and Totem uses Gstreamer for Coding there comes the problem … Xvid was not working in it … if u have tried other formats they should have been worked fine … and THumbnails for avi which have xvid codec are not displayed … this is beacuse the default encoder of system was Gstreamer …

I tried to reinstall gstremer codec as in the restricted guide. no way ,totem still doesn’t work

I’m having the same problem with Totem. Though I’m able to watch divx files in smplayer. I’ve followed the instruction through that link and also through this one http://forums.opensuse.org/new-user-how-faq-read-only/407184-multi-media-restricted-format-installation-guide.html I’ve followed those instructions a couple times now in slightly different ways. Nothing seems to work.

I’d like to convert “recordmydesktop” ogv files to avi and then manipulate them in avidemux. I’ve tried using VLC and handbrake for the conversion, avidemux can’t handle the converted files.

From what I’ve seen, it appears that gstreamer is broke. But following the instructions from those links don’t fix the problem.

Same here.
It used to work but now gstreamer is totally broken.

See my post : gstreamer issue - openSUSE Forums

I have tried all possible combination, but none of them worked.

Something is messed up and I can’t find what.

have you tried using xvidenc or divxenc, from my repo in my sig? :wink:

Also, why don’t just people use something that works, like I dunno, mplayer and xine? ;), but instead waste their time in trying to fix the mess that is gstreamer?

Because gstreamer has always worked for me for years.

It used to work with Debian or Ubuntu on my laptop before I switch to openSUSE 11.1.

It also worked very well with 11.2.

So why should we resign ?

There is just a bug that deserve to be fixed.

I see there are not many gstreamer users here, but gstreamer is the only and best for a perfect and complete integration with all Gnome apps.

So I know it works with xine, but I can’t be satisfied with it.

gstreamer has more problems than mplayer itself, despite mplayer having probably the most ugly code out there and it’s a mess. Still, this hasn’t prevented it from beating every single player out there. Also, there’s absolutely no reason whatsoever why mplayer can’t be integrated in gnome, considering that mplayer is command line only and if a GUI is needed, there are lots of front-ends written for GTK/GNOME

In short; gstreamer is what VfW used to be on Windows. A total mess and a wonder it works most of the time

I have gnome-mplayer on my laptop, but still I prefer Totem. Gstreamer is also used by Banshee.
And mplayer won’t give me any preview in nautilus.
By the way, I tried to install totem-xine but libnvtvsimple.so is missing.

So right now, if there is a mess, it is not in gstreamer (that works in most cases) but rather in the pacman packages.

well, that’s not really the fault of mplayer not giving you preview in nautilus, is it? if nautilus doesn’t support mplayer for previews…

As for gstreamer, contact the packman packagers. Little we can do about it here

So if nautilus does not support mplayer, then why do I use Gnome ? :smiley:
You may be an anti-gstreamer or pro-mplayer, but please don’t be so pushy.

We are discussing and trying to find a solution to a issue with gstreamer. Comma.

is that a trick question? as I said, you can’t blame the player itself IF the file manager doesn’t support it for previewing. I have no idea if nautilus supports mplayer for previewing so you tell me if it does or not… if it really does but still you can’t get it, then there’s something wrong in how nautilus connects to mplayer for these previews, again not the fault of mplayer itself

The solution is to contact the packagers, unless you want to fiddle yourself, patch/rebuild whole gstreamer, etc

Also, I’m not pushy :wink: If I was, I will only dictate mplayer, something I obviously didn’t as in my first post I said to use other solutions if the current one doesn’t work. When it’s fixed, then go back to it, but until then IMO one should use something that works as a replacement

I’ve no clue why you’re on GNOME… :slight_smile:

Ok, ok, I misunderstood, sorry.
I did report the issue to the package maintainer a few days ago, and got some feedback, but nothing more so far.
Wait and see…

Well, I’ve seen more than once packages from packman being either “broken” or just didn’t work like they should. I’ve even seen mplayer packages on more than one occasion not working like they should. Good thing that I never use mplayer from packman, nor x264, xvid, lame, etc. I always self-compile these proggies since I must have the latest ones due to development work and testing I’m doing

I am having the same problem: gstreamer not playing xvid (and perhaps other formats) with freshly installed opensuse 11.2 32-bit with packman packages. BTW, in openSuse 11.1 it worked. Looking into the packman mailinglist, it looks like there is a problem with gstreamer010-ffmpeg 0.10.9-999.pm.999.3

I do not want to use gstreamer but unfortunately I am forced to use it. OpenOffice Impress is using gstreamer to play movies in its presentations and I need impress for my work. So this is another reason why some people have to use gstreamer.

Good news !
There were a bunch of updates on Pacman today, many concerning ffmpeg and gstreamer.
And now it works fine back ! Good work and thanks to the pacman team.

withb today updates to gstreamer the problem is solved!