Xserver doesn't start anymore after yesterdays online update

Hi Folks,

I have an issue with the Xserver and/or the graphic driver.
Everything worked fine until yesterday. There was an online update around 11:30 PM and I just applied it. After reboot the Xserver did start but the resolution was set to 800x600. No way to change it within the system settings. So I tried to install the nvidia driver because it did work fine before the update.
Now the Xserver doesn’t start anymore. At the end of the boot process it immediately enters the console.
If I try “init 5” it starts the green screen (the one with the chameleon) and never reaches the login prompt.

I tried the nvidia-xconfig command. Didn’t help.
If I try

nvidia-setting -g

it prompts: “ERROR: Cannot open display ´´.”

I installed any ****… driver that yast proposes (origianla nvidia driver, x11-video-nvidiaG02, nouveau) but nothing works.
Video Card is NV44 [GeForce 7100 GS] (rev a1).

Would be great if anybody here could give me a hint how to fix this.

What version of openSUSE
What Desktop?

OS: opensuse 12.3
KDE: 4.10

It’s possible you fell prey to a bug
You should check this post:

Well, I don’t think this is the case because of:

But if that is indeed your problem, just reinstall kdm and it should work again.

zypper in -f kdm

If that doesn’t help, try to rename the file /etc/X11/xorg.conf, you should be able to get to a graphical system then…

mv /etc/X11/xorg.conf /etc/X11/xorg.conf.bak

And then, please post the file /var/log/Xorg.0.log

I fixed the problem so far. Or at least, worked around it.
I just installed a system backup, applied the latest updates and now I am back again.

At the moment the nouveau driver is installed. It crashes at any logout, shutdown or reboot and just out of nothing from time to time. Beside those effects it works pretty fine.

And btw: Of course I did do the xorg.conf.bak stuff. Didn’t work. And I also did the nvidia-config with the same result. Didn’t work.

No xorg.conf is available at the moment.

Thanks for your help!