XRDP Console Session not connecting

I have been using XRDP for a long time on all my systems which include Leap 15.1 and Tumbleweed. Not has any issues but each connection opens up a new session, as expected. Documentation suggests it is possible to connect to the existing main console session. Can’t find any references to this with SUSE but checking some Ubuntu forums it looks like adding this code to xrdp.ini should work.

[Console]
name=console
lib=libvnc.so
ip=127.0.0.1
port=5900
username=na
password=ask
delay_ms=2000

It doesn’t for me! I just get connection errors as follows:

VNC started connecting
Waiting 2000 ms for VNC to start
VNC connecting to 127.0.0.1 5900
VNC error - problem connecting
some problem

Anyone ever got XRDP to work mirroring the console instead of a new session?

Thanks,

Julian
https://www.dropbox.com/s/kmnoi7gzc7nphhn/Capture.JPG

https://www.dropbox.com/s/kmnoi7gzc7nphhn/Capture.JPG?dl=0

It seems that, you’re attempting to connect to the IPv4 Local Host – IPv4 address 127.0.0.1.

  • Can you ping “localhost” and ‘127.0.0.1’?

[HR][/HR]On this Leap 15.0 system, a ping to ‘127.0.0.7’ is OK but, a ping to ‘localhost’ is also OK but, it’s using the IPv6 address …

I can ping 127.0.0.1 and localhost (both IPv4 and IPv6).

I suspect that VNC is not starting or starting on the wrong port.

How are the systemd vnc services looking?

  • I’m not using VNC here but, there are three xvnc systemd services on this machine – two static and one (xvnc.socket) disabled …

Every flavor of VNC is set up and configured somewhat differently, so when you read general guides on the Internet, you have to be very discerning or strictly follow TigerVNC documentation (which is what openSUSE uses).

For your specific question about connecting to an existing session…
The following describes how to set this up

https://doc.opensuse.org/documentation/leap/reference/html/book.opensuse.reference/cha.vnc.html#sec.vnc.persistent

TSU

I am not actually running a VNC server but XRDP is using libvnc. It maybe the case that it is not possible on SUSE, hence the request for anyone that has made it work.

Thanks.

Then, it could be that, PolKit is preventing XRDP from accessing libvnc. The documentation is here: <https://doc.opensuse.org/documentation/leap/security/html/book.security/cha.security.policykit.html&gt;.

Then you’ll have to describe how you’re using XRDP, it’s only a protocol and <how> you use XRDP in an application might make a diff…
So, for instance I use XRDP when I forward X over SSH, I often fine it convenient to set up by using the YaST module to set up and configure VNC which also enables problem-free use of X over SSH.

TSU

@JulinaB:

Are you using the XRPD packages from the openSUSE repositories? – <https://software.opensuse.org/package/xrdp>.

  • Be careful with “One-Click Install” – you can easily end up with Tumbleweed repositories on your system …