XPS 13 Plus 9320: Audio, Kamera u. externe Monitore werden nicht erkannt

Hallo

ich habe einen XPS 13 Plus 9320 mit:

Prozessor: 12th Generation Intel(R) Core™ i7-1260P (18MB Cache, up to 4.7 GHz, 12 cores)
Speicher: 32 GB LPDDR5, 5.200 MHz, integriert, Dual-Channel
Storage: 1TB M.2 PCIe Gen 4 NVMe Solid State Drive
Grafik: Intel(R) Iris(R) Xe Grafik G7 (integriert)
Kamera: 1 x RGB-Kamera mit HD-Auflösung u. 1 x IR-Kamera
Audio: Realtek ALC1319D

BIOS 1.11.0

Betriebssystem: openSUSE Leap 15.4
KDE-Plasma-Version: 5.24.4
KDE-Frameworks-Version: 5.90.0
Qt-Version: 5.15.2
Kernel-Version: 5.14.21-150400.24.41-default (64-bit)
Grafik-Plattform: X11
Prozessoren: 16 × 12th Gen Intel® Core™ i7-1260P
Speicher: 31,0 GiB Arbeitsspeicher
Grafikprozessor: llvmpipe

Probleme in dieser Kombination:

Externe Bildschirme werden nicht erkannt;
Internes Audiosystem wird nicht erkannt;
Interne Kamera wird nicht erkannt.

Anscheinend gibt es nur Treiber für Ubuntu. Wann wird es Grafik-, Audio- und Kameratreiber für openSUSE geben?

Danke + Gruß

Leap 15.4 benutzt einen Kernel 5.14 (backported 5.15?).
Du kannst einen aktuellen Kernel aus kernel:stable:backports benutzen, der ist zur Zeit bei Kernel 6.1.8.
Als root
zypper ar -f -p 50 https://mirrorcache-eu.opensuse.org/repositories/Kernel:/stable:/Backport/standard/ kernel-stable-backports

zypper dup --allow-vendor-change --from https://mirrorcache-eu.opensuse.org/repositories/Kernel:/stable:/Backport/standard/

Neu starten.

Den Kernel benutze ich hier in Leap 15.4 auch:

uname -a && lsb-release -id
Linux linux64 6.1.8-lp153.3.g2d8f09a-default #1 SMP PREEMPT_DYNAMIC Tue Jan 24 08:14:27 UTC 2023 (2d8f09a) x86_64 x86_64 x86_64 GNU/Linux
Distributor ID: openSUSE
Description:    openSUSE Leap 15.4

Hallo Sauerland,

vielen Dank für die schnelle und super kompetente Antwort. Mit dem neuen Kernel werden nun externe Monitore und das interne Audiosystem erkannt. Die Kamera wird noch nicht gefunden. Leider gibt es auch im BIOS keinen Funktionstest dafür, sodass ich kann nicht hundertprozentig ausschließen kann, dass sie defekt ist, was allerdings bei einem neuen Gerät nicht der Fall sein sollte. Hast du eine Idee wie ich das testen könnte.
Nochmals vielen Dank für Deine Hilfe.

Beste Grüße

Du könntest mal mit einer einfachen Kamerasoftware wie zum Beispiel “cheese” testen, ob du ein Bild bekommst. “cheese” ist in den Paketquellen vorhanden…

…ihr seid aber schnell. Danke. Ich habe es mit cheese und kamoso von KDE versucht. Leider kein Bild.

Zeig mal bitte den Output folgenden Befehls um genau zu sehen, was für Hardware vorhanden ist.

 lspci -nn

und

inxi -F

sudo lscpi -nn gibt zurück:

00:00.0 Host bridge [0600]: Intel Corporation Device [8086:4621] (rev 02)
00:02.0 VGA compatible controller [0300]: Intel Corporation Alder Lake-P Integrated Graphics Controller [8086:46a6] (rev 0c)
00:04.0 Signal processing controller [1180]: Intel Corporation Alder Lake Innovation Platform Framework Processor Participant [8086:461d] (rev 02)
00:05.0 Multimedia controller [0480]: Intel Corporation Device [8086:465d] (rev 02)
00:06.0 PCI bridge [0604]: Intel Corporation 12th Gen Core Processor PCI Express x4 Controller #0 [8086:464d] (rev 02)
00:07.0 PCI bridge [0604]: Intel Corporation Alder Lake-P Thunderbolt 4 PCI Express Root Port #0 [8086:466e] (rev 02)
00:07.2 PCI bridge [0604]: Intel Corporation Alder Lake-P Thunderbolt 4 PCI Express Root Port #2 [8086:462f] (rev 02)
00:08.0 System peripheral [0880]: Intel Corporation 12th Gen Core Processor Gaussian & Neural Accelerator [8086:464f] (rev 02)
00:0d.0 USB controller [0c03]: Intel Corporation Alder Lake-P Thunderbolt 4 USB Controller [8086:461e] (rev 02)
00:0d.2 USB controller [0c03]: Intel Corporation Alder Lake-P Thunderbolt 4 NHI #0 [8086:463e] (rev 02)
00:0d.3 USB controller [0c03]: Intel Corporation Alder Lake-P Thunderbolt 4 NHI #1 [8086:466d] (rev 02)
00:12.0 Serial controller [0700]: Intel Corporation Alder Lake-P Integrated Sensor Hub [8086:51fc] (rev 01)
00:14.0 USB controller [0c03]: Intel Corporation Alder Lake PCH USB 3.2 xHCI Host Controller [8086:51ed] (rev 01)
00:14.2 RAM memory [0500]: Intel Corporation Alder Lake PCH Shared SRAM [8086:51ef] (rev 01)
00:14.3 Network controller [0280]: Intel Corporation Alder Lake-P PCH CNVi WiFi [8086:51f0] (rev 01)
00:15.0 Serial bus controller [0c80]: Intel Corporation Alder Lake PCH Serial IO I2C Controller #0 [8086:51e8] (rev 01)
00:15.1 Serial bus controller [0c80]: Intel Corporation Alder Lake PCH Serial IO I2C Controller #1 [8086:51e9] (rev 01)
00:16.0 Communication controller [0780]: Intel Corporation Alder Lake PCH HECI Controller [8086:51e0] (rev 01)
00:1e.0 Communication controller [0780]: Intel Corporation Alder Lake PCH UART #0 [8086:51a8] (rev 01)
00:1e.3 Serial bus controller [0c80]: Intel Corporation Device [8086:51ab] (rev 01)
00:1f.0 ISA bridge [0601]: Intel Corporation Alder Lake PCH eSPI Controller [8086:5182] (rev 01)
00:1f.3 Multimedia audio controller [0401]: Intel Corporation Alder Lake PCH-P High Definition Audio Controller [8086:51c8] (rev 01)
00:1f.4 SMBus [0c05]: Intel Corporation Alder Lake PCH-P SMBus Host Controller [8086:51a3] (rev 01)
00:1f.5 Serial bus controller [0c80]: Intel Corporation Alder Lake-P PCH SPI Controller [8086:51a4] (rev 01)
01:00.0 Non-Volatile memory controller [0108]: KIOXIA Corporation Device [1e0f:000d]

…und inxi -F gibt zurück:

ystem: Host: localhost Kernel: 6.1.8-lp153.3.g2d8f09a-default x86_64 bits: 64 Desktop: KDE Plasma 5.24.4
Distro: openSUSE Leap 15.4
Machine: Type: Laptop System: Dell product: XPS 9320 v: N/A serial:
Mobo: Dell model: 0CW9KM v: A00 serial: UEFI: Dell v: 1.11.0 date: 12/09/2022
Battery: ID-1: BAT0 charge: 53.1 Wh (100.0%) condition: 53.1/54.4 Wh (97.6%)
CPU: Info: 8-Core model: 12th Gen Intel Core i7-1260P bits: 64 type: MT MCP cache: L2: 18 MiB
Speed: 2500 MHz min/max: 400/4700 MHz Core speeds (MHz): 1: 2500 2: 2500 3: 2500 4: 2500 5: 2500 6: 2500 7: 2500
8: 2500 9: 937 10: 2500 11: 2500 12: 2500 13: 2500 14: 2500 15: 2500 16: 2500
Graphics: Device-1: Intel Alder Lake-P Integrated Graphics driver: i915 v: kernel
Device-2: Logitech Logitech Webcam C925e type: USB driver: snd-usb-audio,uvcvideo
Display: x11 server: X.Org 1.20.3 driver: loaded: modesetting unloaded: fbdev,vesa resolution: 1: 3840x2400~60Hz
2: 5120x1440~60Hz
OpenGL: renderer: Mesa Intel Graphics (ADL GT2) v: 4.6 Mesa 21.2.4
Audio: Device-1: Intel driver: N/A
Device-2: Intel Alder Lake PCH-P High Definition Audio driver: sof-audio-pci-intel-tgl
Device-3: Plantronics Savi 7xx type: USB driver: plantronics,snd-usb-audio,usbhid
Device-4: Logitech Logitech Webcam C925e type: USB driver: snd-usb-audio,uvcvideo
Device-5: Realtek USB Audio type: USB driver: snd-usb-audio
Sound Server-1: ALSA v: k6.1.8-lp153.3.g2d8f09a-default running: yes
Sound Server-2: PulseAudio v: 15.0 running: yes
Sound Server-3: PipeWire v: 0.3.49 running: yes
Network: Device-1: Intel Alder Lake-P PCH CNVi WiFi driver: iwlwifi
IF: wlan0 state: down mac: 56:bc:4d:5c:1d:1c
Device-2: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152
IF: eth0 state: up speed: 1000 Mbps duplex: full mac: 08:92:04:86:8a:11
Bluetooth: Device-1: Intel type: USB driver: btusb
Report: rfkill ID: hci0 state: up address: see --recommends
Drives: Local Storage: total: 953.87 GiB used: 31.01 GiB (3.3%)
ID-1: /dev/nvme0n1 vendor: KIOXIA model: KXG70ZNV1T02 NVMe 1024GB size: 953.87 GiB
Partition: ID-1: / size: 97.87 GiB used: 11.48 GiB (11.7%) fs: ext4 dev: /dev/dm-2
ID-2: /boot/efi size: 14.99 GiB used: 40 MiB (0.3%) fs: vfat dev: /dev/nvme0n1p1
ID-3: /home size: 761.63 GiB used: 19.49 GiB (2.6%) fs: ext4 dev: /dev/dm-3
Swap: ID-1: swap-1 type: partition size: 64 GiB used: 0 KiB (0.0%) dev: /dev/dm-1
Sensors: Message: No sensor data found. Is lm-sensors configured?
Info: Processes: 380 Uptime: 0h 8m Memory: 30.97 GiB used: 5.27 GiB (17.0%) Shell: Bash inxi: 3.3.07

Ok, da haben wir schon mal den Typ deiner Kamera:

Device-2: Logitech Logitech Webcam C925e type: USB driver: snd-usb-audio,uvcvideo

Ist das eine externe Kamera?

…sorry ich habe die Befehle abgesetzt als der Rechner noch an der Thunderbolt Dock hing. Die Logitech Webcam C925e ist eine externe Kamera und die funktioniert auch einwandfrei. Es geht aber um die integrierte Kamera, diese hat wohl zwei Objektive 1 x RGB-Kamera mit HD-Auflösung u. 1 x IR-Kamera. Mehr Infos dazu habe ich bei DELL leider nicht gefunden.

Dann bitte nochmal beide Befehle ohne Dockingstation. Aber soweit ich das sehe, wird die interne Kamera gar nicht erkannt…

Ich hab es gefunden…ist so ein Laptop wo sich der Hersteller was ganz tolles ausgedacht hat. Einen speziellen Treiber den es nur für Ubuntu gibt damit die Kamera erkannt wird :face_with_symbols_over_mouth:
https://www.dell.com/support/kbdoc/de-de/000203830/webcam-wird-auf-xps-13-plus-9320-laptops-mit-ubuntu-22-04-nicht-erkannt

…schade. Wird es Ihrer Meinung nach irgendwann einmal einen Standardtreiber für alle Plattformen geben? Was bringt es wenn ich bei Dell nachfrage? Ich habe da schon das eine oder andere gekauft.

Hier noch die gewünschten Meldungen:

sudo lspci -nn

00:00.0 Host bridge [0600]: Intel Corporation Device [8086:4621] (rev 02)
00:02.0 VGA compatible controller [0300]: Intel Corporation Alder Lake-P Integrated Graphics Controller [8086:46a6] (rev 0c)
00:04.0 Signal processing controller [1180]: Intel Corporation Alder Lake Innovation Platform Framework Processor Participant [8086:461d] (rev 02)
00:05.0 Multimedia controller [0480]: Intel Corporation Device [8086:465d] (rev 02)
00:06.0 PCI bridge [0604]: Intel Corporation 12th Gen Core Processor PCI Express x4 Controller #0 [8086:464d] (rev 02)
00:07.0 PCI bridge [0604]: Intel Corporation Alder Lake-P Thunderbolt 4 PCI Express Root Port #0 [8086:466e] (rev 02)
00:07.2 PCI bridge [0604]: Intel Corporation Alder Lake-P Thunderbolt 4 PCI Express Root Port #2 [8086:462f] (rev 02)
00:08.0 System peripheral [0880]: Intel Corporation 12th Gen Core Processor Gaussian & Neural Accelerator [8086:464f] (rev 02)
00:0d.0 USB controller [0c03]: Intel Corporation Alder Lake-P Thunderbolt 4 USB Controller [8086:461e] (rev 02)
00:0d.2 USB controller [0c03]: Intel Corporation Alder Lake-P Thunderbolt 4 NHI #0 [8086:463e] (rev 02)
00:0d.3 USB controller [0c03]: Intel Corporation Alder Lake-P Thunderbolt 4 NHI #1 [8086:466d] (rev 02)
00:12.0 Serial controller [0700]: Intel Corporation Alder Lake-P Integrated Sensor Hub [8086:51fc] (rev 01)
00:14.0 USB controller [0c03]: Intel Corporation Alder Lake PCH USB 3.2 xHCI Host Controller [8086:51ed] (rev 01)
00:14.2 RAM memory [0500]: Intel Corporation Alder Lake PCH Shared SRAM [8086:51ef] (rev 01)
00:14.3 Network controller [0280]: Intel Corporation Alder Lake-P PCH CNVi WiFi [8086:51f0] (rev 01)
00:15.0 Serial bus controller [0c80]: Intel Corporation Alder Lake PCH Serial IO I2C Controller #0 [8086:51e8] (rev 01)
00:15.1 Serial bus controller [0c80]: Intel Corporation Alder Lake PCH Serial IO I2C Controller #1 [8086:51e9] (rev 01)
00:16.0 Communication controller [0780]: Intel Corporation Alder Lake PCH HECI Controller [8086:51e0] (rev 01)
00:1e.0 Communication controller [0780]: Intel Corporation Alder Lake PCH UART #0 [8086:51a8] (rev 01)
00:1e.3 Serial bus controller [0c80]: Intel Corporation Device [8086:51ab] (rev 01)
00:1f.0 ISA bridge [0601]: Intel Corporation Alder Lake PCH eSPI Controller [8086:5182] (rev 01)
00:1f.3 Multimedia audio controller [0401]: Intel Corporation Alder Lake PCH-P High Definition Audio Controller [8086:51c8] (rev 01)
00:1f.4 SMBus [0c05]: Intel Corporation Alder Lake PCH-P SMBus Host Controller [8086:51a3] (rev 01)
00:1f.5 Serial bus controller [0c80]: Intel Corporation Alder Lake-P PCH SPI Controller [8086:51a4] (rev 01)
01:00.0 Non-Volatile memory controller [0108]: KIOXIA Corporation Device [1e0f:000d]

inxi -F

System: Host: localhost Kernel: 6.1.8-lp153.3.g2d8f09a-default x86_64 bits: 64 Desktop: KDE Plasma 5.24.4
Distro: openSUSE Leap 15.4
Machine: Type: Laptop System: Dell product: XPS 9320 v: N/A serial:
Mobo: Dell model: 0CW9KM v: A00 serial: UEFI: Dell v: 1.11.0 date: 12/09/2022
Battery: ID-1: BAT0 charge: 50.1 Wh (94.4%) condition: 53.1/54.4 Wh (97.6%)
CPU: Info: 8-Core model: 12th Gen Intel Core i7-1260P bits: 64 type: MT MCP cache: L2: 18 MiB
Speed: 2500 MHz min/max: 400/4700 MHz Core speeds (MHz): 1: 1055 2: 2500 3: 2500 4: 2500 5: 2500 6: 2500 7: 2500
8: 2500 9: 2500 10: 2500 11: 2500 12: 2500 13: 2500 14: 2500 15: 2500 16: 2500
Graphics: Device-1: Intel Alder Lake-P Integrated Graphics driver: i915 v: kernel
Display: x11 server: X.Org 1.20.3 driver: loaded: modesetting unloaded: fbdev,vesa resolution: 3840x2400~60Hz
OpenGL: renderer: Mesa Intel Graphics (ADL GT2) v: 4.6 Mesa 21.2.4
Audio: Device-1: Intel driver: N/A
Device-2: Intel Alder Lake PCH-P High Definition Audio driver: sof-audio-pci-intel-tgl
Sound Server-1: ALSA v: k6.1.8-lp153.3.g2d8f09a-default running: yes
Sound Server-2: PulseAudio v: 15.0 running: yes
Sound Server-3: PipeWire v: 0.3.49 running: yes
Network: Device-1: Intel Alder Lake-P PCH CNVi WiFi driver: iwlwifi
IF: wlan0 state: down mac: 92:1e:3d:4b:6f:3e
Bluetooth: Device-1: Intel type: USB driver: btusb
Report: rfkill ID: hci0 state: up address: see --recommends
Drives: Local Storage: total: 953.87 GiB used: 30.97 GiB (3.2%)
ID-1: /dev/nvme0n1 vendor: KIOXIA model: KXG70ZNV1T02 NVMe 1024GB size: 953.87 GiB
Partition: ID-1: / size: 97.87 GiB used: 11.49 GiB (11.7%) fs: ext4 dev: /dev/dm-2
ID-2: /boot/efi size: 14.99 GiB used: 40 MiB (0.3%) fs: vfat dev: /dev/nvme0n1p1
ID-3: /home size: 761.63 GiB used: 19.44 GiB (2.6%) fs: ext4 dev: /dev/dm-3
Swap: ID-1: swap-1 type: partition size: 64 GiB used: 0 KiB (0.0%) dev: /dev/dm-1
Sensors: Message: No sensor data found. Is lm-sensors configured?
Info: Processes: 377 Uptime: 0h 2m Memory: 30.97 GiB used: 2.35 GiB (7.6%) Shell: Bash inxi: 3.3.07

…darf ich bitte noch eine Frage zur Bildschirmauflösung stellen? Mit dem neuen Kernel lässt sich die Auflösung des externen Monitors einwandfrei einstellen. Die des Laptops aber nicht und die Auflösung ist winzig 3840x2400 s. Anhang. Kann man da was machen?

Du verwendest eine Wayland Session. Da ich Wayland (persönlich) immernoch als unzuverlässig und buggy empfinde, verwende ich es nicht. Deshalb kann ich auch nicht sagen ob das ein gnerelles Wayland/Plasma Problem ist. Aber du kannst natürlich testweise eine X11 session starten (wenn du dich als User anmeldest einfach den X11 Typ auswählen) und schauen, ob du da die Auflösung ändern kannst. Ich gehe aber stark davon aus, das es unter X11 reibungslos funktioniert…

Zum Thema Kamera:
Poste
lsusb

…ich war mit einer X11 Session angemeldet obwohl die Info impliziert, dass ich mit einer Wayland Session angemeldet war. Jedenfalls habe ich dann auch Wayland ausprobiert. Hier konnte man die Auflösung des Laptop Screens auch nicht verändern aber man konnte diesen individuell skalieren und das kann man unter X11 nur global. Da man unter Wayland wieder andere Tools braucht arbeite ich erst mal weiter mit X11.
Du hast mir sehr geholfen. Danke dafür.

sorry hier noch was lsusb zurückgibt:

Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 003: ID 27c6:63bc Shenzhen Goodix Technology Co.,Ltd. Goodix USB2.0 MISC
Bus 003 Device 002: ID 8086:0b63 Intel Corp. USB Bridge
Bus 003 Device 004: ID 8087:0033 Intel Corp.
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Hallo,
nochmals Danke für Eure Hilfe. Mit dem 6 er Kernel gehen schon mal externe Screens und das interne audio (Mikro und Lautsprecher). Das ich auf die interne Kamera verzichten muss ist schade aber ist wohl auf absehbare Zeit so.
Was massiv stört ist die Auflösung des Laptop Bildschirms (3840x2400) screen shot s.o. und das ist auch unter X11 so.
Mit dem 5 er Kernel geht aber Standard HD

Habt Ihr einen Tip wie das auch mit dem 6er Kernel gehen könnte.
Danke + Gruß

Mein System ist

Betriebssystem: openSUSE Tumbleweed 20230304
KDE-Plasma-Version: 5.27.2
KDE-Frameworks-Version: 5.103.0
Qt-Version: 5.15.8
Kernel-Version: 6.2.1-1-default (64-bit)
Grafik-Plattform: X11
Grafikprozessor: Mesa Intel® HD Graphics 630
eDP-1 connected primary 3840x2160+0+0 (normal left inverted right x axis y axis) 344mm x 194mm

und ich stelle in systemsettings5 unter Anzeige und MonitorAnzeige-Einrichtung den Parameter Globale Skalierung auf den Wert 200% und nach dem nächsten Ab-/Anmelden wird mein Bildschirm entsprechend skaliert.

Hallo susejunky,
vielen Dank für Deine schnelle Antwort. Die Globale Skalierung auf 200% setzen habe ich auch schon ausprobiert. Da bleiben aber zwei Problem die Skalierung greift eben global auch bei angeschlossenen externen Bildschirmen und die Menueleiste (wenn der Laptop Screen der primäre ist) bleibt zumindest bei mir immer noch so klein.
Beste Grüße