XP Windows install and will loss GRUB

Hi all,

I virus got my XP installation this morning. I have to install it. When I install windows it will write over the GRUB and I will no longer be able to re-boot my openSusie OS.

My question is After XP is installed is there a way to re-install GRUB without having to re-install openSusie 11.2?

Any help will be appreciated! :slight_smile:

Thank you,
Paul :’(

Hash: SHA1

Yes, boot your PC using the DVD and the repair mode, then select repair
grub, other method if you don’t have the DVD is using the live CD and
select boot installed system, once on openSUSE go to YaST2 and repair
the boot loader

No in elenath hîlar nan hâd gîn
Version: GnuPG v2.0.12 (GNU/Linux)
Comment: Using GnuPG with SUSE - http://enigmail.mozdev.org/



Thank you for your response. I appreciate it and makes sense. :wink:

This is a company laptop. Thank God I had openSusie installed. I was able to xfer all my important files to memory sticks.

The XP install is about done so all I got to do is get the rest of the apps installed.

This is great! I didn’t want to have to reinstall openSusie because I have it just the way I want it and love it. I was able to continue my development on my project today.

Thanks again,
Paul lol!

The actual route to the graphical repair is Not from the ‘Repair Installed System’ option when you first boot the DVD, you actually have to proceed as if for a New Install

All the way to Picture 5 in this:
11.2 Slideshow Images - Windows Live

At pic 5 select repair option

Hi caf4926,

Thanks for the info. I haven’t started the openSusie GRUB repair yet. By the time I installed all the apps needed on the XP OS it was late. I hate all the re-booting every time I install something new. If this was not a company laptop I would have never re-installed XP. My company would frown on that however. :\

I have been working today, but will repair the GRUB as soon as I complete my work today.

This sounds easy and I have the DVD install so this is perfect. I also saved the Grub Menu contents in Kate on a flash drive. So the repair should go very smoothly.

Thank you,
Paul :slight_smile:

If you have trouble with the DVD.

Here is another method:
Re-Install Grub Quickly with Parted Magic - openSUSE Forums

I’m having a similar problem with my migration to a new HDD. Windows was installed on the new HDD using the recovery CDs that came with my laptop. I then partitoned the remainder of the hdd up and copied (by cloning each to and image and then restoring) the openSUSE partitions from the old hdd to the new hdd.

So I basically have a booting XP system and and installed but non booting oS system. I now need to get grub re-installed so I get the option to choose os when booting. I tried repair the boot loader by going to the repair installtion on the 11.2 DVD but it is not working. I get an error saying

An error occured during bootlader installation.

Re-Install Grub Quickly with Parted Magic - openSUSE Forums

Ok, I tried that method and grub now displays on boot but trying to boot oS gives the following error.

Booting SUSE Linux
root (hd0,2)
Filesystem type is ext2fs, partiton type 0x83
kernel /vmlinuz- root=/dev/disk/my disk id-part5 resume=/dev/disk/my disk id-part6 splash=silent quiet showopts
[Linux-bzImage, setup=0x3c00, size=0x3e4c80]
initrd /initrd

Error 15: File not found

Press any key to continue…
Pressing any key just loops back to grub and the same error.

Is the error telling me that initrd does not exist or cannot be found? If so how can I get it back?

You probably have your HD boot order mixed up

Notice the menu from your suse install thinks it’s at root (hd0,2)

So is your suse HD seen as hd0

what is fdisk -l showing

Here is fdisk -l

root@sysresccd /root % fdisk /dev/sda -l

Disk /dev/sda: 250.0 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xcccdcccd

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1       16573   133122591    7  HPFS/NTFS
/dev/sda2           29777       30401     5019840    c  W95 FAT32 (LBA)
Partition 2 does not end on cylinder boundary.
/dev/sda3   *       16574       16604      249007+  83  Linux
/dev/sda4           16605       29776   105804090    f  W95 Ext'd (LBA)
/dev/sda5           16605       19214    20964793+  83  Linux
/dev/sda6           19215       19475     2096451   82  Linux swap / Solaris
/dev/sda7           19476       23939    35857048+  83  Linux
/dev/sda8           23940       29776    46885671   83  Linux

Partition table entries are not in disk order

In the above the partitons are as follows:
sda1 is my XP partion
sda2 is the Thinkpad recovery partition.
sda3 is /boot
sda5 is /

Here is the menu.lst

# Modified by YaST2. Last modification on Fri Mar 12 10:37:49 GMT 2010
# Configure custom boot parameters for updated kernels in /etc/sysconfig/bootloader

default 0
timeout 8
##YaST - generic_mbr
gfxmenu (hd0,2)/message
##YaST - activate

###Don't change this comment - YaST2 identifier: Original name: linux###
    root (hd0,2)
    kernel /vmlinuz- root=/dev/disk/by-id/ata-Hitachi_HTS542525K9SA00_071007BB0F00WDGAHZXA-part5 resume=/dev/disk/by-id/ata-Hitachi_HTS542525K9SA00_071007BB0F00WDGAHZXA-part6 splash=silent quiet showopts
    initrd /initrd

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- SUSE LINUX 
    root (hd0,2)
    kernel /vmlinuz- root=/dev/disk/by-id/ata-Hitachi_HTS542525K9SA00_071007BB0F00WDGAHZXA-part5 showopts apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 x11failsafe
    initrd /initrd

Here is device.map

(hd0)    /dev/disk/by-id/ata-Hitachi_HTS542525K9SA00_071007BB0F00WDGAHZXA

Where is menu.lst placed?
Look at sda3 and sda5 and check for /boot/grub/menu.lst

I don’t use a separate /boot partition, it tends to cause confusion

menu.lst is placed in /dev/sda3/grub/

Running find /boot/grub/menu.lst shows (hd0,2)

I’ve spent so much time on this that I think I’m just going to bite the bullet and re-install oS from scratch.

If I do a clean installtion of oS so it’s dual booting properly, can I then just dd the old hdd partitons over the top leaving the /boot partition alone on the new hdd? I’ll obviously have to change the fstab so it matches the new disk.

Personally I would scrap the /boot
Do some resizing to take up the space it frees up and just have

Ok, I’ll try that.

You know you can put the boot flag on the extended and boot from the root partition.

Look at my fdisk:

Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1        7600    61046968+   7  HPFS/NTFS
/dev/sda2            7601        7982     3068415   82  Linux swap / Solaris
/dev/sda3   *        7983       30401   180080617+   5  Extended
/dev/sda5            7983       10532    20482843+  83  Linux
/dev/sda6           10533       19456    71681998+  83  Linux
/dev/sda7           19457       30401    87915681   83  Linux

Ok, I finely got it working. It turned out the the symbolic links for vmlinuz and initrd were incorrect. Once I recreated them grub booted oS fine.

Thanks for filling us in:)