Xorg + Plasma high CPU usage.

I am having an issue with KDE4 where Xorg and Plasma are both eating up the CPU. They are both together eating up average 40-50%, so combine my CPU is maxed out. I have no clue to why or what occured to have caused this as there have been no changes to the system the past few days prior. This issue is isolated to just my one account. If I log into another account it runs fine.This is isolated just to my account under KDE, Gnome runs fine.

So I imagine there must be some file or config screwed up or missing in my profile folder. Where should I begin to look?

Log files by the way show nothing of interest, or out of the ordinary I should say.

Things I’d have a look at are:

Plasmoids. Are you running any, some of them have ‘issues’. I believe YaWP (yet another weather plasmoid) did this. Try removing them & see what happens to cpu usage. The bubble monitor plasmoids were a bit hungry (for me anyway) as well.

vsync for desktop effects. For some reason this got turned on for me (don’t know how or why really). It’s in the advanced tab where you configure the desktop effects. Turning this option OFF took my cpu usage from ~50% to ~7% (plasma & xorg were eating a whole core!)


I am seeing high CPU usage (99%) after the machine is brought back from being locked overnight… I am only running one plasmoid - stdin, which isnt set to update update. It only runs once and stays static. For some reason if I lock my screen and unlock it the next day, I will see the cpu at 99% for plasma-desktop. I can logout and back in and it will be back to the 20-30% range…

OS: Linux i686
Current user: monty@groucho
System: openSUSE 11.1 (i586)
KDE: 4.2.90 (KDE 4.2.90 (KDE 4.3 Beta2)) “release 138”

You nailed the issue… I have been noticing some issues (plasma desktop crashing overnight)… it was determined to be the stdin plasmoid… I had been running two instances of the plasmoid - one that ran a command and updated every 30 seconds… the other one just ran once and never updated again… The overnight crashes were determined to be the stdin plasmoid… I removed the updating instance, but left the static instance… I havent had the crashes anymore… but occasionally I have seen the high cpu issue reported here… I closed the one remaining stding plasmoid instance and voila! the cpu usage came down to normal…

I hope this info helps anyone else seeing high cpu usage from plasma-desktop

I don’t mean to bump this, but this thread is the first google result for “plasma-desktop xorg cpu”

I found in debian sid that just having big scaled shortcut icons on your plasma desktop can chew up 100% of a core. Remove those plasmoids and it drops back to 0-1%

again sorry for bumping


I have the same problem. Plasma-desktop takes almost 60 % and Xorg takes almost 50 % (because I have core2duo). I have removed all plasmoids and nothing has happened. Please where is the problem?

Thank you for your hints.

Xorg.log.* are fine, no errors, just missing some fonts. After I log out of system every think turn to be allright.

This thread is even the first google result for “plasma-desktop cpu” :slight_smile:
For me the high CPU usage disappeared, after I changed in my “Desktop Settings” under “Activity” from “Type: Folder View” to “Type: Desktop” and back.

have been having this issue, but notice it is made worst when i run the spideroak backup program, as soon as i exit this, then cpu usage goes from 45-50% down to 1-2%, anyone else that has spideroak have this problem?

maybe nepomuk and strigi. try disable desktop index or endure the lag for a full indexing. then it’ll rarely lag.

If you found out which plasmoid is buggy you should report it at bugs.kde.org in order to get it fixed.

Thank You!
Turning OFF vsync instantly made my laptop feel like a Pentium again, where it was starting to feel like I was on a i386… Between Xorg and FF, I couldn’t get any code written and uploaded… forget any streaming media.

Again, Thanks.

ey dude:

Old Threads/“Necro-Bumping”

Do your part to keep the forums tidy. Posting in old threads, or “necrobumping” is generally discouraged in the technical issue subforums, since it can potentially create disjointed “zombie” information; outdated posts with data which is no longer relevant due to rolling nature, combined with more recent posts reflecting more current circumstance. Furthermore, technical support threads should remain succinct, and multiple pages are to be avoided if possible.
Rules of thumb

  • If you have a question, start a new thread and link to the old if relevant.
  • If you have something to add and judge that your information is related, but more up-to-date, start a new thread and link to the old if desired, but avoid duplicating effort by posting information already contained in the Arch wiki.
  • If you have a version-agnostic or corresponding solution, necrobumping can be appropriate.



****26-May-2009, 12:03

Running Suse 12.3 on a 2006 dual cpu IBM Thinkpad. Plasma-desktop was maxing out one of the CPUs and locking up the system. I disabled Vsync and the problem seems to have been resolved.