XORG - help plz!

hello - i dunno if this is the place for this, but i’m desperte.
i’ve got opensuse 11.3 installed on my laptop (hp tx2620) which has ati radeon hd card.
i’ve managed to install ATI drivers with no problem.

there was update of xorg in the automatic updates, and i didn’t think it will cause troubles.

but after rebooting - it won’t work.
if i start the computer in normal mode, i get black screen.
and if i start in fail-safe mode - after i login to my system (entering password in login screen) i get white screen with the mouse - but that it.

help - what can i do???


An xorg update will occassionally break the proprietary driver.

There is a troubleshooting guide here: SDB:ATI troubleshooting - openSUSE

I’ve never had to follow this guide, so I can not provide a recommendation as to whether it is good or not good.

If the guide does not help, then I believe you need to remove the old fglrx rpms and then rebuild the driver and reload the fglrx rpms.

To find what fglrx rpms are installed, type:

rpm -qa '*fglrx*

and then remove those rpms.

One way to remove is the command (run with root permissions):

rpm -e $(rpm -qa | grep fglrx)

then after those are removed, assuming you have kernel-source and kernel-syms, and the base development pattern installed (with gcc, make) you can then rebuild the proprietary driver (ie install ‘the hardway’ as it is often called, although it is not hard).

i managed to fix it - like this:

i got into console with ctrl+alt+f4, and then uninstalled fglrx using the /usr/share/lib/fglrx-uninstall.sh, and then i ran again the ati drivers i had, and it fixed it.

thank you very very much for helping me on this :slight_smile:

Congratulations. I am glad to read you have repaired this.

Thankyou for sharing your solution.