xorg.conf apparently not read during boot on 11.3

Hi everyone,

I installed 11.3 several weeks ago, and because I use a KVM switch to go to a second computer I also created an xorg.conf and EDID file using nvidia-settings and a direct video connection (no KVM switch). I also forced the resolution and refresh rate by specifying it in nvidia-settings to the xorg.conf file, that is, no automatic stuff. This worked fine and I could switch between computers while maintaining my video resolution, etc. This was with an older CRT type of monitor.

But I updated my monitor last night to a new NEC PA261W. The new monitor works great if I connect it directly to the video card (nvidia GTX 275; 1920 x 1200 resolution). I made a new xorg.conf and EDID file as before, but now when I switch the video with the KVM switch the resolution reverts to a default 1024 x 768 . . . which doesn’t look very good at all!

When my new monitor is connected directly the var/log/xorg.0.log looks like this (a snippet):

22.711] (--) NVIDIA(0): Connected display device(s) on GeForce GTX 275 at PCI:10:0:0:
22.711] (--) NVIDIA(0):     NEC PA241W (CRT-0)
22.711] (--) NVIDIA(0): NEC PA241W (CRT-0): 400.0 MHz maximum pixel clock
22.774] (II) NVIDIA(0): Assigned Display Device: CRT-0
22.774] (II) NVIDIA(0): Validated modes:
22.774] (II) NVIDIA(0):     "1920x1200_60+0+0"
22.774] (II) NVIDIA(0): Virtual screen size determined to be 1920 x 1200
22.801] (--) NVIDIA(0): DPI set to (93, 95); computed from "UseEdidDpi" X config
22.801] (--) NVIDIA(0):     option

But when I go through the KVM switch it looks like this (snippet again):

22.620] (--) NVIDIA(0): Connected display device(s) on GeForce GTX 275 at PCI:10:0:0:
22.620] (--) NVIDIA(0):     CRT-0
22.620] (--) NVIDIA(0): CRT-0: 400.0 MHz maximum pixel clock
22.714] (II) NVIDIA(0): Assigned Display Device: CRT-0
22.714] (WW) NVIDIA(0): No valid modes for "1920x1200_60+0+0"; removing.
22.714] (WW) NVIDIA(0): 
22.714] (WW) NVIDIA(0): Unable to validate any modes; falling back to the default mode
22.714] (WW) NVIDIA(0):     "nvidia-auto-select".
22.714] (WW) NVIDIA(0): 
22.714] (II) NVIDIA(0): Validated modes:
22.714] (II) NVIDIA(0):     "nvidia-auto-select"
22.714] (II) NVIDIA(0): Virtual screen size determined to be 1024 x 768
22.740] (WW) NVIDIA(0): Unable to get display device CRT-0's EDID; cannot compute DPI
22.740] (WW) NVIDIA(0):     from CRT-0's EDID.
22.740] (==) NVIDIA(0): DPI set to (75, 75); computed from built-in default

I also tried booting with nomodeset, but this made no difference.

I am definitely a newby, but this looks like xorg.conf and the edid file are not being read on bootup to me. Which brings up the question of why the old monitor worked, because before I made the xorg.conf file in 11.2 it definitely didn’t. Unless, something in 11.3 handled my old monitor without the xorg.conf file, but can’t with the new monitor.

I’m at a loss here, does anyone have any ideas?

Thanks for your help!