Xonar DG not detected?

It seems my Xonar soundcard is not detected by Suse, is there anything I can do about this? :expressionless:

Hello Happycats,

I see this is your first post here, thus welcome!

People here like to get as much information as possible to be able to provide anwers as good as possible. Please the least information you could give is what openSUSE level you are using. For many problems (maybe not this one, but you never know), it is also important to tell which desktop you are using (KDE, Gnome, different).

Also telling thing like “it seems…” is not very informative. I guess that your guess is based on much harder information, like “I went into YaST > Hardware > Sound and I did not see any sound devices there”, or whatever brought you to the idea. Allways remind that here are many ways to do things in Linux and that we are not looking over your shoulder, nor is anyone here clairvoyant (not that I know :wink: ).

I am sorry, I am using KDE, I did look into hardware and then sound within Yast and could not find any of the Xonar cards including the DG which is the one I own. Not sure where to go from here, it detects my onboard sound but I much rather use my sound card.

xonar cards are always IMHO more difficult for our users to configure given the number of posts asking for help on such devices. I recommend you do a search through our forum for the keyword ‘xonar’ to see if you can learn anything there.

For me to provide assistance, I typically need the output requested to be provided in our multimedia stickie (which I hope you read): Welcome to multimedia sub-area

I’ll quote the salient part for you:


and select the SHARE/UPLOAD option and after the script finishes it will give you a URL to pass to the support personnel. Please post here the output URL/website-address that gives. Just the URL/website-address. You may need to run that script twice (the first time with root permissions to update in the /usr/sbin directory, and the second time to get the URL).
Note if for some reason that gives you no website/url/address then run it with the no-upload option:

/usr/sbin/alsa-info.sh --no-upload

and post the file /etc/alsa-info.txt it creates to Pastebin.comand press SUBMIT on that site and again post here the URL/website-address it provides.

… some clarification on running the script “alsa-info.sh” … when you run:


you should get something like this (if it asks for an update, select NO):

followed by this (select the SHARE/UPLOAD option):

followed by this (its quickest if you simply select ‘NO’ to seeing the output - you will see it on the web page) :

followed by this (where in RED is the URL).

Just post the URL you get (similar to the RED URL in my example, but yours will be different).

Again, if you can not get that, then run this with the no upload option:

/usr/sbin/alsa-info.sh --no-upload
which will create the file /tmp/alsa-info.txt. Copy that file and paste it on [Pastebin.com](http://pastebin.com) and press submit. That will give you a URL address. Please post that URL here.

Also provide the following:

  • in a terminal, or xterm, or konsole, type: rpm -qa ‘alsa#and post output here
  • in a terminal, or xterm, or konsole, type: rpm -qa ‘pulse#and post output here
  • in a terminal, or xterm, or konsole, type: rpm -q libasound2 #and post output here
  • in a terminal, or xterm, or konsole, type: uname -a #and post output here
  • for openSUSE-11.1 or earlier, in a terminal, or xterm, or konsole, type: cat /etc/modprobe.d/sound #and post output here
  • for openSUSE-11.2 or newer, in a terminal, or xterm, or konsole, type: cat /etc/modprobe.d/50-sound.conf #and post output here

For users whose PC has more than one sound device, and who are also using openSUSE-11.4, I recommend installing the application ‘pavucontrol’ (pulse audio volume control) and then while playing a multimeida application run ‘pauvcontrol’ in order to configure the output of the multimedia application to stream to the correct hardware device.

Installing this program will make my sound work? I am actually on the live CD right now trying to find an Linux OS that is simple to use and works with everything I have, this one seems like the best one I have come across yet…Just dont wanna install if its not gonna work in the long run.

No, installing ‘pavucontrol’ by itself will not ‘just make’ your sound work. BUT what it will do is provide you control over your sound devices so that YOU can tune them to work. With pulse audio volume control (pavucontrol) one can direct the sound from any media application(s) to any sound output device(s) (speakers). And one can direct the sound from any input sound device(s) (for example mic(s)) to any recording application(s). … It allows one to control the volume levels. To control the record levels. etc … BUT it does require a degree of familiarity with ‘pavucontrol’ which requires effort.

What is interesting is many users claim pulse audio simplifies things too much … yet other’s who struggle with pavucontrol complain pulse makes audio too complex.

As I learn more about pulse audio, I am beginning to appreciate and like it. BUT I note it (pulse) is NOT IMHO appropriate for older computers due to the over head it imparts.

Oh alright so I must first fix the sound issue, that program seems very nice though, my computer is up to date (8gbram,q6600,gtx460). Honestly I just want to try linux because I am tired of Windows to the point I would almost try anything else. I am gonna keep windows for games though…

Assuming your games are not ‘chess’ (whose graphics are not exactly demanding) that’s likely a good decision. You will find that the performance of manufacturer provided provided GNU/Linux graphic drivers SUBSTANTIALLY lag that of MS-Windows graphic drivers. (ie by 2x or 3x slower).

Haha yeah, I kinda figured, well enough for browsing and HD video I suppose though. I found this: Download - AlsaProject

It lists my sound card as working, I am a little bit confused on how to install it and what to install actually, there are a bunch of files here…Do I just need the driver? If so how does this install? Sorry if these questions seem dumb…

Your openSUSE install by default comes with the alsa sound driver ALREADY INSTALLED. You simply need to configure it.

If you need detailed help, then please provide the information I requested in post#4 above.