Xlink kai and openSUSE x64

Hi guys.
So decided to try linux. I wanna try and learn it.

There’s this program i’d like to try and get working on linux.

Its called xlink kai. XLink Kai: Evolution VII. Global Network Gaming.

Kai downloads to x32 systems only.
But linux users have told me that it indeed does work.
Through the terminal i did a ldd kaiengine

The name of the program file is kaiengine
And it showed up with some packages that need to be installed.

A linux user told me to do the following

if you use ubuntu 32-bit, you install WxGTK libraries.

Code:
sudo apt-get install libwxbase2.8-0 libwxgtk2.8-0

if you use ubuntu 64-bit, you download 32-bit libraries, install it.

Code:
wget http://ubuntu-ashisuto.ubuntulinux.jp/ubuntu/pool/universe/w/wxwidgets2.8/libwxbase2.8-0_2.8.10.1-0ubuntu1_i386.deb
wget http://ubuntu-ashisuto.ubuntulinux.jp/ubuntu/pool/universe/w/wxwidgets2.8/libwxgtk2.8-0_2.8.10.1-0ubuntu1_i386.deb
wget http://ubuntu-ashisuto.ubuntulinux.jp/ubuntu/pool/universe/libp/libpcap/libpcap0.7_0.7.2-9_i386.deb
dpkg-deb -x libwxbase2.8-0_2.8.10.1-0ubuntu1_i386.deb .
dpkg-deb -x libwxgtk2.8-0_2.8.10.1-0ubuntu1_i386.deb .
dpkg-deb -x libpcap0.7_0.7.2-9_i386.deb .
sudo mv ./usr/lib/* /usr/lib3
2/

But sudo doesn’t work on opensuse terminals.
So which do i use?
i tried yast, but i’m not sure i got the command in properly.

Hope you can help! ty in advance :)!

Anyone? :frowning:

just wanna know how to install the packages…

I’ev tried searching for them through pack repositories on yast etc. but no luck.

sudo apt-get doesn’t seem to work. So was just wondering if there is another command i can run through the terminal.

You cannot install .deb packages on an .rpm based system just like that. You can try to use ‘alien’ to create rpms from the .deb. files.

Are you on a 64bit system? Then there’s extra trouble.

You download it and try installing it by running:

kaid

Post the error messages here so that we will try to help you.