x11vnc connection issues

Ive been working on getting my tumbleweed setup to work with x11vnc. The machine is my main desktop and I am generally using it locally but while I am away I want to connect to my existing kde session. On my prior suse versions I had always used x11vnc to accomplish this but I am running into issues with my new tumbleweed desktop. In the past I have ssh’d into my system, started a 1 time vnc session with the command below then tunnel the port to the machine im connecting from and use a vnc client. In the past this has worked great now it doesnt. You can see below. Is there a better recommended way to get VNC on an existing KDE desktop session, or am I still going down the correct route to use x11vnc in this fashion and just hitting some bug?


x11vnc -o ~/vncTestLog -usepw -ncache -noxdamage -bg -auth $(xauth info |grep Authority | cut -d ":" -f 2| tr -d " ") -display :0

I have tried multiple clients with varying expriences. Viangre to connect seems to control the remote system but I dont actually see the screen of my remote system with it. Remmina, tightvnc, etc… will connect and I can see the screen. But as soon as I interact in a way that changes a large part of the screen I get disconnected and cannot connect back in. Taking a look at the vnc logs I get the following error

*** rfbSendFramebufferUpdate FAILED #1

The log file from when the connection from the remote machine started

15/09/2022 21:54:24 Got connection from client ::1
15/09/2022 21:54:24   0 other clients
15/09/2022 21:54:24 Normal socket connection
15/09/2022 21:54:24 Disabled X server key autorepeat.
15/09/2022 21:54:24   to force back on run: 'xset r on' (3 times)
15/09/2022 21:54:24 incr accepted_client=1 for ::1:40110  sock=10
15/09/2022 21:54:24 Client Protocol Version 3.8
15/09/2022 21:54:24 Protocol version sent 3.8, using 3.8
15/09/2022 21:54:24 Send channel security type 'none'
15/09/2022 21:54:24 rfbProcessClientSecurityType: executing handler for type 2
15/09/2022 21:54:24 copy_tiles: allocating first_line at size 241
15/09/2022 21:54:30 Pixel format for client ::1:
15/09/2022 21:54:30   32 bpp, depth 24, little endian
15/09/2022 21:54:30   true colour: max r 255 g 255 b 255, shift r 16 g 8 b 0
15/09/2022 21:54:30 no translation needed
15/09/2022 21:54:30 Using compression level 1 for client ::1
15/09/2022 21:54:30 Enabling X-style cursor updates for client ::1
15/09/2022 21:54:30 Enabling full-color cursor updates for client ::1
15/09/2022 21:54:30 Enabling cursor position updates for client ::1
15/09/2022 21:54:30 Enabling KeyboardLedState protocol extension for client ::1
15/09/2022 21:54:30 Enabling NewFBSize protocol extension for client ::1
15/09/2022 21:54:30 Enabling SupportedMessages protocol extension for client ::1
15/09/2022 21:54:30 Enabling SupportedEncodings protocol extension for client ::1
15/09/2022 21:54:30 Enabling ServerIdentity protocol extension for client ::1
15/09/2022 21:54:30 Using zlib encoding for client ::1
15/09/2022 21:54:34 client_set_net: ::1  0.0000
15/09/2022 21:54:34 set_ncache_xrootpmap: trying root background
15/09/2022 21:54:34 snapshotting background...
15/09/2022 21:54:34 done.
15/09/2022 21:54:34 created selwin: 0x1b000f6
15/09/2022 21:54:34 called initialize_xfixes()
*** rfbSendFramebufferUpdate *FAILED* #1

Added the following options to my command based on looking at some examples found, the combination of adding the 3 seems to have fixed my issue. I tried various combinations which all seemed to lead to the crashing I noted above. So I will call it a win that I got it working and post my command incase other people have the same issue.


x11vnc -o ~/vncTestLog -xkb -noxrecord -noxfixes -usepw -ncache -noxdamage -bg -auth $(xauth info |grep Authority | cut -d ":"
 -f 2| tr -d " ") -display :0

The options added were

-xkb, -noxkb
When in modtweak mode, use the XKEYBOARD extension (ifthe X display supports it) to do the modifier tweaking. This is powerful and should be tried if there are still keymapping problems when using -modtweak by itself. The default is to check whether some common keysyms, e.g. !, @, , are only accessible via -xkb mode and if so then automatically enable the mode. To disable this automatic detection use -noxkb.
-noxrecord
Disable any use of the RECORD extension. This iscurrently used by the -scrollcopyrect scheme and to monitor X server grabs.
-noxfixes
Do not use the XFIXES extension to draw the exact cursorshape even if it is available.Note: To work around a crash in Xorg 1.5 and latersome people needed to use -noxfixes. The Xorg crash occurred right after a Display Manager (e.g. GDM) login. Starting with x11vnc 0.9.9 it tries to automatically avoid using XFIXES until it is sure a window manager is running. See the -reopen option for more info and how to use X11VNC_AVOID_WINDOWS=never to disable it.

Hi baaldemon,
i had also no success with your command, but when i execute

export XAUTHORITY=$(echo /run/user/`id -u`/xauth_*)

at the server and then start your command it works for me.
Hope it helps

Greetings paulepank