X server problem : No Screens Detected

Dear All,
i am a linux newbie and this is my first time trying to install it on my laptop.

i have a SONY VAIO VGN-BX laptop that has an ATI RADEON MOBILITY 2300 HD.

when i installed suse 11 from the DVD, it displays a message saying that the xserver couldn’t be started and that no screens are detected.

kindly advise on how to rectify this problem.


Just to get started, from command line do

su (to become root)
sax2 -r (reprobe your video card)

Follow that process through. If all is well, try changing to runlevel 5 (with X-server and graphical desktop) with

init 5

If this doesn’t lead to a working xorg.conf, then try this

sax2 -r -m 0=vesa (basic vesa video driver)

Once you have a graphical environment, it will be easier to install any required drivers. Post again if you need further help with this.

thank you very much for your fast reply.

unfortunately , it is still not working

i logged in as root and typed

sx2 -r

it gave me the graphical interface for a second then disappeared again giving this message : SAX : no x-server running

i wrote again sax2 -r -m 0=vesa

gave me the same error message.

i would very much appreciate your help

NB : i tired installing dreamlinux (based on debian) and had the exact same problem

i installed fedora 9 and it worked smoothly

i just want to use opensuse not fedora :frowning:

Hmmm…usually sax gives this message: ‘SAX: no x-server is running SAX: will start own server if needed SAX’. You may have some key X packages missing. When you installed, did you choose ‘custom’? What desktop system (if any) did you choose?

Anyway, try the following first:

If nothing is able to start, try checking your current runlevel (as root) with


If you get ‘N 5’, change to runlevel 3 with

init 3

(This is equivalent to typing ‘3’ at the grub boot prompt). Then try issuing

sax2 (without any options)

If this fails, I would try using the install DVD to repair/reinstall the X-server. Select ‘Repair Installed System’. The automatic repair should take care of it.

it is still not working with opensSuse 11.0.

i just gave up and installed SLED 10 SP2 , it is working smoothly with the new ATI driver 8.8

thank you very much deano for your continuous support :slight_smile:

Also a newbie, I have a similar problem as puzzled, however; I keep creating new openSUSE cds and none (of the 4 made) give the option to repair my computer. The suse 10.3 offer the options
installation - no API
Boot from HArd Drive
Rescue System

and every 11.0 gives
Run OpenSUSE 11.0
Run opensuse 11.0 - safemode
Check Media
Memory Test

So do I have to keep burning new disks or should I choose another operating system?

> I keep creating new openSUSE cds and none (of the 4 made) give the
> option to repair my computer.

maybe it is only on the DVD…i don’t know (i’m still running 10.3)…

i DO know that many of the old timers around here recommend to
install from the DVD (not the CD, because it lacks so many

and, if you have not already, be sure and Before you install SuSE
11.0 read this:

see caveat: http://tinyurl.com/6aagco
DenverD (Linux Counter 282315) via NNTP, Thunderbird, KDE
3.5.7, SUSE Linux 10.3, #1 SMP i686 athlon