X server fatal errors

Hi everyone, I did a zypper dup recently and got some packages upgraded. I remember xorg was upgraded, some drivers, and some xfce packages.

Now, when I try to boot I get to lightdm and the login attempts are rejected. It’s like it tries to login but sends me back to login screen.

I tried to start xfce with startx, and got some fatal errors on X server, related to xfce-panel, xfsettingsd, xfce4-session, xfwm4…

The last error is

(Qt: Fatal) QxcbConnection: Could not connect to display :1.0

Any help would be appreciated to fix this.

Startx has been deprecated for a while (apart for root) and is npt expected to do anything useful.

Things to try (and report back on):
Openbox (Xfce is sort of an Openbox theme)
SDDM (the default lightweight desktop manager)
and most importantly

zypper lr -Eu

Thank you for your suggestions.

I re-installed openSUSE just a couple of days ago, to official repos I added packman and libdvdcss.

IceWM and Openbox start just fine.

I would try sddm as well, but it comes with plasma and I don’t want it for now.

Thanks again.

Was that re-installing and formatting partitions or keeping /home/username ?
If the latter try creating a new user to check whether the problem is with your user’s xfce configuration.

I did a clean install, having new partitions formatted.

Xfce stopped starting after yesterday’s upgrade. It did work 2 days ago.

A small comment…
AFAIK XFCE has never installed using lightdm by default (but who knows, I’m not in front of a LEAP 15 XFCE at the moment).
The Display Manager has always been gdm.

To inspect, verify and if you wish change (not recommended unless you know what you are doing…

To display the Display Manager

update-alternatives --config default-displaymanager

To display the Window Manager (but AFAIK changes have no effect, you can change only in login screen)

update-alternatives --config default-xsession.desktop

You cannot select lightdm unless you install it first.


Sorry, but I know that at least as far back as 42.1 (probably farther back), Xfce does automatically install LightDM and use it when the Xfce pattern is chosen, not GDM.:wink:

I have run into similar problems in a couple instances in the past. My solution was to install and switch to the KDM Display Manager. I suggest you try switching to XDM, and if that does not work, try installing and switching to KDM.

They usually work well in Xfce, though LightDM is a bit snappier (when it works).

Yeah, Xfce is installed with lightdm.

Nothing helped yet, don’t think it’s about the display manager (xdm doesn’t start it as well).

I tried to start Xfce with another user, still the same problem.

In .xsession-errors file I get multiple lines of Invalid MIT-MAGIC-COOKIE…

I renamed the .Xauthority file, still nothing.

I guess I will use i3 until I find a way to start xfce again.