X fails to start after latest kernel and nvidia update

Hi all,

My gf has an AlienWare with a GTX1080 that refused to startx lately. Sometimes it started, sometimes it didn’t. Work around was to start Linux without graphical mode by adding the 3 in the grub kernel line and then after login type startx. I was hoping new updates would resolve this.

Today the laptop received the latest kernel for Leap 15.1 and also the latest NVidia G05 driver 440.82-lp151.25.1

Now it refused to start xorg at all. I can’t get it to start. It gives the following errors:

xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error


Ofc this happens at the worst possible time, where the machine is used for a Python class based internet course :frowning:

The machine does have intel GPU on the CPU, but this can only turned on (as far as I know) via a DELL support tool on Windows, which is never ever touched except for Bios updates and AlienWare light changes. So the BIOS setting is still on NVIDIA.

I removed the NVIDIA driver and went with the opensource nouveau, this resulted with the same issue. Then I reinstalled NVIDIA and DMESG shows this, I think an extra problem:


Also, the xorg log file just shows the same error as in the first image in the first post.

With the opensource driver DMESG says:
“Failed to start a user Manager for UID 462”

Also in the sysconfig Editor under:

Desktop > Displaymanager > Displaymanager_xserver there used to be GDM.

For testing I changed it to xorg. Now after the reboot, GDM is gone from this list and xorg remains. Even after reinstallation of GDM.

Looks like you have a mix of NVIDIA driver versions. It shows in the log that it expects some other version. How did you install the drivers? Did you reboot inbetween?

The drivers were installed and working until the update of today.

after that, all manual installations were followed with a reboot. Yet, removing Nvidia en using nouveau does result in the same xorg problem.

Must be from the .run from NVIDIA’s site. The 440.64 driver was not removed ( completely ), then the 440,82 version was installed but the mix won’t work,
Use the 440.64 .run with the uninstall option, the same for the 440,82 version. Then reinstall the 440.82 version.

If you do use an rpm package, please let know which

Ok tnx, I’ll let you know tomorrow morning.

If you sort out the double-driver issue, give this a try:

Also, when you get a chance, I recommend installing bumblebee and you may need cuda for later(non-manual install intro here: https://forums.opensuse.org/showthread.php/537906-Cuda-Nvidia-bumblebee-codecs-quot-safe-quot-way).

Looks like bumblebee may be on the way out (looking for a maintainer and bug fixer)… have you tried prime? I use DRI_PRIME=1 and switcheroo-control with my dual AMD gpu’s.

See [opensuse-factory] Bumblebee up for grabs - openSUSE Factory - openSUSE Mailing Lists

That is new to me. I guess it’ll be a while before optimus support for OpenSUSE for a while. At least for Kernel 4.12 series, everything seems to work for me anyways. Not so much for 5.3+

So I downloaded the second latest drivers and installed it. Everything works. Then I used the NVIDIA-uninstall to remove the driver. I then installed the latest via YaST, and again the same problem.

It keeps referring to a kernel version of the previous driver version.

I would say the package is broken or something.

This is NOT an Optimus laptop. You can’t switch graphic cards while its running. It’s a BIOS setting and a reboot is required. So with NVIDIA on the system doesn’t know there also is an Intel GPU. So no Optimus/bumblebee issues. This is purely a driver issue I think.

So the old driver is the run file from NVIDIA site, the new driver is from the Suse repo.

I didn’t know they made new laptops like that. I guess it’s good for a powerhouse laptops. My 2015 alienware still has optimus. I am not saying that this is an optimus/bumblebee issue but libxorg requirement for Nvidia is not compatible with standard libxorg for Opensuse kernel directly.

If you use the Yast/zypper to install the drivers (OpenSUSE repo), you have to use the corresponding kernel version. If you manually install the driver (Nvidia website, not OpenSUSE’s “nvidia” repo), you should be able to re-compile whichever kernel version you’re using.

But now, still don’t understand why the new drivers in the repo won’t work.

I have another laptop like this, I don’t want to update atm :smiley:

Well, that’s really because it’s up to the maintainers of the repos and your card. I personally have been piggy-backing off of the support of bumblebee and cuda. If you really want, you could try to use the Nvidia’s repository for cuda (https://developer.nvidia.com/cuda-downloads?target_os=Linux&target_arch=x86_64&target_distro=OpenSUSE&target_version=15&target_type=rpmnetwork).

For my desktop with an Nvidia card, I get my drivers for my GTX1070Ti for OpenSUSE through the Nvidia’s cuda-repository. They make sure the driver and toolkit is compatible with OpenSUSE kernels but I wonder what will happen when we go to LEAP 15.2 and the ne kernel 5.3+, I haven’t tested that.

You need to uninstall the .run driver using it’s .run version. Then force a reinstall from the packages. Do not use both at the same time. It’s either the .run, or the packages. Nasty thing is, that it may work as long as the .run and the rpm package use the same NVIDIA version, but, like you experience, not if those differ.

For me I just use the run files, CUDA without installing driver and then cuDNN files are a manual copy… :wink:

Spoiler alert for your Nvidia adventure with the new kernel 5.6 :wink: (https://forums.opensuse.org/showthread.php/539756-5-6-0-Kernel-release-20200401-and-Nvidia-propriatary-driver/page4). Often I struggle to keep codecs + cuda + driver + kernel + some proprietary software compatible at each update and manual installation is something I want to try to avoid at least until I have more free time.

That is what I did. Used the .run uninstaller and after that I did a search on the system for any leftovers of the NVIDIA driver. Found nothing and installed the RPM from the repo and it still fails.