X bug? When using XDMCP the login works but desktop is never shown

(if you want to talk about how insecure XDMCP is or recomend me VNC please dont bother to read further)

I am having a strange problem when connecting to OpenSuse 11.4 host with KDE desktop over XDMCP using xming, X-Win32 or NX.

The login screen is shown and i can enter username/password, but when the login starts, the progress bar goes to the end
and then various outputs come out: nothing changes, the screen stays (background + progress bar at end) or the parts of
desktop are shown but they dont respond to keyboard or mouse.

Actually once (in 100 tries) the desktop got loaded and it was functioning.

There is nothing wrong with the network connection, also the xming works on other distributions.

Hm, you say that once in a 100 (respect for your endurance) it works OK. Seems like one of those intermittent problems which are very difficult to pin dfown (as you are of course aware of). To get some more insight:

. In the cases it fails, does this allways show exactly the same situation when things stop or is the intermittancy also there in that it does different on every trial?

. In the only case you got a complete desktop, did it function as intended then or got you stuck when doing things in the desktop (like starting an application).

Edit: rereading your post, I think my first question is allreay answered there. I would category this as “loose connector” if you see what I mean. But very difficult to find. Did you check the connection for excessive errors?

  1. Well to me it looks like it is always the same situation but the refresh of the screen is sent at different times to the xserver. I have just tested it a little further, started the xming with -swcursor (Disable the usage of the Windows cursor and use the X11 soft-ware cursor instead) and the cursor is moving, am am not familiar with how X work internally but it looks to me that eiter the clicks are not accepted…
  2. Unfortunally this was after updating the opensuse and I have thought it was a bug fixed with update and i didnt do any testing.

Do you maybe know if there is some way to raise the logging level for Xorg log on xdmcp sessions?

(it is not network, i have verified it twice)

Endurance: i am one of those unlucky persons which are trying to like the linux since 2001 and always give up as something critical which i want to use doesnt work and it involves far too much backround knowlidge to fix it. I periodically install the various distributions and check them for workstation usage (c/c++ developer and unfortunally i cant decide which OS to support and which not). I was quite surprised that i didnt need to dig through n config files to enable XDMCP but at the end… well another nasty surprise for me :sarcastic:

You do not tell much about the system(s) where the X-servers are running (you named xming, X-Win32 and NX). I have only some experience where the X-server system also runs Linux and thus the standard Xorg server. What sort of systems are they, didn’t something change there?

You say you updated openSUSE, but you do not tell from what to what. My idea is that you should tell more details about your environment and way of working for people here to get a bit of a feeling about what your situation is.

What do you mean by using NX? Do you have a NX server running on openSUSE?

FreeNX (0.7.3) available in my repo works with XDMCP. Version 0.7.2 gave me a black screen. Nomachine NX works. There is a noticeable difference however between FreeNX and NX when connecting with “Unix : XDM” Desktop settings from a NX client (like the Nomachine one). NX displays the xdm/gdm/kdm login screen while FreeNX skips the greeter and starts the desktop stored in the WINDOW_MANAGER environment variable. I just checked both FreeNX and Nomachine servers on 11.4. They both work fine here. The server is up to date.

Actually, the easiest way to check if/how the XDMCP server is responding is to do an X query to it:

X -query <server>

It should start an X session.

Depending on the server configuration, you might have to specify from which client:

X -query <server> -from <client>

Use hostnames or ips for server and client.

NX doesn’t use XDMCP. When I metioned XDMCP, I actually meant the login manager (XDM). The NX server doesn’t need XDM/GDM/KDM but will use it if it’s running.

Ok about details, maybe i should mention it before, its ESX…

22.269] (**) ImPS/2 Generic Wheel Mouse: Device: "/dev/input/mouse0"
22.273] (EE) ioctl EVIOCGNAME failed: Inappropriate ioctl for device

** 22.281] (II) UnloadModule: “evdev”**
22.281] (EE) PreInit returned NULL for “ImPS/2 Generic Wheel Mouse”

Heh, icewm works with XDMCP… bug in KDE.

I don’t think so. KDE login works for me (as well as Gnome, icewm or others) with X -query on 11.4 servers running either xdm, gdm or kdm. There must be a problem with your KDE installation. Maybe you should check the files in /usr/share/xsessions - How does kde.desktop look like? - and make sure that xdmcp is enabled in the login manager you’re using. I don’t think it is enabled by default.

If you’re talking about FreeNX (0.7.2), a black screen in KDE login wouldn’t surprise me. Try version 0.7.3 (from my repo)!

Here are my logs.

After the last entry…:

Xlib: extension “VMWARE_CTRL” missing on display

… everything hangs untill i close xming.

I wasn’t talking about vmware and xming (that I never used), just saying that “regular” XDMCP login has no problem with KDE. I can not help with vmware.

Ok, i have tryed 32 bit, 64 bit, KDE, XFCE, IceWM, results:
32 or 64 bit KDE and XFCE fail to show the desktop
IceWM works in all cases.

I have decided to kick the **** linux and wait a few more years again…